Results 1 to 3 of 3

Thread: metasploit is not working

  1. #1
    Just burned his ISO
    Join Date
    Aug 2010
    Posts
    6

    Unhappy metasploit is not working

    when i try to run enum module or msssql_exec sometimes error message occurs and other time it says module executed ..,but nothing happens..here is my console view

    msf auxiliary(mssql_enum) > show options

    Module options:

    Name Current Setting Required Description
    ---- --------------- -------- -----------
    PASSWORD no The password for the specified username
    RHOST 192.168.1.3 yes The target address
    RPORT 1433 yes The target port
    USERNAME sa no The username to authenticate as

    msf auxiliary(mssql_enum) > set MSSQL_USER sa
    MSSQL_USER => sa
    msf auxiliary(mssql_enum) > set MSSQL_PASS password1
    MSSQL_PASS => password1
    msf auxiliary(mssql_enum) > set RHOST 192.168.1.3
    RHOST => 192.168.1.3
    msf auxiliary(mssql_enum) > run[*] Running MS SQL Server Enumeration...[*] Auxiliary module execution completed
    msf auxiliary(mssql_enum) > set MSSQL_PASS password1
    MSSQL_PASS => password1
    msf auxiliary(mssql_enum) > run[*] Running MS SQL Server Enumeration...[*] Auxiliary module execution completed
    msf auxiliary(mssql_enum) >

    see nothing happens ,

    but i can see that

    " HEX2BINARY /pentest/exploits/framework3/data/exploits/mssql/h2b no The path to the hex2binary script on the disk "

    is not there in the showed options ,someone plz help me to

    install this HEX2BINARY script on the disk ... or plz explain what is the issue actually whether HEX2BINARY or something else ..thanks in advance

  2. #2
    Good friend of the forums espreto's Avatar
    Join Date
    Mar 2010
    Location
    Brazil
    Posts
    303

    Default Re: metasploit is not working

    What the revision?

    Update!
    Code:
    root@bt:~# svn update /pentest/exploits/framework3/
    Hunting for MSSQL

    Regards,
    (gdb) disass m(y_br)ain

    «

  3. #3
    Just burned his ISO
    Join Date
    Aug 2010
    Posts
    6

    Default Re: metasploit is not working

    thanks a lot for answering mate .. i tried svn update but its not working , the module executes but enumerates nothing ..., i found a working modules options in a tutorial which is like this ....

    Basic options:
    Name Current Setting Required Description
    ---- --------------- -------- -----------
    HEX2BINARY /home/carlos/framework3/trunk/data/exploits/mssql/h2b no The path to the hex2binary script on the disk
    MSSQL_PASS no The password for the specified username
    MSSQL_USER sa no The username to authenticate as
    RHOST yes The target address
    RPORT 1433 yes The target port

    and mine is like this

    msf auxiliary(mssql_enum) > show options

    Module options:

    Name Current Setting Required Description
    ---- --------------- -------- -----------
    PASSWORD no The password for the specified username
    RHOST 192.168.1.3 yes The target address
    RPORT 1433 yes The target port
    USERNAME sa no The username to authenticate as

    it is obvious tht i'm missing something called "HEX2BINARY" in my disk when compared with that working module ... so plz help me to solve the problem ..thanks in advance

Similar Threads

  1. [metasploit] - MetaSploit nao atualiza
    By warlockthefeared in forum Suporte Software
    Replies: 38
    Last Post: 03-09-2011, 11:52 AM
  2. Replies: 1
    Last Post: 07-26-2010, 10:59 PM
  3. DNS Spoofing is working/working not!
    By htons139 in forum Beginners Forum
    Replies: 3
    Last Post: 05-19-2010, 08:20 PM
  4. metasploit o non metasploit, questo Ŕ il problema!
    By eqweo in forum Discussioni Generali
    Replies: 2
    Last Post: 01-14-2010, 12:16 AM
  5. Belkin F5D7050e - Confirmed working/Not working?
    By Beanz in forum OLD Newbie Area
    Replies: 1
    Last Post: 12-07-2008, 06:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •