Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Carwhisperer help...

  1. #1
    Junior Member nightlybuild's Avatar
    Join Date
    Feb 2010
    Location
    InYourBucci/Chicago
    Posts
    36

    Default Carwhisperer help...

    I need help running carwhisperer. I start my hci0 device and it gives me no errors. Then I try to run cw_scanner, but it just gives me an error "Cannot mkdir results: File exists at ./cw_scanner line 15." Could someone explain to me how I am supposed to use carwhisperer and why I am getting this error.
    Thanks!

    Edit: Has anyone got Carwhisperer working at all?
    Last edited by nightlybuild; 02-23-2010 at 10:43 PM.
    If you get tired of listening to your music... cat /vmlinuz > /dev/audio
    -_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_
    Macbook 2.4Ghz Dual Core, 4GB Ram, Edimax EW-7318USG, BT4

  2. #2
    Just burned his ISO
    Join Date
    Mar 2010
    Posts
    1

    Default Re: Carwhisperer help...

    I'm having some difficulties using the carwhisperer as well. As for your issue the cw_scanner is failing to make a directory. Are you logged in as root when you are running the cw_scanner script?

  3. #3
    Junior Member nightlybuild's Avatar
    Join Date
    Feb 2010
    Location
    InYourBucci/Chicago
    Posts
    36

    Default Re: Carwhisperer help...

    Quote Originally Posted by st0n3dg0rilla View Post
    I'm having some difficulties using the carwhisperer as well. As for your issue the cw_scanner is failing to make a directory. Are you logged in as root when you are running the cw_scanner script?
    Yes I am logged in as root. I'm not sure what is causing that error. Would anyone know why...is anybody getting this to work?
    If you get tired of listening to your music... cat /vmlinuz > /dev/audio
    -_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_
    Macbook 2.4Ghz Dual Core, 4GB Ram, Edimax EW-7318USG, BT4

  4. #4
    Very good friend of the forum Gitsnik's Avatar
    Join Date
    Jan 2010
    Location
    The Crystal Wind
    Posts
    851

    Default Re: Carwhisperer help...

    Quote Originally Posted by nightlybuild;
    "Cannot mkdir results: File exists at ./cw_scanner line 15."
    A basic grasp of linux and the command line in general would be infinitely useful to you here, but that should start you off somewhat.

    Admittedly, that seems to be poor coding on the carwhisperer's programmers behalf, but I don't know who it is and I haven't actually read the code to see what is going on there - it might be intentionally n00b pr00fing the system. Anyway, get back to us and see if you can figure it out.
    Still not underestimating the power...

    There is no such thing as bad information - There is truth in the data, so you sift it all, even the crap stuff.

  5. #5
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default Re: Carwhisperer help...

    One might also try looking on google with the error message as well as the developer website.

  6. #6
    Junior Member nightlybuild's Avatar
    Join Date
    Feb 2010
    Location
    InYourBucci/Chicago
    Posts
    36

    Default Re: Carwhisperer help...

    Quote Originally Posted by Archangel.Amael View Post
    One might also try looking on google with the error message as well as the developer website.
    I've tried google and developer's website. Yesterday I even sent them an email hoping to get an answer. I don't get it...does this work for other people? Why would it come with Backtrack if it doesn't work.
    If you get tired of listening to your music... cat /vmlinuz > /dev/audio
    -_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_
    Macbook 2.4Ghz Dual Core, 4GB Ram, Edimax EW-7318USG, BT4

  7. #7
    Very good friend of the forum Gitsnik's Avatar
    Join Date
    Jan 2010
    Location
    The Crystal Wind
    Posts
    851

    Default Re: Carwhisperer help...

    Quote Originally Posted by nightlybuild View Post
    I've tried google and developer's website. Yesterday I even sent them an email hoping to get an answer. I don't get it...does this work for other people? Why would it come with Backtrack if it doesn't work.
    A little work is in order on your behalf. Perhaps trying what I suggested in the first place and learning the basics so that the error message makes more sense.
    Still not underestimating the power...

    There is no such thing as bad information - There is truth in the data, so you sift it all, even the crap stuff.

  8. #8
    Junior Member nightlybuild's Avatar
    Join Date
    Feb 2010
    Location
    InYourBucci/Chicago
    Posts
    36

    Default Re: Carwhisperer help...

    I think that I may have got it working. But I can't be too sure because I don't have a car with bluetooth at this time, might go to my cousin's house and try it out. I had to delete the "results" folder. Or just comment out that line that always makes the directory at line 15 of the script. All I get now is the curser moving down about every 10 seconds. I'm guessing that it's scanning. I'll let you guys know if I get it working on a car.
    If you get tired of listening to your music... cat /vmlinuz > /dev/audio
    -_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_
    Macbook 2.4Ghz Dual Core, 4GB Ram, Edimax EW-7318USG, BT4

  9. #9
    My life is this forum Barry's Avatar
    Join Date
    Jan 2010
    Posts
    3,817

    Default Re: Carwhisperer help...

    Quote Originally Posted by nightlybuild View Post
    I think that I may have got it working. But I can't be too sure because I don't have a car with bluetooth at this time, might go to my cousin's house and try it out. I had to delete the "results" folder. Or just comment out that line that always makes the directory at line 15 of the script. All I get now is the curser moving down about every 10 seconds. I'm guessing that it's scanning. I'll let you guys know if I get it working on a car.
    If you have a bluetooth headset it works with those as well. Basically it will work with anything that has a default passcode of 0000 or 1234, which is damn near everything....

  10. #10
    Junior Member nightlybuild's Avatar
    Join Date
    Feb 2010
    Location
    InYourBucci/Chicago
    Posts
    36

    Default Re: Carwhisperer help...

    Quote Originally Posted by Barry View Post
    If you have a bluetooth headset it works with those as well. Basically it will work with anything that has a default passcode of 0000 or 1234, which is damn near everything....
    I just tried it with a bluetooth headset. The scan lists the MAC address of the device, but the next line says "Can't open input file!: No such file or directory"
    So I got past one obstacle, but now I have another...I'll see what I can do, any suggestions?

    Also, in the results directory it makes a file for every line that shows up in the scan it goes: "1.log 1.raw 2.log 2.raw" and so on...the log files only list the MAC address and the raw files don't have anything in them.
    If you get tired of listening to your music... cat /vmlinuz > /dev/audio
    -_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_
    Macbook 2.4Ghz Dual Core, 4GB Ram, Edimax EW-7318USG, BT4

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •