Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Bluesmash issues

  1. #1
    Member
    Join Date
    Jan 2010
    Posts
    102

    Default Bluesmash issues

    Hey guys, im trying to use bluesmash with my dongle & phone but im getting some issues.

    Code:
    root@bt:~# hciconfig
    hci0:   Type: USB
            BD Address: 00:15:83:17:C5:DB ACL MTU: 384:8 SCO MTU: 64:8
            UP RUNNING
            RX bytes:18154 acl:235 sco:0 events:712 errors:0
            TX bytes:104374 acl:377 sco:0 commands:282 errors:0
    When i try attacks im getting errors like
    Code:
    /dev/rfcomm0
    Code:
    sh: bluesnarfer: command not found
    and when an attack does go through, my phone beeps and asks for a code which i have never set or even no how to. Ive tried this a couple of times and it doesnt output any info for me?

    Code:
    root@bt:/pentest/bluetooth/bluesnarfer# ./bluesnarfer -C 1 -r 1-20 -b 00:1B:33:B9:F6:FA
    device name: Ben
    bluesnarfer: release rfcomm ok
    Also ive tried this to
    Code:
    Blue|Smash Frontline Bluetooth Sniffer
    Enter device name eg hci0.....:  hci0
    Use Timer ? y/n:  y
    Use Filter ? y/n:  n
    Ignore packet type? y/n:  n
    Ignore zero length packets? y/n:  y
    Own pin? y/n:  y
    Scanning for devices.......
    Blue|Smash found 00:1B:33:B9:F6:FA - Ben
    Enter the Master's MAC....:00:15:83:17:C5:DB
    Enter the Slaves's MAC....:00:1B:33:B9:F6:FA
    sh: csr_sniffer: command not found
    sh: csr_sniffer: command not found
    sh: csr_sniffer: command not found
    Launching Sniffer :p
    hcidump's log will be stored in 00:15:83:17:C5:DB@00:1B:33:B9:F6:FA.cap
    Can't open device: No such device
    csr_sniffer's log will be stored in 00:15:83:17:C5:DB@00:1B:33:B9:F6:FAraw.cap
    Starting Sniffer... Ctrl + c to exit.
    sh: csr_sniffer: command not found
    
    
       Error! Exiting Blue|Smash...

  2. #2
    Member
    Join Date
    Jan 2010
    Posts
    102

    Default Re: Bluesmash issues

    Bump... i need some sort of thread or post which gets people started, all the videos and information are scarce and very vague.

    There was a thread on the old remote exploit forums called "Ultimate Bluetooth thread" is there any way of retreiving this???

  3. #3
    My life is this forum Snayler's Avatar
    Join Date
    Jan 2010
    Posts
    1,418

    Default Re: Bluesmash issues

    Quote Originally Posted by MassAppeal View Post
    There was a thread on the old remote exploit forums called "Ultimate Bluetooth thread" is there any way of retreiving this???
    google --> "cache: (link_here)".
    BTW, have you even looked into the man pages?
    Last edited by Snayler; 02-20-2010 at 04:12 PM.

  4. #4
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default Re: Bluesmash issues

    Quote Originally Posted by MassAppeal View Post
    Bump... i need some sort of thread or post which gets people started, all the videos and information are scarce and very vague.

    There was a thread on the old remote exploit forums called "Ultimate Bluetooth thread" is there any way of retreiving this???

    Bump. Please don't bump. It is against the rules you agreed to uphold.
    OK I gathered some links for you.
    New Tutorial For BT3 ONLY
    This appears to be a copy of the first page of the tutorial But I am not sure if it is correct.
    Google


    and
    [New Tutorial For BT3 ONLY]One bluetooth post to rule them all! - Page 20 - Remote Exploit Forums20.html+New+Tutorial+for+BT3+Only&cd=1&hl=en&ct=clnk

    If you change the above number in red to the one you want it should take you to the page you need. There are about 20 of them.

    Further use of the great google shows
    The Blue|Smash Project
    Drgr33ns Blogs, Tutorials and Info.: Blue-Smash v1.0c Released!!!
    Last edited by Archangel-Amael; 02-22-2010 at 09:32 PM. Reason: grammar

  5. #5
    Junior Member nightlybuild's Avatar
    Join Date
    Feb 2010
    Location
    InYourBucci/Chicago
    Posts
    36

    Default Re: Bluesmash issues

    I need help with bluetooth in general too. I am able to start up my bluetooth, do scans, sdptool, and those basics things. But when it comes to actual pairing/connecting to the device I get stuck. Every tutorial (including the one you had a link to) talks about editing the hcid.conf. I think that in Back Track 4, BlueZ was updated and now uses main.conf. There isn't much that I can change from there except a few things like name and class...nowhere close to how many things you can change in hcid.conf. I also have no idea what the default pin is or how to change it. There is no documentation on this subject anywhere, I've been looking around with google for a while now. Please, if anyone can help me it will be greatly appreciated.

  6. #6
    Member
    Join Date
    Jan 2010
    Posts
    102

    Default Re: Bluesmash issues

    Thanks guys,

    And yes i did spend about 2-3 hours searching around, looking for valid links and trying all sites i could find... im not trying to be spoonfed i just wanted a few resources i could get some info from. Much appreciated.

    http://www.soldierx.com/bbs/201001/B...th-Backtrack-4

    I have been following this and i run into the same troubles as this guy, i can see my phone, i can scan the open ports etc but i cannot do anything without the phone beeping and asking for a passcode... i beleived the whole idea was about this being done with the phone users knowledge or input.
    Last edited by MassAppeal; 02-22-2010 at 01:47 PM.

  7. #7
    Member
    Join Date
    Jan 2010
    Posts
    102

    Default Really struggling with bluetooth

    Bluetooth hacking wth Backtrack 4 | SOLDIERX.COM
    New Tutorial For BT3 ONLY

    I have been using the following 2 websites as a guide plus a hell of a lot of googling to try and get my Bluetooth attacks to work, what i cannot get working is the PIN.

    I can successfully query my phone for services & channels its running, but my BT Adapter always makes me put a pin in on my phone like im missing some sort of authentication option in my config.

    Also i cannot find hcid.conf file in the bluetooth directories "/etc/bluetooth/hcid.conf" all i get is

    > rfcomm.conf
    > network.conf
    > main.conf

    And these files dont contain some of the options. Such as
    Code:
    hciconfig -a hci0 name USBNAME
    When i run this command i cannot find the file that it writes to, and even when i find the option in the above .conf files and change it ,manually there and restart my device it doesn't read it & change...

    And some of the commands in the bluetooth tools have alot of errors in them, as if the scripts don't sit in the right directories.

    Has anybody had any success with Bluetooth on BT4 yet? and if so is my phone not compatible if it always asks for the PIN Number?

  8. #8
    My life is this forum Snayler's Avatar
    Join Date
    Jan 2010
    Posts
    1,418

    Default Re: Really struggling with bluetooth

    Quote Originally Posted by MassAppeal View Post
    and if so is my phone not compatible if it always asks for the PIN Number?
    Why did you expect your phone not to ask for a PIN code? Or do you think the bug that allowed this hack to happen would be around forever?
    Last edited by Snayler; 02-26-2010 at 05:40 PM.

  9. #9
    Junior Member Tr00g33k's Avatar
    Join Date
    Jul 2008
    Posts
    46

    Default Re: Bluesmash issues

    Ok no problem if it asks for pin, but i just cant find out where is default pin located or how to change it in BT 4 !?
    I have tried million tutorials, and i have tried a lot of thing by myself, evrything works perfect until i come to PIN, and i cant figure out the default PIN in Bt4 :S
    Please help.
    Last edited by Tr00g33k; 09-16-2010 at 12:54 PM.

  10. #10
    My life is this forum Snayler's Avatar
    Join Date
    Jan 2010
    Posts
    1,418

    Default Re: Bluesmash issues

    How about gooling "linux+bluetooth+PIN"? I'm sure you'll find something...

Page 1 of 2 12 LastLast

Similar Threads

  1. Eth0 Issues
    By sirwolfgang in forum Beginners Forum
    Replies: 8
    Last Post: 06-17-2010, 10:08 PM
  2. Issues running on Eee 900
    By RChadwick in forum BackTrack Bugs
    Replies: 6
    Last Post: 03-07-2010, 03:18 AM
  3. WNDA3100 Issues
    By cynofield in forum Beginners Forum
    Replies: 4
    Last Post: 02-11-2010, 10:33 AM
  4. Performance Issues
    By patrick in forum Beginners Forum
    Replies: 1
    Last Post: 02-01-2010, 04:00 PM
  5. HP dvx sound issues
    By halfdone in forum BackTrack Fixes
    Replies: 0
    Last Post: 01-28-2010, 05:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •