Results 1 to 6 of 6

Thread: Medusa Modules -none loaded

  1. #1
    Just burned his ISO
    Join Date
    Feb 2010
    Location
    Arizona
    Posts
    15

    Default Medusa Modules -none loaded

    Hello All,

    Following some basic info regarding tool usage from foofus.net, says that "medusa -d" will list all available modules... but for some reason I don't have any listed in: "/usr/local/lib/medusa/modules" (where he indicates that they would be)

    ...must be doing somthing incorrectly

    any suggestion to get these modules loaded?

    thanx,

    J

  2. #2
    Just burned his ISO
    Join Date
    Feb 2010
    Location
    Arizona
    Posts
    15

    Default Re: Medusa Modules -none loaded

    hmmmm, not sure why this worked...

    i uninstalled medusa and reinstalled, to much surprise all modules are now available...

    apt-get remove medusa
    apt-get install medusa

    meduse -d

    All supported modules are now ready to rock.

  3. #3
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default Re: Medusa Modules -none loaded

    That's because I fixed the errors in the package and now you have it.
    So to everyone getting this problem update your medusa and all will be fine.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  4. #4
    Just burned his ISO
    Join Date
    Feb 2010
    Location
    Arizona
    Posts
    15

    Default

    Many thanx, I didn't realize you were part of the dev team for backtrack...

    ...curious as to why you didn't respond until a solution/workaround was already in place?

    thanx again,

    J

    ...still failing badly over here;

    I am looking at the modules "/usr/local/lib/medusa/modules" ...and all .mod's are present

    "ftp.mod : Couldn't load "/usr/local/lib/medusa/modules/ftp.mod" [libssh2.sared object file: No such file or directory]" ...is such example of error generated.

    when i run the actual command; this output is given, but i'm unsure how to re-install and specify this option. ...or should i just a typical ./configure, make, makeinstall????

    "Place the module in the medusa directoMODULE_NAME environment variable or run the configure script again using --with-ath]"

    thanks,

    J
    Last edited by Archangel-Amael; 09-08-2010 at 09:49 AM.

  5. #5
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default Re: Medusa Modules -none loaded

    Actually yes, I participate as a contributer to BackTrack.
    As for Medusa, I am glad you brought this thread up ( now I didn't have to go search for it).
    Last night I was messing around with this and me and balding-parrot have resolved the issue.
    First make sure you have the latest version of medusa
    apt-get purge medusa && apt-get install medusa libssh2-1 < this second package will also bring in a few other dependencies and the latest hydra package. There are about 20 in all. But you get the new libssh the newest hydra with more compiled options as well as the fixed medusa.
    If something does not work then make sure you post it here.

    EDIT: See also the fix here:
    http://www.backtrack-linux.org/forum...tml#post174491
    Last edited by Archangel-Amael; 09-08-2010 at 10:42 AM.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  6. #6
    Just burned his ISO
    Join Date
    Feb 2010
    Location
    Arizona
    Posts
    15

    Default Re: Medusa Modules -none loaded

    Many thanx Archangle, my modules are now identified correctly and all is well. Thanks for your extended effort (bt dev) to this project.

    J

Similar Threads

  1. Error 8: Kernel must be loaded befor booting
    By PinguPing in forum Anfänger Ecke
    Replies: 1
    Last Post: 08-29-2010, 10:13 AM
  2. error 8 kernel must be loaded before booting
    By xxXBattousai in forum Beginners Forum
    Replies: 1
    Last Post: 03-28-2010, 10:35 PM
  3. Module Windows Application cannot be loaded
    By yukapuka in forum OLD Newbie Area
    Replies: 4
    Last Post: 07-26-2009, 11:52 PM
  4. Fully-Loaded Version
    By Virchanza in forum OLD BT4 Feature Requests
    Replies: 20
    Last Post: 05-12-2009, 10:24 PM
  5. Ndiswrapper loaded on boot
    By gummo in forum OLD Newbie Area
    Replies: 2
    Last Post: 12-04-2007, 11:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •