Results 1 to 7 of 7

Thread: nvidia xconfig

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Aug 2010
    Posts
    9

    Default nvidia xconfig

    Hallo!
    Ich habe mir einen BT4-R1 USB-Stick mit persistent mode erstellt, funktioniert wunder bar. Nun habe ich den nvidia treiber mittels "apt-get install nvidia-driver" zuvor den xserver abgeschaltet, zusätzlich habe ich noch die Cuda Treiber samt Toolkit installiert.
    Wenn ich nun den BT neustarte funktioniert der nvidia treiber nicht mehr, fehlermeldung:
    Code:
    'You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server
    Ich kann den xserver nicht neustarten. Wenn ich dann über Pyrit auf den cuda treiber zugreife schmiert er voll ab.

    Ich habe darauf hin BT4-R1 auf die Festplatte installiert, da hatte ich den selben fehler, konnte aber den xserver mit einem kurzen logout neustarten,seit dem läuft er.
    Aber seit dem läuft mein AlfaAWSU036NEH (rt3070) sie andern Thread.

    Gruß
    Z

  2. #2
    Just burned his ISO
    Join Date
    Aug 2010
    Posts
    9

    Default Re: nvidia xconfig

    So!
    Auf meiner USB-Persisten:
    Die Xconfig file mußte ich 2 mal laden und 2 mal den xserver neustarten und dann geht der nvidia-treiber wieder incl. cuda support. Allerdings muss das nach jedem Neustart gemacht werden. Kann man die xconfig irgendwie fixen ?

    Gruß
    Z

  3. #3
    Just burned his ISO
    Join Date
    Aug 2010
    Posts
    9

    Default Re: nvidia xconfig

    So ein neues altes Proplem!
    BT4-R1 Festplatten installation: Hardware : NB Acer 7720g + nvidia 9600m gt + Display 1920x1600x60hz.
    Leider muss ich nach jedem Neustart meinen nvidia dreiver deinstalliern und wieder neuinstalliern, damit der xserver überhaupt startet. Leider funktioniert er nur eingeschrängt und ich kann meine nvida-settings nicht einstellen. Wenn ich pyrit starte, peng freez und nix geht mehr.
    Wenn ich nvidia neu indstalliere oder auch cudatoolkit läd er immer die neuseten pakette, obwohl ich sie eigendlich aus dem ordner rausgewofen habe (apt-get autoclean).

    meine xconfi:
    Code:
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 256.40  (buildmeister@builder99.nvidia.com)  Wed Jul  7 13:23:55 PDT 2010
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Unknown"
        HorizSync       28.0 - 33.0
        VertRefresh     43.0 - 72.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    Meine nvidia pakette:
    Code:
    root@bt:~# apt-cache showpkg nvidia-driver
    Package: nvidia-driver
    Versions:
    256.40-bt0 (/var/lib/apt/lists/archive.offensive-security.com_dists_pwnsauce_microverse_binary-i386_Packages) (/var/lib/dpkg/status)
     Description Language:
                     File: /var/lib/apt/lists/archive.offensive-security.com_dists_pwnsauce_microverse_binary-i386_Packages
                      MD5: 9581c12c2028ed561c43c3f9d19f86fb
    
    195.36.15-bt1 (/var/lib/apt/lists/archive.offensive-security.com_dists_pwnsauce_microverse_binary-i386_Packages)
     Description Language:
                     File: /var/lib/apt/lists/archive.offensive-security.com_dists_pwnsauce_microverse_binary-i386_Packages
                      MD5: 9581c12c2028ed561c43c3f9d19f86fb
    
    
    Reverse Depends:
      cuda-gdb,nvidia-driver
      cuda-toolkit,nvidia-driver
      cuda-toolkit,nvidia-driver
      cuda-toolkit,nvidia-driver
      cuda-toolkit,nvidia-driver
      cuda-toolkit,nvidia-driver
    Dependencies:
    256.40-bt0 - mesa-common-dev (0 (null))
    195.36.15-bt1 - mesa-common-dev (0 (null))
    Provides:
    256.40-bt0 -
    195.36.15-bt1 -
    Reverse Provides:
    Vieleicht weis jemand rat.

    Thanks
    Z

  4. #4
    Just burned his ISO
    Join Date
    Aug 2010
    Posts
    9

    Default Re: nvidia xconfig

    noch mal meine corg file:

    Code:
    root@bt:~# nvidia-xconfig
    
    Using X configuration file: "/etc/X11/xorg.conf".
    
    VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf.
                      Device section "Configured Video Device" must have a Driver
                      line.
    
    Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
    New X configuration file written to '/etc/X11/xorg.conf'
    
    ----------------------------------------
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 1.0  (buildmeister@builder57)  Wed Nov 26 11:27:46 PST 2008
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "Module"
        Load           "dbe"
        Load           "extmod"
        Load           "type1"
        Load           "freetype"
        Load           "glx"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Unknown"
        HorizSync       28.0 - 33.0
        VertRefresh     43.0 - 72.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection

  5. #5
    Just burned his ISO
    Join Date
    Aug 2010
    Posts
    9

    Default Re: nvidia xconfig

    Das waren meine alten Dateien!

    Ich habe BT4-R1 Neuinstalliert.
    Geht immer noch nix und jetzt kann ich nur über den Recover starten modus starten und da dann den xserver recover wählen, dies aber bei jedem reboot. Ich würde gerne alle Treiber deinstallieren und neu aufspielen.

    hier meine aktuelle xorg:
    Code:
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # Note that some configuration settings that could be done previously
    # in this file, now are automatically configured by the server and settings
    # here are ignored.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Device"
    	Identifier	"Configured Video Device"
    EndSection
    
    Section "Monitor"
    	Identifier	"Configured Monitor"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Monitor		"Configured Monitor"
    	Device		"Configured Video Device"
    EndSection
    Code:
    apt-cache showpkg nvidia-driver
    Package: nvidia-driver
    Versions:
    256.40-bt0 (/var/lib/apt/lists/archive.offensive-security.com_dists_pwnsauce_microverse_binary-i386_Packages)
     Description Language:
                     File: /var/lib/apt/lists/archive.offensive-security.com_dists_pwnsauce_microverse_binary-i386_Packages
                      MD5: 9581c12c2028ed561c43c3f9d19f86fb
    
    195.36.15-bt1 (/var/lib/apt/lists/archive.offensive-security.com_dists_pwnsauce_microverse_binary-i386_Packages)
     Description Language:
                     File: /var/lib/apt/lists/archive.offensive-security.com_dists_pwnsauce_microverse_binary-i386_Packages
                      MD5: 9581c12c2028ed561c43c3f9d19f86fb
    
    
    Reverse Depends:
      cuda-gdb,nvidia-driver
      cuda-toolkit,nvidia-driver
      cuda-toolkit,nvidia-driver
      cuda-toolkit,nvidia-driver
      cuda-toolkit,nvidia-driver
      cuda-toolkit,nvidia-driver
    Dependencies:
    256.40-bt0 - mesa-common-dev (0 (null))
    195.36.15-bt1 - mesa-common-dev (0 (null))
    Provides:
    256.40-bt0 -
    195.36.15-bt1 -
    Reverse Provides:
    root@bt:~#

  6. #6
    Just burned his ISO
    Join Date
    Aug 2010
    Posts
    9

    Default Re: nvidia xconfig

    Hallo!
    Ich habe herrausgefunden das es an den Treibern ab nvidIa treibern nvidia-driver-256.40-bt0 liegt.
    Bei jeder neuinstallation wird er geladen, wenn ich ihn über apt-get install nvidia-driver lade.
    Manuell werden andere Treiber nicht erkannt.
    Wie kann ich alle nvidia Treiber samt cuda treiber von meinenm System deinstallien, das wenn ich apt-get install nvidia-driver der nvidia-driver-195.36.15-bt1 geladen wird.
    Oder gibt es Notfalls die Möglichkeit BT4-R1 zurück zu setzten ohne wieder eine Neuinstllation des BT?

  7. #7
    Just burned his ISO
    Join Date
    Aug 2010
    Posts
    9

    Default Re: nvidia xconfig

    Hi!
    So habe den Treiber as der Liste "256.40-bt0 (/var/lib/apt/lists/archive.offensive-security.com_dists_pwnsauce_microverse_binary-i386_Packages)" entfernt, den alten deinstalliert.
    Mit apt-get install den 195 er drauf. Leider besteht wieder das Problem das er den Treiber nicht lädt.
    Ich habe noc einaml einen Stick mit Persisitent erstellt, da kann ich den Treiber normal nutzen. Ich habe versucht von dem Stick die xconfig zu nehmen,nur geht dann der xserver garnicht. Also ich würde gerne alle Resten von den vorherigen nv-treibern löschen.

    Gruß
    Z

Similar Threads

  1. 2.6.34 & nvidia
    By Nemis in forum BackTrack Fixes
    Replies: 0
    Last Post: 07-12-2010, 08:37 PM
  2. pyrit CUDA nvidia Tutorial + Nvidia overclock instructions
    By purehate in forum OLD BT4beta HowTo's
    Replies: 155
    Last Post: 01-26-2010, 12:27 AM
  3. Need Nvidia driver
    By -=DDOS=- in forum OLD Newbie Area
    Replies: 6
    Last Post: 05-28-2009, 09:55 PM
  4. cracking wpa with nvidia gpu
    By spawn in forum OLD Wireless
    Replies: 2
    Last Post: 03-13-2009, 08:10 AM
  5. PC changes and compiz nvidia
    By hm2075 in forum OLD BT3beta General
    Replies: 9
    Last Post: 01-18-2008, 08:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •