Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: backtrack 4 r1 grub problem

  1. #1
    Just burned his ISO
    Join Date
    May 2010
    Posts
    7

    Default backtrack 4 r1 grub problem

    Hello everyone

    i download backtrack 4 r1 and burn it to dvd and when i boot it it goes to Grub how ican fix it.
    when i used backtrack 4 final it doesn't go to grub

    thank you so much sorry for my bad english

  2. #2
    My life is this forum Snayler's Avatar
    Join Date
    Jan 2010
    Posts
    1,418

    Default Re: backtrack 4 r1 grub problem

    Grub was always used since BackTrack 4 beta. You are mistaken about BT4 final not using Grub.

    You need to better describe your problem.
    Last edited by Snayler; 08-26-2010 at 03:06 AM.

  3. #3
    Senior Member
    Join Date
    Jul 2009
    Posts
    135

    Default Re: backtrack 4 r1 grub problem

    Grub has always been in all BT4 iso's including the beta. You can go back to the BT4 that you claim didnt have grub and cd into /boot/ and see if you see a grub folder in there. im 99.9% sure you would find that grub folder in there.

  4. #4
    Member
    Join Date
    Jan 2010
    Posts
    70

    Default Re: backtrack 4 r1 grub problem

    While the following is idle speculation:
    The OP might also being saying that the grub menu is popping up after a hdd install.
    The OP might be used to a BT4F install on a hdd which doesn't print a grub menu.
    The OP might also have a bad burn and be dropped into the grub shell and thinking "WTF?"

    @OP:
    Can you try to describe your problem a bit clearer? What was the behavior you're used to seeing (IE: grub menu with options, or a printout saying that it will boot soon, etc.)? What is the behavior you're seeing now (ie: are you getting grub> console; are you getting a menu; etc).

  5. #5
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default Re: backtrack 4 r1 grub problem

    More speculation, the OP may not actually be talking about "booting it goes to grub" but rather means it goes to a shell (which is normal).
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  6. #6
    Just burned his ISO
    Join Date
    May 2010
    Posts
    7

    Default Re: backtrack 4 r1 grub problem

    i mean when i insert a backtrack r1 dvd it's not going to this screen



    it's going to grub screen it's like that screen

  7. #7
    Junior Member Tr00g33k's Avatar
    Join Date
    Jul 2008
    Posts
    46

    Default

    I have exactly the same problem as Neooo, i downloaded BackTrack 4 R1, and burned it on dvd with windows 7, first i tried on HP laptop, booted just fine, then i tried on TroNote laptop, when the dvd boots up i get only grub. Any help would be much appreciated

    Thanks in advance

    Solution:

    Install windows, install VMware workstation 6.5
    - Create new virtual machine, boot from DVD
    - Choose option "use physical disc"
    Boot BT, and here you go, boot menu, as it should be.
    Boot only in text mode, and then manually install BT on your hd.
    Help with manuall installation: http://www.offensive-security.com/do...bt4install.pdf
    For me works just fine

    But if anybody figures it out, why I get grub instead standard boot menu, i would appreciate it

    Tr00G33k
    Last edited by Archangel-Amael; 09-04-2010 at 03:22 PM.

  8. #8
    My life is this forum Snayler's Avatar
    Join Date
    Jan 2010
    Posts
    1,418

    Default Re: backtrack 4 r1 grub problem

    Quote Originally Posted by Tr00g33k View Post
    Solution:

    Install windows, install VMware workstation 6.5
    - Create new virtual machine, boot from DVD
    - Choose option "use physical disc"
    Boot BT, and here you go, boot menu, as it should be.
    Boot only in text mode, and then manually install BT on your hd.
    Help with manuall installation: http://www.offensive-security.com/do...bt4install.pdf
    For me works just fine

    But if anybody figures it out, why I get grub instead standard boot menu, i would appreciate it

    Tr00G33k
    Like in here: http://www.backtrack-linux.org/forum...rkstation.html

    Also possible to accomplish with VirtualBox, I'll release a tutorial once I have the time.
    Last edited by Snayler; 09-04-2010 at 03:21 PM.

  9. #9
    Junior Member Tr00g33k's Avatar
    Join Date
    Jul 2008
    Posts
    46

    Default Re: backtrack 4 r1 grub problem

    Quote Originally Posted by Snayler View Post
    Like in here: http://www.backtrack-linux.org/forum...rkstation.html

    Also possible to accomplish with VirtualBox, I'll release a tutorial once I have the time.
    I dont take any credit for what i did to solve the problem, but i really didnt saw your post. Soo I`m sorry i just wanted to help others who have the same problem. [COLOR="yellow"][B]And i took a look at your post, and it doesnt work for me, i cant istall it with install.sh script. I get error about partitioning. Soo for me works just manual installation.
    Last edited by Archangel-Amael; 09-05-2010 at 01:31 PM. Reason: Removed color tags

  10. #10
    My life is this forum Snayler's Avatar
    Join Date
    Jan 2010
    Posts
    1,418

    Default Re: backtrack 4 r1 grub problem

    Quote Originally Posted by Tr00g33k View Post
    I dont take any credit for what i did to solve the problem, but i really didnt saw your post. Soo I`m sorry i just wanted to help others who have the same problem.
    Don't worry, I was just pointing out a tutorial so that others can follow.
    Quote Originally Posted by Tr00g33k View Post
    And i took a look at your post, and it doesnt work for me, i cant istall it with install.sh script. I get error about partitioning. Soo for me works just manual installation.
    Have you tried the manual partitioning inside the install.sh?

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 1
    Last Post: 04-05-2010, 01:12 AM
  2. Backtrack grub and Ubuntu grub
    By gots2love&hateIT in forum Beginners Forum
    Replies: 5
    Last Post: 01-16-2010, 05:07 AM
  3. problem with grub
    By clorus in forum OLD Newbie Area
    Replies: 2
    Last Post: 01-13-2010, 09:54 PM
  4. Grub boot problem BT4 USB
    By ee0u30eb in forum OLD BackTrack 4 General Support
    Replies: 2
    Last Post: 09-30-2009, 10:23 AM
  5. BT4 USB Boot problem - Grub
    By falcaun in forum OLD BackTrack 4 General Support
    Replies: 7
    Last Post: 06-30-2009, 05:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •