Results 1 to 4 of 4

Thread: Connecting to X server refused

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Aug 2010
    Location
    Montana
    Posts
    4

    Default Connecting to X server refused

    I am very new to linux/backtrack. I recently tried to download the .iso of backtrack 4, and I used unetbootin just as this site recommended to install on usb drive. All seemed to work, but when I type: startx and press enter, a whole bunch of stuff pops up like

    (EE) Screen(s) found, but none have a usable configuration.

    Fatal server error:
    no screens found
    giving up.
    xinit: Connection refused (errno 111): unable to connect to X server
    xinit: No such process (errno 3): Server error.

  2. #2
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default Re: Connecting to X server refused

    Reboot, try fixvesa before typing startx and see if that fixes the problem.
    If not you will need to provide more info. Example post can be found through searching here and google.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  3. #3
    Just burned his ISO
    Join Date
    Aug 2010
    Location
    Montana
    Posts
    4

    Default Re: Connecting to X server refused

    Thank you Archangel, I have been actually searching google quite a bit, but it is hard to know exactly what to type considering how new I am. I think I've already tried this, but I will do so again and tell you what happens.

  4. #4
    Just burned his ISO
    Join Date
    Mar 2010
    Posts
    1

    Default Re: Connecting to X server refused

    Quote Originally Posted by Archangel-Amael View Post
    Reboot, try fixvesa before typing startx and see if that fixes the problem.
    If not you will need to provide more info. Example post can be found through searching here and google.

    Hi Archangel, I did followed your instruction concerning the same problem but I found my cursor missing and GUI increases in a larger level after running the instruction '' fixvesa'' to solve the problem of ''X server refused''. I had googled and done a lot of search (in this forum and on the internet) concerning the problem but I cannot find a solution to it yet.
    I cannot even perform any activity now or use my Backtrack 4 because the cursor is disappearing and the screen in on a larger size than normal.
    Please, could you or anyone help me with what code or instruction to run to correct this problem because am a newbie concerning Linux.

Similar Threads

  1. Putty Connection Refused
    By rpcnow in forum Beginners Forum
    Replies: 2
    Last Post: 05-10-2010, 06:53 PM
  2. apt-get 111 connection refused - parallels
    By stelmo in forum Beginners Forum
    Replies: 3
    Last Post: 05-07-2010, 12:41 AM
  3. Metasploit Framework - Server Started - No Server Started
    By mcurran in forum Beginners Forum
    Replies: 1
    Last Post: 02-07-2010, 01:11 AM
  4. VMware Server and Windows Server 2003
    By Zo7779 in forum OLD General IT Discussion
    Replies: 3
    Last Post: 05-08-2008, 05:53 AM
  5. Replies: 0
    Last Post: 06-02-2007, 10:07 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •