Results 1 to 10 of 11

Thread: Dlink DWL-G122 injection?

Hybrid View

  1. #1
    arcus
    Guest

    Default Dlink DWL-G122 injection?

    does g122 support injection? i've searched the forum n have google it, some says it support injection. when i plug my g122, it recognized as rausb0..then i made it to monitor mode and able to monitor traffic but when i try to inject using aireplay..i got 0 ARP request and i had wait quite a long time but still 0 arp request..i used airoscript..what's the problem?is it able to inject?

  2. #2
    Junior Member
    Join Date
    Feb 2007
    Posts
    73

    Default

    The problem is that you don't have a valid ARP req. One thing you can do to verify that injection is working is to perform a FakeAuth attack on the AP. If you get a Successful response Associating and Authenticating all is well then. I may be wrong but, I think your device is a Ralink chipset. In which is fully supported by aircrack.

  3. #3
    Junior Member
    Join Date
    Dec 2006
    Posts
    42

    Default

    Check out if your device is hw ver B1 (sticker on its back). If it is, you've got the perfect one. Every other hw version has reported problems at some point, so you'll have to google a bit to find solutions, patches or bad news.

    I don't agree with Tybalt about the fakeauth attack, as many times this attack fails but still you can do an injection attack when a valid station is associated to the AP. This is first hand learned, so I admit no discussion.

    What you don't mention in your post is if you are also performing a deauth attack to force the station to reassociate, so the injection attack can capture its ARP request and start replaying it..

  4. #4
    arcus
    Guest

    Default

    yup, my dlink is B1..i figured it out already that it can do injection but still got problems with arp request..after doing the deauth, i only got about 3 ARP request..and the IV's never reached more than 6..damn..i tried everything, i've google and read the documentation of aircrack but still out of luck..ne ideas?

  5. #5
    Junior Member
    Join Date
    Dec 2006
    Posts
    42

    Default

    Could be a weak signal? Too noisy? Can you post a snapshot?
    Are you faking the client or deauthenticating a valid associated station?
    Do you have any other APs to try?

  6. #6
    arcus
    Guest

    Default

    i deauth a valid associated clients but i did try to fake auth but still the same..is it possible that if the network is not busy, the IV's are hard to collect? the associated client sometimes disappear from the station list then reappear..is it becoz the signal is weak? then when i did aireplay when the -h option, i put the MAC of the valid client, but aireplay said that the mac supply in -h is not the same as the interface..im a bit confuse coz what i read before that we should supply -h with the client MAC..i only got one AP for this wep cracking test..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •