Results 1 to 4 of 4

Thread: Error when trying to run airodump

  1. #1
    Just burned his ISO
    Join Date
    Apr 2006
    Posts
    6

    Question Error when trying to run airodump

    i have a ubiquiti card and i'm getting this error when trying to run wireless commands...

    i was able to set the card and get network access thought, which is the way i'm connected right now....

    airodump-ng -w Out ath0
    ioctl(SIOCSIWMODE) failed: Invalid argument
    Error setting monitor mode on ath0


    any ideas?

    thanks
    __________________

  2. #2
    Junior Member
    Join Date
    Dec 2006
    Posts
    42

    Default

    Try to set the card in monitor mode this way:

    Code:
       wlanconfig ath0 destroy
       wlanconfig ath0 create wlandev wifi0 wlanmode mon
    It seems to be the fail proof way to set up monitor mode in atheros chipsets. You can also not kill ath0, keeping it in station mode, and create instead an ath1 device to monitor.

    Good luck

  3. #3
    Just burned his ISO
    Join Date
    Apr 2006
    Posts
    6

    Thumbs up

    Quote Originally Posted by madmanu View Post
    Try to set the card in monitor mode this way:

    Code:
       wlanconfig ath0 destroy
       wlanconfig ath0 create wlandev wifi0 wlanmode mon
    It seems to be the fail proof way to set up monitor mode in atheros chipsets. You can also not kill ath0, keeping it in station mode, and create instead an ath1 device to monitor.

    Good luck

    i will try this ....thanks for your response...

  4. #4
    Just burned his ISO
    Join Date
    Jul 2006
    Posts
    12

    Default

    Worked for me, Thanks a lot !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •