I'm trying to get my airport extreme card BCM4321 rev 5 to work in bt4 r1
I have a Macbookpro 4,1

I know I won't be able to do injecting, but for general internet use.

According to this:
HCL:Wireless - Offensive-security.com

when I run:
lspci -n| grep 14e4

I see:
0b:00.0 0280: 14e4:4328 (rev 05)

then I read in the above list that it will work with this:
Broadcom.com - 802.11 Linux STA driver

so I have downloaded, but want to know if I need it? and how to install?
also it says i may need kernel.lzm and compat-wireless

where do i find those and how do i procede... please help...