Page 4 of 4 FirstFirst ... 234
Results 31 to 35 of 35

Thread: howto - rtl8187 backtrack r1 monitor mode - Unknown error 132

  1. #31
    Just burned his ISO
    Join Date
    Apr 2010
    Posts
    8

    Default Re: howto - rtl8187 backtrack r1 monitor mode - Unknown error 132

    Quote Originally Posted by Jayman007 View Post
    Worked for me as well.

    I went ahead and saved the following as a script called fixwifi and run that whenever my adapter shuts off. Works like a charm. I wish we could figure out how to stop it from happening from the beginning cause this never happens with the r8187 drivers. In any case, it's nice to know how to fix it. So using the above patched driver method I can use the r8187 driver and using the code I pasted below I can get the rtl8187 drivers working. Now I can use either in bt4 r2.

    Code:
    rmmod rtl8187
    rfkill block all
    rfkill unblock all
    modprobe rtl8187
    rfkill unblock all
    ifconfig wlan0 up
    Its work for me, all works fine Thanks !

  2. #32
    Developer muts's Avatar
    Join Date
    Jan 2006
    Posts
    272

    Default [SOLVED] howto - rtl8187 backtrack r1 monitor mode - Unknown error 132

    try this, this seems to work for me:

    Code:
    #!/bin/bash
      rmmod rtl8187
      rfkill block all
      rfkill unblock all
      modprobe rtl8187
      rfkill unblock all
      ifconfig wlan0 up
    If that doesn't work, try running this script:


    Code:
    #!/bin/sh
         for i in /sys/class/rfkill/rfkill*/type;
         do
            type="`cat $i`"
            if [ "$type" = "wlan" ];
            then
               n="`echo $i | sed -r 's%/type$%%'`";
               echo 1 > ${n}/state;
            fi;
         done;

  3. #33
    Member
    Join Date
    Jul 2010
    Location
    Holland
    Posts
    110

    Default Re: [SOLVED] howto - rtl8187 backtrack r1 monitor mode - Unknown error 132

    Code:
    #!/bin/bash
      rmmod rtl8187
      rfkill block all
      rfkill unblock all
      modprobe rtl8187
      rfkill unblock all
      ifconfig wlan0 up
    exactly as described in the youtube vid.

    regards

    P.s. I guess backtrack is the best on the internet, by far! Thanks.
    Last edited by TheFlyingDutchMan; 02-24-2011 at 10:34 PM.

  4. #34
    Just burned his ISO
    Join Date
    Feb 2011
    Posts
    1

    Default Re: howto - rtl8187 backtrack r1 monitor mode - Unknown error 132

    these steps fixed it for me

    1 connect the usb and connect to a network with windows
    2 enable usb wifi vmware
    3 airmon-ng start wlan0
    Working!


    works while you dont disconnect the USB

  5. #35
    Member longjidin's Avatar
    Join Date
    Feb 2010
    Location
    Kg Lengkong to Bukit Lada
    Posts
    93

    Cool Re: howto - rtl8187 backtrack r1 monitor mode - Unknown error 132

    I haved this problem since the BT4 r1 and i get the solution for this ERROR :-

    1. modprobe rtl8187

    2. rfkill block all (in BT4 R1 doesnt have must install its first)

    3. rfkill unblock all

    Now you can try to put your wireless card in monitor mode

    happy hunting....................

Page 4 of 4 FirstFirst ... 234

Similar Threads

  1. Replies: 14
    Last Post: 07-14-2009, 05:53 PM
  2. How to switch to managed mode from monitor mode backtrack 3?
    By donjuanzx9 in forum OLD Newbie Area
    Replies: 8
    Last Post: 07-15-2008, 04:41 AM
  3. error setting monitor mode on wlan0
    By kikoman in forum OLD Newbie Area
    Replies: 3
    Last Post: 10-09-2007, 04:53 PM
  4. Replies: 6
    Last Post: 10-09-2007, 12:31 PM
  5. Error when trying to put card into monitor mode
    By ESC201 in forum OLD Newbie Area
    Replies: 3
    Last Post: 07-27-2007, 09:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •