In our tests we have found the rtl8187 driver to behave strangely in VMware environments. Eight out of ten times, the card would not go into monitor mode, and spit out this error:

root@bt:~# airmon-ng


Interface Chipset Driver

wlan0 RTL8187 rtl8187 - [phy0]

root@bt:~# airmon-ng start wlan0


Interface Chipset Driver

wlan0 RTL8187 rtl8187 - [phy0]SIOCSIFFLAGS: Unknown error 132

(monitor mode enabled on mon0)


To solve this, you can switch to the ieee80211 r8187 drivers, which will work just fine:

rmmod rtl8187
rmmod mac80211
modprobe r8187

And to make these changes permanent, modify your /etc/modprobe.d/blacklist file to blacklist ONLY rtl8187. Entry should look like this:

blacklist snd_desktop
...
#blacklist r8187
blacklist rtl8187
...