Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 39

Thread: [metasploit] - MetaSploit nao atualiza

  1. #21
    Good friend of the forums spawn's Avatar
    Join Date
    Jan 2010
    Posts
    280

    Default Re: [metasploit] - MetaSploit nao atualiza

    http://www.backtrack-linux.org/forum...eligentes.html

    http://www.backtrack-linux.org/forum...niciantes.html

    E lembre-se o Google é seu amigo !

    Se ele tivesse colocado o erro do google

    "svn: Working copy '.' locked"

    ele teria encontrado a solução facilmente.
    E de que adianta o mini-howto do svn se alguns Seres não possuem a habilidade nata de pesquisar ...
    Last edited by spawn; 09-02-2010 at 12:04 PM.

  2. #22
    Just burned his ISO
    Join Date
    Sep 2010
    Posts
    6

    Default Re: [metasploit] - MetaSploit nao atualiza

    OK muito obrigado aqueles que ajudaram...

    e vou procurar mais no google entao valeu....

    mas pensei que vindo direto aki as respostas seriam mais diretas ao que eu queria..

    baixei ontem o back track e to tentando apreende algo nele...

    " A Humildade acima de tudo"
    Bl4ck Pir4t3

  3. #23
    Member
    Join Date
    May 2010
    Posts
    85

    Default Re: [metasploit] - MetaSploit nao atualiza

    Ola pessoal

    Só porque disse que o meu R1 estava bem agora me apresenta mais um problema... vou aproveitar o tópico porque acho que está relacionado.

    É o seguinte fui fazer um upadate pelo fasttrack, normalmente eu faço pelo fasttrack WebGUI, mas ao abrir o site dava como Not Found. Pensei que o mesmo estava sofrendo alguma manutenção e tentei mais tarde, a mesma coisa. Fui então tentar pela linha de comando, pelo menu interativo (./fast-track -i) e para minha surpresa toda vez que digitava o comando ele me apresentava o menu mostrando as opções de comando, tentei com -c, -g novamente com -i e sempre a mesma coisa, apresentava o menu. Tornei a tentar pela GUI e aí me mostrou o seguinte erro:

    python: can't open file 'ftgui': [Errno 2] No such file or directory
    Procurando algo aqui no fórum encontrei um caso semelhante e segui duas intruções:

    1) espreto

    /pentest/exploits/fastrack# python setup.py install
    2) Arch

    apt-get purge fasttrack && apt-get install fasttrack
    Thread: http://www.backtrack-linux.org/forum...db-errors.html

    Finalizando tudo isso, reiniciei o R1 e fiz:

    apt-get update
    apt-get upgrade
    E fui tentar abrir a GUI e novamente me apresenta o mesmo erro. Fui então pelo menu interativo e aí tem um bug que não entendo o motivo: ao digitar o ./fast-track -i ele me apresenta o 1º menu, como bem mosta o curso do Metasploit Unleashed, aí eu digito a opção 1:

    1. Fast-Track Updates
    2. Autopwn Automation
    3. Microsoft SQL Tools
    4. Mass Client-Side Attack
    5. Exploits
    6. Binary to Hex Payload Converter
    7. Payload Generator
    8. Fast-Track Tutorials
    9. Fast-Track Changelog
    10. Fast-Track Credits
    11. Exit

    Enter the number: 1
    Ele deveria me apresentar um 2º menu, como esse:

    Fast-Track Updates

    Enter a number to update

    1. Update Fast-Track
    2. Metasploit 3 Update
    3. Aircrack-NG Update
    4. Nikto Plugin Update
    5. W3AF Update
    6. SQLMap Update
    7. Installation Menu
    8. Update Milw0rm Exploits
    9. Update Kismet-Newcore
    10. Update Everything
    11. Return to Main Menu
    Mas não é o que acontece, o menu que ele me mostra é esse:

    Fast-Track Update Menu (BackTrack):

    1. Update Fast-Track

    (q)uit

    Enter number:
    Ou seja, não tenho nenhuma opção (GUI ou Interativo) para atualização

    A versão que tenho do fasttrack é essa:

    # dpkg --list fasttrack

    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
    ||/ Name Version Description
    +++-==============-==============-============================================
    ii fasttrack 4.0-r344-bt0 Fast-Track - Where speed really does matte
    Não sei o que realmente acontece

    Fico agradecido por qualquer ajuda

  4. #24
    Good friend of the forums espreto's Avatar
    Join Date
    Mar 2010
    Location
    Brazil
    Posts
    303

    Default Re: [metasploit] - MetaSploit nao atualiza

    @todumco

    Code:
    root@bt:~# apt-get dist-upgrade
    Att,
    (gdb) disass m(y_br)ain

    ®

  5. #25
    Member
    Join Date
    May 2010
    Posts
    85

    Default Re: [metasploit] - MetaSploit nao atualiza

    Bom espreto

    Pergunta: antes de ter executado esse comando eu deveria ter descomentado alguma linha de algum arquivo antes?

    Enfim, executei o comando e ele fez 126Mb de atualização, depois reiniciei o R1, e fui aos testes.

    Infelizmente ambos os problemas citados acima continuam, a única maneira que tenho para acessar a WebGUI é digitando o comando:

    /pentest/exploit/fasttrac/:# python ./fast-track.py -g
    E aí depois tenho que clicar no Firefox e entrar em localhost:44444

    Obrigado

  6. #26
    Moderator firebits's Avatar
    Join Date
    Mar 2010
    Location
    Brazil
    Posts
    353

    Default Re: [metasploit] - MetaSploit nao atualiza

    Não perdendo a idéia de repositórios e atualizações sem foco no fasttrack, você pode setar o repositório Dev do Backtrack e obter tools novas mas instáveis:

    # nano /etc/apt/sources.list

    Adicione ou descomente a linha:

    deb Index of /repotest ./

    Salve e feche o arquivo e na sequência:

    #apt-get update

    Dica
    ===
    Para quem não curte ficar baixando pacote à pacote, perde VM por falta snapshot e crer ter um repositório local do Backtrack (SUN BackTrack Linux Repository):

    Abra o firefox e digite:
    SUN Backtrack Linux Repository

    Cada link:
    Distro
    Index of /dists

    Pool de Pacotes Diversos
    Index of /pool

    Pool de Pacotes de Testes (Instável)
    Index of /repotest

    Pool de Pacotes Forks Backtrack
    Index of /buildbox

    Dá para setar fazendo:
    GPG Key
    $wget -q http://archive.offensive-security.com/backtrack.gpg -O- | sudo apt-key add -

    MAIN REPOSITORY (Repositório Padrão)
    $ sudo echo "deb http://archive.offensive-security.com pwnsauce main microverse macroverse restricted universe multiverse" > /etc/apt/sources.list

    TEST REPOSITORY (Não indicado para usuários comuns, sim desenvolvedores e outros seres
    sudo echo "deb http://sun.offensive-security.com/repotest/ ./" >> /etc/apt/sources.list


    Ai, é só fazer download localmente com wget, gerar imagem ISO ou local em um partição, mountar e setar os paths no /etc/apt/sources.list

    Não há muitas atualizações ultimamente, variando (conforme minha métrica) de 15 em 15 dias ou por demanda.

    Então você gasta uma "boa banda de internet" para montar o reposiório e ai é só mantendo atualizado localmente com wget via algum script shell.

    Bom é uma idéia minha, que vou fazer algum deployment para isso.
    Last edited by firebits; 10-01-2010 at 12:35 PM.

  7. #27
    Member
    Join Date
    May 2010
    Posts
    85

    Default Re: [metasploit] - MetaSploit nao atualiza

    Oi firebits

    Não perdendo a idéia de repositórios e atualizações sem foco no fasttrack, você pode setar o repositório Dev do Backtrack e obter tools novas mas instáveis:
    Eu fiz o que você comentou, mas pelo que entendi foi para adicionar novas ferramentas, certo?

    Enfim, o meu problema continua

    Obrigado

  8. #28
    Good friend of the forums spawn's Avatar
    Join Date
    Jan 2010
    Posts
    280

    Default Re: [metasploit] - MetaSploit nao atualiza

    tenta novamente
    apt-get update
    apt-get upgrade

    Att

  9. #29
    Good friend of the forums espreto's Avatar
    Join Date
    Mar 2010
    Location
    Brazil
    Posts
    303

    Default Re: [metasploit] - MetaSploit nao atualiza

    @todumco

    Veja o post abaixo:

    http://www.backtrack-linux.org/forum...hing-menu.html

    Agora me responde! Você quer atualizar o metasploit utilizando a GUI do fasttrack? É isso?

    Att,
    (gdb) disass m(y_br)ain

    ®

  10. #30
    Member
    Join Date
    May 2010
    Posts
    85

    Default Re: [metasploit] - MetaSploit nao atualiza

    @spawn

    Fiz novamente o que sugeriu, mas continuou os problemas... obrigado

    @espreto

    Quero ter opções de atualização tanto pela WebGUI ou pelo Interactive.

    Pelo que vi do link que passou acima, acho que se eu fizer o downgrade resolve o problema, o que acha?

    Ah... para melhor visualização do que está acontecendo gravei um vídeo (a resolução não é lá essas coisa, mas se vê o que acontece):

    Bug fasttrack menu | Videolog: todumco

    Obrigado
    Last edited by todumco; 10-02-2010 at 02:25 PM. Reason: correção

Page 3 of 4 FirstFirst 1234 LastLast

Similar Threads

  1. metasploit o non metasploit, questo è il problema!
    By eqweo in forum Discussioni Generali
    Replies: 2
    Last Post: 01-14-2010, 12:16 AM
  2. Metasploit help!
    By to learn in forum OLD Newbie Area
    Replies: 2
    Last Post: 11-15-2009, 04:53 AM
  3. Metasploit
    By kdiggity317 in forum OLD Newbie Area
    Replies: 5
    Last Post: 09-05-2008, 08:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •