Page 3 of 3 FirstFirst 123
Results 21 to 25 of 25

Thread: HOWTO- Alfa 802.11a/b/g/n AWUS050NH (rt2800usb) on BackTrack 4 R1

  1. #21
    Just burned his ISO Net2010's Avatar
    Join Date
    Sep 2010
    Posts
    10

    Default Re: HOWTO- Alfa 802.11a/b/g/n AWUS050NH (rt2800usb) on BackTrack 4 R1

    Quote Originally Posted by chalo View Post
    There is a good write up on the awus036nh and bt4r1. There is a patch that fixes the issue with mon0 is on channel x and the ap is on channel z. i have tried the patch with the awus036nh usb it and association and injection is now ok.
    The only problem i seem to have is that the packet injection is going ok (500pps) on but the iv`s are not increasing.Kindly give feedback

    Read the blog here hXXp://blog.rootshell.be/2010/08/09/backtrack4-r1-awus036nh-win/

    Credits to /dev/random for the good write up, DomInat3 for the patch and muts for the great os.
    I followed the instructions and most of it work for me the one problem is channel -1and if i use this

    PHP Code:
    cd /usr/src/drivers
    wget http
    ://wireless.kernel.org/download/compat-wireless-2.6/compat-wireless-2010-04-20.tar.bz2
    tar jxvf compat-wireless-2010-04-20.tar.bz2
    cd compat
    -wireless-2010-04-20
    wget http
    ://patches.aircrack-ng.org/mac80211_2.6.32.2-wl_frag+ack_radiotap.patch
    cat mac80211_2.6.32.2-wl_frag+ack_radiotap.patch patch -p1
    make
    make install
    make unload
    modprobe rt2800usb 
    i got working use 100% with out any problem

  2. #22
    Just burned his ISO
    Join Date
    Oct 2010
    Posts
    1

    Exclamation Alfa 802.11a/b/g/n AWUS051NH not working on Backtrack r1

    Hi All,

    I have recently bought an Alfa 802.11a/b/g/n AWUS051NH wireless adapter and followed all the steps in the installation guide for installing the driver on Ubuntu (since the underlying OS of backtrack is Ubuntu). Now when i type iwconfig and the result was:

    lo no wireless extensions.
    eth0 no wireless extensions.
    ra0 Ralink STA

    It means there is some driver problem, correct?

    I also tried armon-ng and the output was blank.

    I followed the steps mentioned in "AWUS051NH_Linux_QIG.pdf" that is shipped with the adapter and since backtrack kernel version is "2.6.30.9" i used the driver "RT2870_LinuxSTA_V2.3.0.0.tar.tar.bz2".

    Please help me in troubleshooting this issue and get the adapter working.

    Note i tried: "apt-get update && apt-get install firmware-ralink" as well.

    Thanks in advance.

    Regards
    Sanjeev

  3. #23
    Senior Member LHYX1's Avatar
    Join Date
    Sep 2010
    Location
    Belgium
    Posts
    127

    Default Re: HOWTO- Alfa 802.11a/b/g/n AWUS050NH (rt2800usb) on BackTrack 4 R1

    Hi all,
    I also bought the Alfa AWUS051NH wireless adapter but I can't get it to work.
    (I have backtrack 4 R2)

    Code:
    root@bt:~# airmon-ng
    
    
    Interface	Chipset		Driver
    
    wlan1		Ralink RT2870/3070	rt2800usb - [phy0]
    Code:
    root@bt:~# iwconfig wlan1
    wlan1     IEEE 802.11abgn  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:on
    Code:
    root@bt:~# airmon-ng start wlan1
    
    
    Found 3 processes that could cause trouble.
    If airodump-ng, aireplay-ng or airtun-ng stops working after
    a short period of time, you may want to kill (some of) them!
    
    PID	Name
    5944	wpa_supplicant
    5963	dhclient
    5983	dhclient
    Process with PID 5944 (wpa_supplicant) is running on interface wlan0
    Process with PID 5983 (dhclient) is running on interface wlan0
    
    
    Interface	Chipset		Driver
    
    wlan0		Atheros 	ath9k - [phy1]
    wlan1		Ralink RT2870/3070	rt2800usb - [phy0]SIOCSIFFLAGS: No such file or directory
    
    				(monitor mode enabled on mon0)
    Code:
    root@bt:~# airodump-ng wlan1
    ioctl(SIOCSIFFLAGS) failed: No such file or directory
    When I try this:
    Code:
    cd /usr/src/drivers/compat*
    make install
    make wlunload
    make wlload
    Still no succes.
    I get the same error.

    Please help

  4. #24
    Just burned his ISO
    Join Date
    Dec 2010
    Posts
    2

    Cool Re: HOWTO- Alfa 802.11a/b/g/n AWUS050NH (rt2800usb) on BackTrack 4 R1

    Hi Peeps, i'm a noob 2 Backtrack and im really stuck trying to get my Hornettek Janus High Power 802.11 b/g/n WLAN USB Adapter with an RT3072 chipset to work with my Backtrack 4. i hav done lsusb and it shows that i have this Janus RT3072 connected but i cant't seem to get it to work , iwould really appreciate it if sme1 can hook me up with the commands Or way to get this working .
    thnx in advance to any1 who tries to help out.

  5. #25
    Just burned his ISO
    Join Date
    Feb 2011
    Posts
    7

    Post Re: HOWTO- Alfa 802.11a/b/g/n AWUS050NH (rt2800usb) on BackTrack 4 R1

    Alright i have got a lot of help here so far. I have installed the drivers and got everything to work including monitor mode. My problem is i connect to the internet for anywhere between 2 to 10 minutes before my connection is lost. I dont get it, I can do everything fine but only for a random amount of time. Then i must go back to Wicd to reconnect again. Only to last another few minutes. I have done ifconfig wlan0 down up and sudo start stop and everything else i can find on the matter but nothing works. Any help i could get would be great and would help me get on to bigger and better things.

Page 3 of 3 FirstFirst 123

Similar Threads

  1. Alfa AWUS050NH V2
    By oNek376 in forum HardWare Compatibility List
    Replies: 8
    Last Post: 03-13-2010, 06:21 PM
  2. RTL8180 and ALFA AWUS050NH on Backtrack 4 Final
    By morgan123 in forum OLD Newbie Area
    Replies: 2
    Last Post: 01-31-2010, 02:06 AM
  3. Alfa AWUS050NH USB
    By xovian in forum OLD Newbie Area
    Replies: 32
    Last Post: 12-06-2009, 11:29 PM
  4. Alfa awus050nh
    By mahabad1972 in forum OLD Bt4beta Non-Working Hardware
    Replies: 3
    Last Post: 06-11-2009, 05:13 PM
  5. Alfa AWUS050NH
    By mahabad1972 in forum OLD Bt4beta Non-Working Hardware
    Replies: 1
    Last Post: 06-05-2009, 04:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •