Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Problems updating to kernel 2.6.34

  1. #1
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    20

    Default Problems updating to kernel 2.6.34

    Hi all,

    I'm having problems to update my kernel to the latest version. First of all after my fresh install to HD I ran:

    apt-get update
    apt-get upgrade
    apt-get dist-upgrade

    I've confirmed the kernel update with "No" when the console is asking for it. Everything goes without any errors further, but when I type:

    uname -r:

    I get that the kernel version is: 2.6.30.9. So I've tried the instructions from this link but then I get a lot of errors after the reboor. Allthough BT still boots, my mouse isn't working anymore. Just like another forum member here, and the kernel version is still 2.6.30.9?

    So I've installed BT just another time, but I don't know how to update my kernel. Is there any1 who knows how this can be done, or know a webbpage where I can instrctions to do so?

    Any help would be greatly appreciated!

  2. #2
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    2

    Default

    Hello,

    i have similar problems using BT4 VmWare image. I have proceed with the fresh downloaded VmWare Image how it is posted in u link. After that i wanted to install the new vmware-tools and it breaks because he want to use /lib/modules/2.6.30.9 instead of 2.6.34.
    X-Server wonīt do a thing to after this so.. Something canīt be right. What to do?


    Greetings,

    Kaji

    Hey Guys,

    i figured it out by myself. Sometimes i am really stupid..^^ Update BackTrack-Linux to 2.6.34 is a nice HowTo. And the problem ist that u havenīt updatet u grub. Because of that u are still booting the 2.6.30.9 Kernel. By dist-upgrade u can choose to write Grub new. Then everything runs fine and u get Kernel 2.6.34 in Grub.


    Greetings

    Kaji
    Last edited by Archangel-Amael; 07-20-2010 at 01:22 PM.

  3. #3
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    20

    Default Re: Problems updating to kernel 2.6.34

    Quote Originally Posted by Kajisan View Post
    Hello,

    i have similar problems using BT4 VmWare image. I have proceed with the fresh downloaded VmWare Image how it is posted in u link. After that i wanted to install the new vmware-tools and it breaks because he want to use /lib/modules/2.6.30.9 instead of 2.6.34.
    X-Server wonīt do a thing to after this so.. Something canīt be right. What to do?


    Greetings,

    Kaji

    Hey Guys,

    i figured it out by myself. Sometimes i am really stupid..^^ Update BackTrack-Linux to 2.6.34 is a nice HowTo. And the problem ist that u havenīt updatet u grub. Because of that u are still booting the 2.6.30.9 Kernel. By dist-upgrade u can choose to write Grub new. Then everything runs fine and u get Kernel 2.6.34 in Grub.


    Greetings

    Kaji
    I've solved this problem in an unsuspected way. I was installing an Ubuntu server to one of my partitions, at the end of this installation GRUB reconfigueres and after I rebooted Ubuntu 8.10 with kernel 2.6.34 was bootable.

    So this provides a clue about the cause. BT4 does not use GRUB 2, and if you are running a dual-boot or VM, I think GRUB 1 is not capable of detecting the right kernels.

    This explains why some hardware is not working after the update. From GRUB you try to boot kernel 2.6.30 (which is the only one displayed), but this kernel does not excist anymore. So hardware can't work

    The solution is to (re)install GRUB 2, I don't know however how this works with a VM. (Cause it's in another OS, and not loaded at the start of your computer).

    Hope this helps.

    Cheers,

  4. #4
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    2

    Default Re: Problems updating to kernel 2.6.34

    Hello Falcon22,

    u are wrong. When u make apt-get dist-upgrade Grub asks u wether to update Grub or not. Default is not because it says that it is configured. When u say it should update it, then u have the right Grub menu.

    Besides the Kernel 2.6.30.9 exists after the dist-upgrade too. Because of that u can boot in that


    Greetings

    Kaji

  5. #5
    Member Mr-Protocol's Avatar
    Join Date
    Jan 2010
    Location
    Ohio
    Posts
    142

    Default Re: Problems updating to kernel 2.6.34

    I am having the same type of issue. Confused on how to fix this or if I can even fix it.

    Code:
    root@bt:~# apt-get dist-upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run `apt-get -f install' to correct these.
    The following packages have unmet dependencies:
      linux-image: Depends: linux-image-2.6.34 but it is not installed
    E: Unmet dependencies. Try using -f.
    root@bt:~#
    Then when I do apt-get dist-upgrade -f
    Code:
    You are attempting to install a kernel image (version 2.6.34) However, the directory /lib/modules/2.6.34/kernel still exists.  If this directory belongs to a previous linux-image-2.6.34 package, and if you have deselected some modules, or installed standalone modules packages, this could be bad. If /lib/modules/2.6.34/kernel belongs to a old install of linux-image-2.6.34, then this is your last chance to abort the installation of this kernel image (nothing has been changed yet). If you know what you are doing, and if you feel that this image should be installed despite this anomaly, Please answer n to the question. Otherwise, I suggest you move /lib/modules/2.6.34/kernel out of the way, perhaps to /lib/modules/2.6.34.kernel.old or something, and then try re-installing this image. Stop install since the kernel-image is already installed?
    I click No and it does this:
    Code:
    root@bt:~# apt-get dist-upgrade -f
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Correcting dependencies... Done
    Calculating upgrade... Done
    The following NEW packages will be installed:
      linux-image-2.6.34
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    174 not fully installed or removed.
    Need to get 0B/16.8MB of archives.
    After this operation, 55.3MB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Preconfiguring packages ...
    (Reading database ... 263257 files and directories currently installed.)
    Unpacking linux-image-2.6.34 (from .../linux-image-2.6.34_2.6.34-10.00.Custom-bt6_i386.deb) ...
    Done.
    dpkg: error processing /var/cache/apt/archives/linux-image-2.6.34_2.6.34-10.00.Custom-bt6_i386.deb (--unpack):
     trying to overwrite `/lib/firmware', which is also in package udev
    Running postrm hook script /sbin/update-grub.
    Searching for GRUB installation directory ... found: /boot/grub
    Searching for default file ... found: /boot/grub/default
    Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
    Searching for splash image ... found: /boot/grub/splash.xpm.gz
    Found kernel: /boot/vmlinuz-2.6.30.9
    Found kernel: /boot/memtest86+.bin
    Updating /boot/grub/menu.lst ... done
    
    Errors were encountered while processing:
     /var/cache/apt/archives/linux-image-2.6.34_2.6.34-10.00.Custom-bt6_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    root@bt:~#

  6. #6
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    2

    Default Re: Problems updating to kernel 2.6.34

    I am having the same issue.

    On a clean install of Backtrack 4, I execute the commands:

    apt-get update
    apt-get dist-upgrade

    I receive the same error as Mr-Protocol.

    Any help would be much appreciated.

  7. #7
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    2

    Default Re: Problems updating to kernel 2.6.34

    I am also experiencing this same error.

    Any help would be much appreciated.

  8. #8
    Senior Member skull2006's Avatar
    Join Date
    Jan 2010
    Location
    In my skull
    Posts
    125

    Default Re: Problems updating to kernel 2.6.34

    Dear All,

    I made upgrade and after that i got same problem all network devices didn't work, so could someone give me the solution.

    i post this thread from windows OS (dual boot with backtrack 4 final).

    Regards,

  9. #9
    Member Mr-Protocol's Avatar
    Join Date
    Jan 2010
    Location
    Ohio
    Posts
    142

    Default Re: Problems updating to kernel 2.6.34

    I checked the twitter.

    http://www.offensive-security.com/ba...pgrade-2-6-34/

    Same problem still as i was following those instructions.

    Unpacking linux-image-2.6.34 (from .../linux-image-2.6.34_2.6.34-10.00.Custom-bt7_i386.deb) ...
    Done.
    dpkg: error processing /var/cache/apt/archives/linux-image-2.6.34_2.6.34-10.00.Custom-bt7_i386.deb (--unpack):
    trying to overwrite `/lib/firmware', which is also in package linux-firmware
    Running postrm hook script /sbin/update-grub.
    Last edited by Mr-Protocol; 07-22-2010 at 01:18 AM.

  10. #10
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    1

    Smile Re: Problems updating to kernel 2.6.34

    Quote Originally Posted by Mr-Protocol View Post
    I checked the twitter.

    BackTrack ISO Kernel 2.6.34 Upgrade

    Same problem still as i was following those instructions.

    Had the same problem when i tried to update kernel. <<trying to overwrite `/lib/firmware', which is also in package udev>>
    Fixed it with steps:
    1st. i tried running setup with -f parameter, and when i was asked to proceed with update i've just switched to another window and
    2nd. moved to /lib and looked there for firmware directory. I found "firmware-2.6.30.9" and a strange link to "firmware" that was leading to nowhere.
    3rd. I copied firmware-2.6.30.9 to "firmware-2.6.30.9" and the link started working.
    4th. so I switched back and continued installing the kernel. finally after several hours of trying it installed without any errors.

    P.S. sorry for English, I'm actually Russian.

Page 1 of 3 123 LastLast

Similar Threads

  1. Error updating kernel 2.6.34
    By StasNep in forum Beginners Forum
    Replies: 10
    Last Post: 10-18-2010, 03:09 AM
  2. Problems with apt-get, repositories, and updating.
    By Archangel-Amael in forum Frequently Asked Questions
    Replies: 0
    Last Post: 06-02-2010, 10:02 AM
  3. Updating/Upgrading Problems
    By jimbo79 in forum Beginners Forum
    Replies: 7
    Last Post: 03-10-2010, 11:28 PM
  4. Help with updating Kernel on BT3 USB!
    By stingray91 in forum OLD Newbie Area
    Replies: 1
    Last Post: 10-18-2009, 01:52 PM
  5. Problems updating BT4 with the script
    By michelinok in forum OLD BackTrack 4 (pre) Final
    Replies: 1
    Last Post: 08-11-2009, 09:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •