Results 1 to 6 of 6

Thread: Fatal server error

  1. #1
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    3

    Talking Fatal server error

    I've installed the vmware backtrack image on VMware« Player 3.1.0 build-261024, as I was to finish updating the VMware tool to enable unity mode, as soon as I typed startx, the system gave a fatal server error:

    Cannot run in framebuffer mode. Please specify busIDs for all framebuffer devices

    giving up.
    xinit: Connection refused (errno 111): unable to connect to X server
    xinit: No such process (errno 3): Server error.


    Can anyone help me? noob here.

  2. #2
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    11

    Default Re: Fatal server error

    You haven't given us any information to help you fix this. For example, had you ever booted backtrack on VMWare before? If so, had you ever tried startx before this? If this is just after installation, then the problem is probably a corrupted iso, and you'll need to get a new one. Before that though, check the forums. There was a way to check if your image was corrupted. If you had successfully booted into it before, then what did you do that time? And, if you were able to boot into X before, you may have accidentally reconfigured a file. Sometimes, you'll just have to re-install. However, a reboot might fix everything.

  3. #3
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    1

    Default Re: Fatal server error

    when its loaded type fixvesa then startx. then it shoud work.

  4. #4
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    3

    Default Re: Fatal server error

    I've booted backtrack on VMWare before. Booted with startx. I don't have a corrupted .iso because I've installed it dual boot with windows 7. I'm currently running the VMware image i've also downloaded.

    Backtrack4 works fine not until I try to install the vmware tool update. I didn't reconfigured any file. I followed the steps to install the vmware tool update.

    I've reinstalled it a dozen times already while updating the vmware tool cause i wanna run it in unity mode.

    After installing the update then reboot, then there goes the error if i try to type startx.

  5. #5
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    3

    Default Re: Fatal server error

    Quote Originally Posted by sasnik View Post
    when its loaded type fixvesa then startx. then it shoud work.
    OMG, the fixvesa works but when i tried now to enter the unity mode:

    -Unity is not supported on this operation system.
    -The guest operating system's resolution cannot be changed.


    Unlike before when I haven't yet updated the vmware tool it only displays the
    -The guest operating system's resolution cannot be changed.

    My host is win7 32bit ultimate. My resolution is 1280 by 800. When I installed XP on the my vmware, the unity mode works just fine but I'm really having a problem with BackTrack on unity.

  6. #6
    Just burned his ISO
    Join Date
    Sep 2010
    Posts
    3

    Default Re: Fatal server error

    Uinstall the Vmware tools by command
    Command: to uninstall
    ------------------------------
    vmware-uninstall-tools.pl
    ------------------------------

    Now that you've uninstalled the vmware tools reinstall them by before you reboot after you install the vmware tools. You will then need to reconfigure your xsever by command.
    Command:
    -----------------------------------------------------
    dpkg-reconfigure xserver-xorg
    -----------------------------------------------------

    When the first screen comes up select no to the framebuffer. For everything else after that question slect ok and do not change anything leave as defualt.

    After that fix the splash.
    NOTE: If you used 800x600 use
    Command:
    -----------------------------------------------------
    fix-splash800
    -----------------------------------------------------

    NOTE: If you used higher resolution then 800x600 use
    Command:
    -----------------------------------------------------
    fix-splash
    -----------------------------------------------------

    Now lastly reboot and you should be able to log into x. Now enjoy.

Similar Threads

  1. Fatal server error! Please help me =)
    By finalfight in forum Beginners Forum
    Replies: 3
    Last Post: 03-15-2010, 09:37 PM
  2. Fatal server error
    By gbiafora in forum Beginners Forum
    Replies: 4
    Last Post: 02-08-2010, 05:38 PM
  3. Fatal Server Error - no screens found
    By Tigerente in forum OLD Newbie Area
    Replies: 3
    Last Post: 01-20-2010, 03:50 PM
  4. Fatal Server Error - no screens found
    By Tigerente in forum OLD Newbie Area
    Replies: 0
    Last Post: 01-20-2010, 12:28 PM
  5. Fatal server error
    By maximus121 in forum OLD Newbie Area
    Replies: 6
    Last Post: 11-21-2008, 05:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •