Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Error on dual boot when choosing BackTrack 2

  1. #1
    Just burned his ISO
    Join Date
    Mar 2007
    Posts
    1

    Default Error on dual boot when choosing BackTrack 2

    I have partition my drive and have windows xp on hda1 and BackTrack 2 final installed on hda2. The first time I restarted after installing BackTrack I used LILO to create an option to boot either to windows or backtrack. When I choose BackTrack it starts booting but I get the following error:

    ***ERROR: Root partition has already been mounted read-write. Cannot check!

    For filesystem checking to work properly, your system must initially mount the root partition as read only. Please modify your kernel with 'rdev' so that it does. If you're booting with LILO, add a line:

    read-only

    to the Linux section in your /etc/lilo.conf and type 'lilo' to reinstall it.

    This will fix the problem *AND* eliminate this annoying message.

    Press Enter to continue.

    I followed the instructions in the post
    forums.remote-exploit.org/newthread.php?do=postthread&f=17

    What do I need to do to fix this error from appearing. I am not sure whether to change the read-write option back to read-only. I don't want to get all the write errors the post indicates you will get.

  2. #2
    Just burned his ISO
    Join Date
    Oct 2006
    Posts
    5

    Default

    same problem, same question

  3. #3
    Just burned his ISO
    Join Date
    Nov 2006
    Posts
    9

    Default

    Bump this, same problem also. As of now im just hitting enter to continue, any ideas anyone?

  4. #4
    Senior Member lund99's Avatar
    Join Date
    Feb 2010
    Posts
    142

    Default

    I just switched my lilo conf to read-only - no errors after that

  5. #5
    Just burned his ISO
    Join Date
    Oct 2006
    Posts
    5

    Default

    And I am just wondering! Read only means it reads only that partition...?!

  6. #6
    Just burned his ISO
    Join Date
    Nov 2006
    Posts
    17

    Default

    Quote Originally Posted by m-mode View Post
    And I am just wondering! Read only means it reads only that partition...?!
    the boot code checks the file system (ie. reads it) before mounting it read/write, at least that is what it should be doing. Try following the instructions supplied by the error message (RDEV). If it's still happening, post back.

    Here's some more info gleaned from google:

    9.12 EXT2-fs: warning: mounting unchecked filesystem.
    You need to run e2fsck (or fsck -t ext2 if you have the fsck front-end program) with the -a option to get it to clear the `dirty' flag, and then cleanly unmount the partition during each shutdown.

    The easiest way to do this is to get the latest fsck, umount and shutdown commands, available in Rik Faith's util-linux package. You have to make sure that your /etc/rc* scripts use them correctly.

    NB: don't try to check a filesystem that's mounted read-write -- this includes the root partition if you don't see

    VFS: mounted root ... read-only

    at boot time. You must arrange to mount the root filesystem readonly to start with, check it if necessary, and then remount it read-write. Read the documentation that comes with util-linux to find out how to do this.
    Note that you need to specify the -n option to mount to get it not to try to update /etc/mtab, since the root filesystem is still read-only and this will otherwise cause it to fail!

  7. #7
    Senior Member
    Join Date
    Apr 2006
    Posts
    154

    Default

    Quote Originally Posted by brighamr View Post
    the boot code checks the file system (ie. reads it) before mounting it read/write, at least that is what it should be doing. Try following the instructions supplied by the error message (RDEV). If it's still happening, post back.

    Here's some more info gleaned from google:

    9.12 EXT2-fs: warning: mounting unchecked filesystem.
    You need to run e2fsck (or fsck -t ext2 if you have the fsck front-end program) with the -a option to get it to clear the `dirty' flag, and then cleanly unmount the partition during each shutdown.

    The easiest way to do this is to get the latest fsck, umount and shutdown commands, available in Rik Faith's util-linux package. You have to make sure that your /etc/rc* scripts use them correctly.

    NB: don't try to check a filesystem that's mounted read-write -- this includes the root partition if you don't see

    VFS: mounted root ... read-only

    at boot time. You must arrange to mount the root filesystem readonly to start with, check it if necessary, and then remount it read-write. Read the documentation that comes with util-linux to find out how to do this.
    Note that you need to specify the -n option to mount to get it not to try to update /etc/mtab, since the root filesystem is still read-only and this will otherwise cause it to fail!

    Same problem here...please can you be more specific?
    I'm a total newbie, and i don't want to make some mistake...and my english is very poor!

    Again...thanks!

  8. #8
    Senior Member
    Join Date
    Apr 2006
    Posts
    154

    Default

    Quote Originally Posted by cormega View Post
    I just switched my lilo conf to read-only - no errors after that
    I've tryed your solution, but the problem persists

  9. #9
    Junior Member
    Join Date
    Feb 2010
    Posts
    27

    Default

    Just make sure the bt2 kernel line in your boot loader menu has ro at the end and not rw. It just needs to be mounted as read only. This is for grub anyway.

  10. #10
    Senior Member
    Join Date
    Apr 2006
    Posts
    154

    Question

    Quote Originally Posted by timstewart View Post
    Just make sure the bt2 kernel line in your boot loader menu has ro at the end and not rw. It just needs to be mounted as read only. This is for grub anyway.
    Yes...i've tryed, but i'm using lilo.
    Any info about this problem with lilo?
    It's very annoying!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •