Results 1 to 7 of 7

Thread: Wireless channel issue

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    7

    Default Wireless channel issue

    Hi all

    When using either Gerix or Grim, doing a deauth or similar, i get and error stating that my mon0(atheros 92xx) is on channel -1 and the target network/BSSD is on channel 11 (or what ever channel it is on)

    Is this normal and if not how can I remedy ?

    Thanks in advance

  2. #2
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default Re: Wireless channel issue

    What did the man pages or documentation and or google searching tell you?

  3. #3
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    7

    Default Re: Wireless channel issue

    LOL thanks, I needed that. I had already searched but obviously not well enough. a refined google search gave me the answer.

    Onward and upward

  4. #4
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    7

    Default Re: Wireless channel issue

    Ok so I have not yet solved this issue, was wondering if anyone else was havin the same problem.

    First off, this test is being done at home on my own AP set up for practice purposes

    Hardware:
    HP Probook 4520s
    Wireless card is Atheros 9285 with the compatwireless arth9k driver.
    Card goes into monitor mode no problem.

    command: airmon-ng start wlan0 11
    puts the card into monitor mode but the problem is the channel the card goes to (-1)

    I have looked on other forums and google and the problem has been mentioned before but no-one there seems to have a definitive solution.

    I know this may be a repeat of my OP but wanted to provide more details in the hope that someone here may have the answer because I cant get it to work, from command line or GUI.

    Picture attached

    Thanks in advance
    Immagini allegate Immagini allegate

  5. #5
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    3

    Default Re: Wireless channel issue

    Quote Originally Posted by GregSA View Post
    Ok so I have not yet solved this issue, was wondering if anyone else was havin the same problem.

    First off, this test is being done at home on my own AP set up for practice purposes

    Hardware:
    HP Probook 4520s
    Wireless card is Atheros 9285 with the compatwireless arth9k driver.
    Card goes into monitor mode no problem.

    command: airmon-ng start wlan0 11
    puts the card into monitor mode but the problem is the channel the card goes to (-1)

    I have looked on other forums and google and the problem has been mentioned before but no-one there seems to have a definitive solution.

    I know this may be a repeat of my OP but wanted to provide more details in the hope that someone here may have the answer because I cant get it to work, from command line or GUI.

    Picture attached

    Thanks in advance
    i am having the same issue target is on "ch 1" my card is on "ch 6" i have searched everywhere i can think of no answers.i noticed in " airodump-ng --help" there was a command to change the channel but i was too noob to figure it out .

    sorry guys but im lost any help please?¿?¿?

  6. #6
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    7

    Default Re: Wireless channel issue

    Ok I spent the weekend trying to resolve this and finnaly did.

    My guess is the compat-wireless drivers are not so compatible with the Atheros 92xx card. I booted my laptop with the BT4 live DVD and had no problems, channel no longer locks to -1.

    Uninstalled and re-installed BT4 and left the default drivers in place and so far so good

    Hope this helps anyone else with a similar problem

    Greg

  7. #7
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    14

    Default Re: Wireless channel issue

    There is an issue with a good portion of the newest compat-wireless drivers and the aircrack suite. Ticket is here: #742 (airodump-ng: channel handling is broken.)

Similar Threads

  1. Replies: 3
    Last Post: 07-06-2009, 05:38 AM
  2. Wireless USB Adaptor channel hopping problem
    By imported_charlescywong in forum OLD Newbie Area
    Replies: 3
    Last Post: 03-09-2009, 04:09 AM
  3. wlan0 is on channel 6, but the AP uses channel 9
    By Erika in forum OLD Newbie Area
    Replies: 20
    Last Post: 09-29-2008, 08:38 AM
  4. Wireless issue
    By F4LSE in forum OLD Newbie Area
    Replies: 11
    Last Post: 05-07-2008, 07:58 AM
  5. aireplay-ng channel issue
    By hhmatt in forum OLD BT3beta Software related issues
    Replies: 7
    Last Post: 02-21-2008, 03:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •