As any other week I do the following once a month. apt-get update and dist-upgrade.

After my last dist-upgrade my wireless card stopped working. I can not use it in Gerix.

I scratch my head a while. I even reinstalled BT4F fresh checked the card worked then proceeded to do apt-get update and dist-upgrade.

Here is what dist-upgrade applied.

Calculating upgrade... Done
The following packages will be REMOVED:
openvas-libnasl openvas-server
The following NEW packages will be installed:
alien bison cmake debhelper doxygen dvipdfmx firmware-ar9170 firmware-b43
firmware-ipw firmware-iwlwifi html2text libappconfig-perl libbeecrypt6
libbit-vector-perl libcarp-clan-perl libclass-base-perl
libclass-data-inheritable-perl libclass-makemethods-perl libdate-calc-perl
libgd-gd2-noxpm-perl libgnutls-dev libgraph-perl libgraphviz-perl
libheap-perl libio-stringy-perl libipc-run-perl libipc-shareable-perl
libjcode-pm-perl libkpathsea4 liblog-dispatch-perl liblog-log4perl-perl
libneon27 libole-storage-lite-perl libparams-validate-perl
libparse-recdescent-perl librpm4.4 libsmi2-common libsmi2ldbl
libspreadsheet-parseexcel-perl libspreadsheet-writeexcel-perl
libsql-translator-perl libtasn1-3-dev libtemplate-perl libunicode-map-perl
libxml-writer-perl linux-headers linux-headers-2.6.34 linux-image-2.6.34
linux-source-2.6.34 lmodern openvas-administrator openvas-cli
openvas-manager openvas-scanner rpm sqlfairy tex-common texlive-base
texlive-base-bin texlive-base-bin-doc texlive-common texlive-doc-base
texlive-latex-base texlive-latex-base-doc uuid-dev xmltoman
The following packages will be upgraded:
linux-image linux-source openvas-client openvas-libraries openvas-menu
wireshark wireshark-common
7 upgraded, 66 newly installed, 2 to remove and 0 not upgraded.
Need to get 197MB of archives.
After this operation, 1601MB disk space will be freed.
Do you want to continue [Y/n]? y

dmesg

padlock: VIA PadLock not detected.
usb 1-7: new high speed USB device using ehci_hcd and address 3
usb 1-7: configuration #1 chosen from 1 choice
phy1: Selected rate control algorithm 'minstrel'
Registered led device: rt73usb-phy1::radio
Registered led device: rt73usb-phy1::assoc
Registered led device: rt73usb-phy1::quality
usbcore: registered new interface driver rt73usb
rt73usb 1-7:1.0: firmware: requesting rt73.bin
phy1 -> rt2x00lib_request_firmware: Error - Failed to request Firmware.
rt73usb 1-7:1.0: firmware: requesting rt73.bin
phy1 -> rt2x00lib_request_firmware: Error - Failed to request Firmware.
device mon0 entered promiscuous mode

Kernel:
Linux bt 2.6.30.9 #1 SMP Tue Dec 1 21:51:08 EST 2009 i686 GNU/Linux

I am using a DELL 6400 which is old but use this card for packet injection to study pentest.

Can anyone help in getting my card working again. I have searched the forums but did not find anything related to my situation.