Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Linksys WUSB54GC -rt73usb- card not working after dist-upgrade

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Jan 2008
    Posts
    6

    Default Linksys WUSB54GC -rt73usb- card not working after dist-upgrade

    As any other week I do the following once a month. apt-get update and dist-upgrade.

    After my last dist-upgrade my wireless card stopped working. I can not use it in Gerix.

    I scratch my head a while. I even reinstalled BT4F fresh checked the card worked then proceeded to do apt-get update and dist-upgrade.

    Here is what dist-upgrade applied.

    Calculating upgrade... Done
    The following packages will be REMOVED:
    openvas-libnasl openvas-server
    The following NEW packages will be installed:
    alien bison cmake debhelper doxygen dvipdfmx firmware-ar9170 firmware-b43
    firmware-ipw firmware-iwlwifi html2text libappconfig-perl libbeecrypt6
    libbit-vector-perl libcarp-clan-perl libclass-base-perl
    libclass-data-inheritable-perl libclass-makemethods-perl libdate-calc-perl
    libgd-gd2-noxpm-perl libgnutls-dev libgraph-perl libgraphviz-perl
    libheap-perl libio-stringy-perl libipc-run-perl libipc-shareable-perl
    libjcode-pm-perl libkpathsea4 liblog-dispatch-perl liblog-log4perl-perl
    libneon27 libole-storage-lite-perl libparams-validate-perl
    libparse-recdescent-perl librpm4.4 libsmi2-common libsmi2ldbl
    libspreadsheet-parseexcel-perl libspreadsheet-writeexcel-perl
    libsql-translator-perl libtasn1-3-dev libtemplate-perl libunicode-map-perl
    libxml-writer-perl linux-headers linux-headers-2.6.34 linux-image-2.6.34
    linux-source-2.6.34 lmodern openvas-administrator openvas-cli
    openvas-manager openvas-scanner rpm sqlfairy tex-common texlive-base
    texlive-base-bin texlive-base-bin-doc texlive-common texlive-doc-base
    texlive-latex-base texlive-latex-base-doc uuid-dev xmltoman
    The following packages will be upgraded:
    linux-image linux-source openvas-client openvas-libraries openvas-menu
    wireshark wireshark-common
    7 upgraded, 66 newly installed, 2 to remove and 0 not upgraded.
    Need to get 197MB of archives.
    After this operation, 1601MB disk space will be freed.
    Do you want to continue [Y/n]? y

    dmesg

    padlock: VIA PadLock not detected.
    usb 1-7: new high speed USB device using ehci_hcd and address 3
    usb 1-7: configuration #1 chosen from 1 choice
    phy1: Selected rate control algorithm 'minstrel'
    Registered led device: rt73usb-phy1::radio
    Registered led device: rt73usb-phy1::assoc
    Registered led device: rt73usb-phy1::quality
    usbcore: registered new interface driver rt73usb
    rt73usb 1-7:1.0: firmware: requesting rt73.bin
    phy1 -> rt2x00lib_request_firmware: Error - Failed to request Firmware.
    rt73usb 1-7:1.0: firmware: requesting rt73.bin
    phy1 -> rt2x00lib_request_firmware: Error - Failed to request Firmware.
    device mon0 entered promiscuous mode

    Kernel:
    Linux bt 2.6.30.9 #1 SMP Tue Dec 1 21:51:08 EST 2009 i686 GNU/Linux

    I am using a DELL 6400 which is old but use this card for packet injection to study pentest.

    Can anyone help in getting my card working again. I have searched the forums but did not find anything related to my situation.

  2. #2
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default Re: Linksys WUSB54GC -rt73usb- card not working after dist-upgrade

    Probably not a bug.
    Thread moved.
    If someone else can verify that this is indeed a bug we can move it back.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  3. #3
    Very good friend of the forum TAPE's Avatar
    Join Date
    Jan 2010
    Location
    Europe
    Posts
    599

    Default Re: Linksys WUSB54GC -rt73usb- card not working after dist-upgrade

    Well I can confirm that the WUSB54GC does not work as it used to under the previous BT4.
    (same reported in the thread for the R1 release)

    On release of the new version, still an issue using the rt73usb drivers for the WUSB54GC,
    reportedly one should use the rt73 drivers, instead, however same do not seem to be
    included in the standard way.

    I would say it is a bug / driver issue with the new kernel.

    Page 3, my post --
    http://www.backtrack-linux.org/forum...release-3.html
    Last edited by TAPE; 07-16-2010 at 09:59 PM.

  4. #4
    Just burned his ISO
    Join Date
    Jan 2010
    Location
    Melbourne, Australia
    Posts
    22

    Default Re: Linksys WUSB54GC -rt73usb- card not working after dist-upgrade

    Hi

    had the same issue as above with my WUSB54GC after updating

    dmesg showed firmware was not working

    copied rt73.bin from /lib/firmware-2.6.30.9/ to /lib/firmware-2.6.34

    ie cp /lib/firmware-2.6.30.9/rt73.bin /lib/firmware-2.6.34/rt73.bin


    unplugged and replugged in WUSB54GC

    and all seems to be working

    root@bt:~# airmon-ng start wlan0


    Found 2 processes that could cause trouble.
    If airodump-ng, aireplay-ng or airtun-ng stops working after
    a short period of time, you may want to kill (some of) them!

    PID Name
    5089 dhclient3
    5283 dhclient3
    Process with PID 5283 (dhclient3) is running on interface wlan0


    Interface Chipset Driver

    wlan0 Ralink 2573 USB rt73usb - [phy0]
    (monitor mode enabled on mon0)

    root@bt:~# aireplay-ng -9 mon0
    15:23:52 Trying broadcast probe requests...
    15:23:52 Injection is working!
    15:23:54 Found 1 AP

    15:23:54 Trying directed probe requests...
    15:23:54 00:xx:xx:xx:xx:xx - channel: 1 - 'SSID' ( replaced mac with xx's)
    15:23:54 Ping (min/avg/max): 1.574ms/4.286ms/9.763ms Power: -60.73
    15:23:54 30/30: 100%

  5. #5
    Very good friend of the forum TAPE's Avatar
    Join Date
    Jan 2010
    Location
    Europe
    Posts
    599

    Default Re: Linksys WUSB54GC -rt73usb- card not working after dist-upgrade

    Thanks yours, I did see your previous post mentioning this, however since it got removed, I figured
    the info was not to the mods liking..

    Seems strange that any action should be required at all really.

  6. #6
    Just burned his ISO
    Join Date
    Jan 2010
    Location
    Melbourne, Australia
    Posts
    22

    Default Re: Linksys WUSB54GC -rt73usb- card not working after dist-upgrade

    No problems , Not sure why previous post was removed, Did above work for you ?

  7. #7
    Just burned his ISO
    Join Date
    Jan 2008
    Posts
    6

    Default Re: Linksys WUSB54GC -rt73usb- card not working after dist-upgrade

    bestia,

    I did what you mentioned and it did not resolve the issue.

    cp /lib/firmware-2.6.30.9/rt73.bin /lib/firmware-2.6.34/rt73.bin

    What I did see is the physical file was not in those directories and the OS did not complain about the file not there during the copy.

    I did a 'ls -l' on the directories and the file rt73.bin was not there.

    After doing a locate rt73.bin located in the older kernel directory, but after diung the updatedb the rt73.bin was no where to be found on the drive.

    Let me know your thoughts.

  8. #8
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    3

    Unhappy bug whit wicd start

    thx i will wait for the fix.
    bye
    Last edited by unamed; 07-20-2010 at 04:02 PM.

  9. #9
    Junior Member
    Join Date
    Feb 2010
    Posts
    27

    Default Re: Linksys WUSB54GC -rt73usb- card not working after dist-upgrade

    i downloaded RapidShare: 1-CLICK Web hosting - Easy Filehosting
    copied rt73.bin to /lib/firmware-2.6.34/rt73.bin rebooted and worked for me

  10. #10
    Junior Member creepykrawler's Avatar
    Join Date
    Jan 2010
    Location
    USA
    Posts
    56

    Default Re: Linksys WUSB54GC -rt73usb- card not working after dist-upgrade

    I confirmed that my HWUG1 ( rt73usb driver ) did not function anymore after a

    apt-get update; apt-get upgrade

    Kernel: 2.6.30.9
    I performed lizdainis' step and the adapter now works as it used to prior to update. Note: I copied it to the firmware-2.6.30.9 directory. So, the apt-get dist-upgrade not alone broke this driver but the update/upgrade does. Thanks!!!
    "Failing to plan is planning to fail"

Page 1 of 2 12 LastLast

Similar Threads

  1. Linksys WUSB54GC not working
    By imported_shane8002 in forum OLD Wireless
    Replies: 0
    Last Post: 01-29-2010, 09:58 AM
  2. apt-get dist-upgrade issue
    By RageLtMan in forum OLD BackTrack 4 Bugs and Fixes
    Replies: 13
    Last Post: 01-14-2010, 08:12 PM
  3. dist-upgrade and scapy broken
    By bofh28 in forum OLD BackTrack 4 Software Related Issues
    Replies: 4
    Last Post: 01-11-2010, 11:11 PM
  4. Error with Postgresql after recent dist-upgrade
    By imported_davehardy20 in forum OLD BackTrack 4 Bugs and Fixes
    Replies: 15
    Last Post: 11-20-2009, 10:23 AM
  5. Replies: 0
    Last Post: 11-17-2009, 09:08 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •