Results 1 to 4 of 4

Thread: Can't connect to the wireless connection after update

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Mar 2010
    Posts
    12

    Default Can't connect to the wireless connection after update

    I just bought a new HDD for my pc yesterday,so I decided to reinstall backtrack 4 into my system as i wanted to indulge myself in security and pen testing,right after I installed it,I try to connect to the internet using a few steps mention below:

    Code:
    1. /etc/init.d/networking start
    2. ifconfig wlan0 up
    3. iwconfig wlan0 mode managed essid "my ESSID"
    4. iwconfig wlan0 ap "myap"
    5. iwconfig  wlan0key "my WEP key"
    6. dhclient wlan0
    It was working fine and I was able to connect to the internet,and just like anyone,i start an update:

    Code:
     apt-get update
    apt-get upgrade
    after the upgrade,I shut down my pc,but later on when I try to boot up the backtrack,I can't seems to connect to the internet by using the method mention above.This is the error i encountered:

    Code:
    ~# ifconfig wlan0 up
    SIOCSIFFLAGS: No such file or directory
    Code:
    ~# iwlist scanning
    lo        Interface doesn't support scanning.
    
    eth0      Interface doesn't support scanning.
    
    wmaster0  Interface doesn't support scanning.
    
    wlan0     Interface doesn't support scanning : Network is down
    Code:
    ~# iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    wmaster0  no wireless extensions.
    
    wlan0     IEEE 802.11bg  ESSID:""
              Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
              Tx-Power=0 dBm
              Retry min limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              Link Quality:0  Signal level:0  Noise level:0
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    I've been lingering around this problem on and on,google for info for couple of hours,and try to modprobe -r rt73usb and rt2500usb,but still no luck,below I think is some info useful for you guys to help me up.

    Code:
    ~# lsmod
    
    Module                  Size  Used by
    ipv6                  239348  14
    sbs                    10940  0
    video                  18024  0
    output                  2388  1 video
    sbshc                   4500  1 sbs
    acpi_cpufreq            7808  0
    cpufreq_ondemand        7080  2
    cpufreq_powersave       1268  0
    cpufreq_stats           4728  0
    cpufreq_performance     1300  0
    cpufreq_conservative     7048  0
    freq_table              3476  3 acpi_cpufreq,cpufreq_ondemand,cpufreq_stats
    iptable_filter          2324  0
    ip_tables              10916  1 iptable_filter
    x_tables               13592  1 ip_tables
    parport_pc             24292  0
    lp                      9412  0
    parport                30572  2 parport_pc,lp
    arc4                    1588  2
    ecb                     2484  2
    snd_hda_codec_realtek   194936  1
    rt73usb                26104  0
    rt2500usb              21112  0
    rt2x00usb               9684  2 rt73usb,rt2500usb
    rt2x00lib              36436  3 rt73usb,rt2500usb,rt2x00usb
    led_class               3608  1 rt2x00lib
    snd_hda_intel          24712  3
    snd_hda_codec          57204  2 snd_hda_codec_realtek,snd_hda_intel
    input_polldev           3132  1 rt2x00lib
    mac80211              204728  2 rt2x00usb,rt2x00lib
    snd_hwdep               6776  1 snd_hda_codec
    snd_pcm_oss            37728  0
    snd_mixer_oss          14324  1 snd_pcm_oss
    snd_pcm                67704  4 snd_hda_intel,snd_hda_codec,snd_pcm_oss
    snd_seq_dummy           2424  0
    psmouse                41732  0
    serio_raw               5016  0
    cfg80211               61268  2 rt2x00lib,mac80211
    snd_seq_oss            27328  0
    snd_seq_midi            5952  0
    snd_rawmidi            19488  1 snd_seq_midi
    snd_seq_midi_event      5972  2 snd_seq_oss,snd_seq_midi
    snd_seq                47568  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
    snd_timer              19068  3 snd_pcm,snd_seq
    snd_seq_device          6048  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
    rtc_cmos               10156  0
    rtc_core               15792  1 rtc_cmos
    rtc_lib                 2388  1 rtc_core
    shpchp                 31560  0
    snd                    50468  16 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
    soundcore               5856  1 snd
    wmi                     5960  0
    snd_page_alloc          7836  2 snd_hda_intel,snd_pcm
    i2c_nforce2             6648  0
    evdev                   9120  8
    sg                     25064  0
    firewire_ohci          22648  0
    firewire_core          40640  1 firewire_ohci
    forcedeth              55136  0
    ata_generic             4536  0
    pata_amd               10744  0
    pata_acpi               3892  0
    fuse                   53104  7
    Code:
    ~# lsusb
    Bus 002 Device 003: ID 046d:c054 Logitech, Inc.
    Bus 002 Device 004: ID 04ca:002f Lite-On Technology Corp.
    Bus 002 Device 002: ID 058f:9360 Alcor Micro Corp. 8-in-1 Media Card Reader
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 003: ID 148f:2573 Ralink Technology, Corp. RT2501USB Wireless Adapter
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    If there's any other additional info that is needed by anyone,feel free to tell me,hope any expert could lend me a hand,thanks!

  2. #2
    Just burned their ISO
    Join Date
    Apr 2010
    Location
    Los Angeles
    Posts
    17

    Default Re: Can't connect to the wireless connection after update

    I am having same problem and I also have the RT2501 USB 802.11 adapter (EdiMax EW-7318USg). Worked fine prior to kernel update.

  3. #3
    My life is this forum Snayler's Avatar
    Join Date
    Jan 2010
    Posts
    1,418

    Default Re: Can't connect to the wireless connection after update

    I experienced the same problem a couple of days ago, but after talking with emgent about the issue, he updated the repositories, fixing the problem (at least for me). You can try to dist-upgrade your BT4 installation and see if it solves the problem.

  4. #4
    Just burned his ISO
    Join Date
    Jan 2009
    Posts
    1

    Default Re: Can't connect to the wireless connection after update

    I had the same problem with the intel drivers i.e. ipw2200. They appeared to be misnamed in the /lib/firmware directory i.e. ipw2.2... after doing the update/upgrade. Simply renaming them didn't work but downloading the latest version of the firmware from Intel® PRO/Wireless 2200BG Driver Firmware made things work again. Hopefully these files are unmodified for use with BT4.

Similar Threads

  1. Replies: 3
    Last Post: 01-24-2010, 10:26 AM
  2. Metsploit Update - Could not connect to server
    By karnivore in forum OLD Newbie Area
    Replies: 2
    Last Post: 01-05-2010, 02:54 PM
  3. can't connect to wireless connection using normal pass
    By rebrov in forum OLD BackTrack 4 General Support
    Replies: 1
    Last Post: 12-30-2009, 12:20 AM
  4. No wireless connection
    By shinjuku in forum OLD Latest Public Release - BackTrack4 Beta
    Replies: 9
    Last Post: 05-29-2009, 09:36 PM
  5. Replies: 24
    Last Post: 03-05-2009, 09:36 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •