Results 1 to 7 of 7

Thread: UFW issue.

  1. #1
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Location
    Behind the screen.
    Posts
    2,921

    Default UFW issue.

    Ok after yesterdays upgrade I noticed something wierd with UFW, I mean it will let me connect to my wireless but thats about it. It will not let me connect to any website or anything else, even my router page. After I turned it off it off everything works.

    I tried to reinstall it but I get a funny output like this:
    Code:
    apt-get remove ufw
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages will be REMOVED:
      gufw ufw
    0 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.
    After this operation, 1692kB disk space will be freed.
    Do you want to continue [Y/n]? y
    (Reading database ... 272732 files and directories currently installed.)
    Removing gufw ...
    Removing ufw ...
    INFO: using unknown version '/usr/bin/python2.6' (debian_defaults not up-to-date?)
    Processing triggers for menu ...
    Processing triggers for man-db ...
    using unknown version of python !? ...The same thing pops up when I try to reinstall it.
    Back|track giving machine guns to monkeys since 2007 !

    Do not read the Wiki, most your questions will not be answered there !
    Do not take a look at the: Forum Rules !

  2. #2
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    20

    Default Re: UFW issue.

    Hi Guys,
    I can confirm sickness's problem too, exactly the same thing here.
    Can connect to wifi, but no websites or router pages, but if I turn off ufw back to normal operation

    Something else I just found, if ufw is left enabled but you allow incoming traffic web browsing still works.
    I know this is probably just the same as turning ufw off, but thought it might help.
    Could the way ufw interacts with iptables in kernel .34 be different to kernel .30?
    Last edited by davehardy20; 07-03-2010 at 08:31 AM.

  3. #3
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default Re: UFW issue.

    Quote Originally Posted by davehardy20 View Post
    Could the way ufw interacts with iptables in kernel .34 be different to kernel .30?
    It could be and I would advise checking that error against ubuntu and or google for more info.

  4. #4
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default Re: UFW issue.

    Muts and I are unable to recreate the problem.

  5. #5
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Location
    Behind the screen.
    Posts
    2,921

    Default Re: UFW issue.

    To fix UFW just go to:
    Code:
    /etc/ufw/
    and edit before.rules and before6.rules, replace "-m conntrack --ctstate" to "-m state --state"

    That did it for me.
    Back|track giving machine guns to monkeys since 2007 !

    Do not read the Wiki, most your questions will not be answered there !
    Do not take a look at the: Forum Rules !

  6. #6
    Good friend of the forums
    Join Date
    Jan 2010
    Location
    outside chicago, il
    Posts
    442

    Default Re: UFW issue.

    I like the bleeding edge, but I don't like blood loss

  7. #7
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Location
    Behind the screen.
    Posts
    2,921

    Default Re: UFW issue.

    From what I've read there seems like the bug is fixed in ufw 0.24, should be cool do upgrade this in BT R1
    Back|track giving machine guns to monkeys since 2007 !

    Do not read the Wiki, most your questions will not be answered there !
    Do not take a look at the: Forum Rules !

Similar Threads

  1. Im new to all this and I am having an issue
    By JewSanta in forum OLD Newbie Area
    Replies: 3
    Last Post: 02-05-2010, 02:05 AM
  2. GUI issue
    By eidolonx in forum OLD Newbie Area
    Replies: 6
    Last Post: 07-22-2009, 09:10 PM
  3. Airodump-ng Issue + Aireplay-ng Issue
    By whiteice in forum OLD Newbie Area
    Replies: 1
    Last Post: 11-05-2008, 05:47 AM
  4. BT3 USB Issue
    By KamikazeMango in forum OLD Newbie Area
    Replies: 2
    Last Post: 12-31-2007, 10:10 PM
  5. Tor issue
    By Eron_the_Relentless in forum OLD Newbie Area
    Replies: 5
    Last Post: 07-26-2007, 05:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •