Results 1 to 5 of 5

Thread: Weird wicd autorun stuff

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    6

    Default Weird wicd autorun stuff

    I used "update-rc.d wicd defaults" to start networking automatically with booting BT4. It works as expected but I would really like to disable it (for the root at least ). How to do that?

    Also, I've noticed some weird stuff after using above-mentioned line;
    to use aircrack-ng suite, I have to stop dhclient and wpa_supplicant - makes sense, no problem.
    BUT, while using default "wlan0" with monitor mode enabled I can no longer use aireplay-ng to associate with my AP. Instead, I have to use mon0 at the end of the line and it works great.
    With "wlan0" I can no longer authenticate nor associate at all.

    I tried using ifconfig to disable/enable my wlan card and then used aireplay-ng with "wlan0", only to get obnoxious:

    Code:
    ioctl(SIOCSIWMODE) failed: Device or resource busy
    
    ARP linktype is set to 1 (Ethernet) - expected ARPHRD_IEEE80211,
    ARPHRD_IEEE80211_FULL or ARPHRD_IEEE80211_PRISM instead.  Make
    sure RFMON is enabled: run 'airmon-ng start wlan0 <#>'
    Sysfs injection support was not found either
    Again, with "mon0" it works great...
    What could be the problem?
    all things must end

  2. #2
    My life is this forum Snayler's Avatar
    Join Date
    Jan 2010
    Posts
    1,418

    Default Re: Weird wicd autorun stuff

    Quote Originally Posted by al_Alamm View Post
    Also, I've noticed some weird stuff after using above-mentioned line;
    to use aircrack-ng suite, I have to stop dhclient and wpa_supplicant - makes sense, no problem.
    BUT, while using default "wlan0" with monitor mode enabled I can no longer use aireplay-ng to associate with my AP. Instead, I have to use mon0 at the end of the line and it works great.
    With "wlan0" I can no longer authenticate nor associate at all.

    I tried using ifconfig to disable/enable my wlan card and then used aireplay-ng with "wlan0", only to get obnoxious:

    Code:
    ioctl(SIOCSIWMODE) failed: Device or resource busy
    
    ARP linktype is set to 1 (Ethernet) - expected ARPHRD_IEEE80211,
    ARPHRD_IEEE80211_FULL or ARPHRD_IEEE80211_PRISM instead.  Make
    sure RFMON is enabled: run 'airmon-ng start wlan0 <#>'
    Sysfs injection support was not found either
    Again, with "mon0" it works great...
    What could be the problem?
    The problem is that wlan0 is in managed mode while mon0 is in monitor mode. In order to use wlan0 in monitor mode use:
    Code:
    ifconfig wlan0 down
    iwconfig wlan0 mode monitor
    ifconfig wlan0 up

  3. #3
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    6

    Default Re: Weird wicd autorun stuff

    Thnx, but it didn't help.

    Using aireplay-ng with "wlan0" in order to associate with my AP still just ends up in sending authentication requests...
    all things must end

  4. #4
    My life is this forum Snayler's Avatar
    Join Date
    Jan 2010
    Posts
    1,418

    Default Re: Weird wicd autorun stuff

    Quote Originally Posted by al_Alamm View Post
    Thnx, but it didn't help.

    Using aireplay-ng with "wlan0" in order to associate with my AP still just ends up in sending authentication requests...
    Have you stopped mon0 intreface before running iwconfig wlan0 mode monitor?

  5. #5
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default Re: Weird wicd autorun stuff

    Quote Originally Posted by al_Alamm View Post
    I used "update-rc.d wicd defaults" to start networking automatically with booting BT4. It works as expected but I would really like to disable it (for the root at least ). How to do that?
    Try here
    Making scripts run at boot time with Debian
    As for actually disabling something for root is probably not going to work. root is by default able to do and access everything. Furthermore BT iis designed to be run as root.
    Last edited by Archangel-Amael; 01-20-2010 at 05:18 PM. Reason: Grammar

Similar Threads

  1. AWUS036H won't connect through Wicd
    By thebigbradwolf in forum HardWare Compatibility List
    Replies: 4
    Last Post: 04-04-2011, 10:16 AM
  2. Wicd wireless connection hang while using ALFA
    By King Skull in forum BackTrack Bugs
    Replies: 4
    Last Post: 02-27-2010, 10:02 AM
  3. wicd will not start
    By franky_402 in forum Beginners Forum
    Replies: 7
    Last Post: 01-29-2010, 07:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •