Results 1 to 10 of 10

Thread: Nvidia driver NOT working, failed to start X session

Threaded View

  1. #1
    Just burned his ISO
    Join Date
    Jun 2010
    Posts
    11

    Default Nvidia driver NOT working, failed to start X session

    Hi,

    I tried to install the Nvidia drivers on my Samsung R580 laptop: the video card is a GT330M.
    I ran:
    Code:
    apt-get install nvidia-driver
    then reboot (not sure if really needed) and typed:
    Code:
    startx
    but it didn't work. Here is the Xorg.0.log file:
    Code:
    X.Org X Server 1.5.2
    Release Date: 10 October 2008
    X Protocol Version 11, Revision 0
    Build Operating System: Linux 2.6.24-19-server i686 Ubuntu
    Current Operating System: Linux bt 2.6.30.9 #1 SMP Tue Dec 1 21:51:08 EST 2009 i686
    [...]
    (==) ServerLayout "Simple Layout"
    (**) |-->Screen "Screen 1" (0)
    (**) |   |-->Monitor "My Monitor"
    (**) |   |-->Device "VESA Framebuffer"
    (**) |-->Input Device "Mouse1"
    (**) |-->Input Device "Keyboard1"
    (==) Automatically adding devices
    (==) Automatically enabling devices
    (WW) The directory "/usr/X11R6/lib/X11/fonts/local/" does not exist.
            Entry deleted from font path.
    (WW) The directory "/usr/X11R6/lib/X11/fonts/misc/" does not exist.
            Entry deleted from font path.
    (WW) The directory "/usr/X11R6/lib/X11/fonts/75dpi/" does not exist.
            Entry deleted from font path.
    (WW) The directory "/usr/X11R6/lib/X11/fonts/100dpi/" does not exist.
            Entry deleted from font path.
    (WW) The directory "/usr/X11R6/lib/X11/fonts/Type1/" does not exist.
            Entry deleted from font path.
    (WW) The directory "/usr/X11R6/lib/X11/fonts/CID/" does not exist.
            Entry deleted from font path.
    (WW) The directory "/usr/X11R6/lib/X11/fonts/Speedo/" does not exist.
            Entry deleted from font path.
    (WW) The directory "/usr/X11R6/lib/X11/fonts/75dpi/" does not exist.
            Entry deleted from font path.
    (WW) The directory "/usr/X11R6/lib/X11/fonts/100dpi/" does not exist.
            Entry deleted from font path.
    (WW) The directory "/usr/X11R6/lib/X11/fonts/cyrillic/" does not exist.
            Entry deleted from font path.
    (WW) FontPath is completely invalid.  Using compiled-in default.
    (==) FontPath set to:
            /usr/share/fonts/X11/misc,
            /usr/share/fonts/X11/cyrillic,
            /usr/share/fonts/X11/100dpi/:unscaled,
            /usr/share/fonts/X11/75dpi/:unscaled,
            /usr/share/fonts/X11/Type1,
            /usr/share/fonts/X11/100dpi,
            /usr/share/fonts/X11/75dpi,
            /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType
    (==) ModulePath set to "/usr/lib/xorg/modules"
    (II) Open ACPI successful (/var/run/acpid.socket)
    (II) Loader magic: 0x81d9a40
    (II) Module ABI versions:
            X.Org ANSI C Emulation: 0.4
            X.Org Video Driver: 4.1
            X.Org XInput driver : 2.1
            X.Org Server Extension : 1.1
            X.Org Font Renderer : 0.6
    (II) Loader running on linux
    (--) using VT number 7
    
    (--) PCI:*(0@2:0:0) nVidia Corporation unknown chipset (0x0a29) rev 162, Mem @ 0xcc000000/0, 0xd0000000/0, 0xce000000/0, I/O @ 0x00002000/0, BIOS @ 0x????????/524288
    (II) System resource ranges:
            [0] -1  0       0xffffffff - 0xffffffff (0x1) MX[B]
            [1] -1  0       0x000f0000 - 0x000fffff (0x10000) MX[B]
            [2] -1  0       0x000c0000 - 0x000effff (0x30000) MX[B]
            [3] -1  0       0x00000000 - 0x0009ffff (0xa0000) MX[B]
            [4] -1  0       0xffffffff - 0xffffffff (0x1) MX[B]
            [5] -1  0       0x000f0000 - 0x000fffff (0x10000) MX[B]
            [6] -1  0       0x000c0000 - 0x000effff (0x30000) MX[B]
            [7] -1  0       0x00000000 - 0x0009ffff (0xa0000) MX[B]
            [8] -1  0       0xffffffff - 0xffffffff (0x1) MX[B]
            [9] -1  0       0x000f0000 - 0x000fffff (0x10000) MX[B]
            [10] -1 0       0x000c0000 - 0x000effff (0x30000) MX[B]
            [11] -1 0       0x00000000 - 0x0009ffff (0xa0000) MX[B]
            [12] -1 0       0xffffffff - 0xffffffff (0x1) MX[B]
            [13] -1 0       0x000f0000 - 0x000fffff (0x10000) MX[B]
            [14] -1 0       0x000c0000 - 0x000effff (0x30000) MX[B]
            [15] -1 0       0x00000000 - 0x0009ffff (0xa0000) MX[B]
            [16] -1 0       0xffffffff - 0xffffffff (0x1) MX[B]
            [17] -1 0       0x000f0000 - 0x000fffff (0x10000) MX[B]
            [18] -1 0       0x000c0000 - 0x000effff (0x30000) MX[B]
            [19] -1 0       0x00000000 - 0x0009ffff (0xa0000) MX[B]
            [20] -1 0       0xffffffff - 0xffffffff (0x1) MX[B]
            [21] -1 0       0x000f0000 - 0x000fffff (0x10000) MX[B]
            [22] -1 0       0x000c0000 - 0x000effff (0x30000) MX[B]
            [23] -1 0       0x00000000 - 0x0009ffff (0xa0000) MX[B]
            [24] -1 0       0xffffffff - 0xffffffff (0x1) MX[B]
            [25] -1 0       0x000f0000 - 0x000fffff (0x10000) MX[B]
            [26] -1 0       0x000c0000 - 0x000effff (0x30000) MX[B]
            [27] -1 0       0x00000000 - 0x0009ffff (0xa0000) MX[B]
            [28] -1 0       0x0000ffff - 0x0000ffff (0x1) IX[B]
            [29] -1 0       0x00000000 - 0x00000000 (0x1) IX[B]
            [30] -1 0       0x0000ffff - 0x0000ffff (0x1) IX[B]
            [31] -1 0       0x00000000 - 0x00000000 (0x1) IX[B]
            [32] -1 0       0x0000ffff - 0x0000ffff (0x1) IX[B]
            [33] -1 0       0x00000000 - 0x00000000 (0x1) IX[B]
            [34] -1 0       0x0000ffff - 0x0000ffff (0x1) IX[B]
            [35] -1 0       0x00000000 - 0x00000000 (0x1) IX[B]
            [36] -1 0       0x0000ffff - 0x0000ffff (0x1) IX[B]
            [37] -1 0       0x00000000 - 0x00000000 (0x1) IX[B]
            [38] -1 0       0x0000ffff - 0x0000ffff (0x1) IX[B]
            [39] -1 0       0x00000000 - 0x00000000 (0x1) IX[B]
            [40] -1 0       0x0000ffff - 0x0000ffff (0x1) IX[B]
            [41] -1 0       0x00000000 - 0x00000000 (0x1) IX[B]
    (II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
    (II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
    (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
    (II) "freetype" will be loaded. This was enabled by default and also specified in the config file.
    (II) "record" will be loaded by default.
    (II) "dri" will be loaded by default.
    (II) LoadModule: "dbe"
    
    (II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
    (II) Module dbe: vendor="X.Org Foundation"
            compiled for 1.5.2, module version = 1.0.0
            Module class: X.Org Server Extension
            ABI class: X.Org Server Extension, version 1.1
    (II) Loading extension DOUBLE-BUFFER
    (II) LoadModule: "extmod"
    
    (II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
    (II) Module extmod: vendor="X.Org Foundation"
            compiled for 1.5.2, module version = 1.0.0
            Module class: X.Org Server Extension
            ABI class: X.Org Server Extension, version 1.1
    (II) Loading extension SHAPE
    (II) Loading extension MIT-SUNDRY-NONSTANDARD
    (II) Loading extension BIG-REQUESTS
    (II) Loading extension SYNC
    (II) Loading extension MIT-SCREEN-SAVER
    (II) Loading extension XC-MISC
    (II) Loading extension XFree86-VidModeExtension
    (II) Loading extension XFree86-Misc
    (II) Loading extension DPMS
    (II) Loading extension TOG-CUP
    (II) Loading extension Extended-Visual-Information
    (II) Loading extension XVideo
    (II) Loading extension XVideo-MotionCompensation
    (II) Loading extension X-Resource
    (II) LoadModule: "type1"
    
    (WW) Warning, couldn't open module type1
    (II) UnloadModule: "type1"
    (EE) Failed to load module "type1" (module does not exist, 0)
    (II) LoadModule: "freetype"
    
    (II) Loading /usr/lib/xorg/modules//fonts/libfreetype.so
    (II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
            compiled for 1.5.2, module version = 2.1.0
            Module class: X.Org Font Renderer
            ABI class: X.Org Font Renderer, version 0.6
    (II) Loading font FreeType
    (II) LoadModule: "glx"
    
    (II) Loading /usr/lib/xorg/modules/extensions//libglx.so
    (II) Module glx: vendor="X.Org Foundation"
            compiled for 1.5.2, module version = 1.0.0
            ABI class: X.Org Server Extension, version 1.1
    (==) AIGLX enabled
    (==) Exporting typical set of GLX visuals
    (II) Loading extension GLX
    (II) LoadModule: "record"
    
    (II) Loading /usr/lib/xorg/modules/extensions//librecord.so
    (II) Module record: vendor="X.Org Foundation"
            compiled for 1.5.2, module version = 1.13.0
            Module class: X.Org Server Extension
            ABI class: X.Org Server Extension, version 1.1
    (II) Loading extension RECORD
    (II) LoadModule: "dri"
    
    (II) Loading /usr/lib/xorg/modules/extensions//libdri.so
    (II) Module dri: vendor="X.Org Foundation"
            compiled for 1.5.2, module version = 1.0.0
            ABI class: X.Org Server Extension, version 1.1
    (II) Loading extension XFree86-DRI
    (II) LoadModule: "nvidia"
    
    (II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
    (II) Module nvidia: vendor="NVIDIA Corporation"
            compiled for 4.0.2, module version = 1.0.0
            Module class: X.Org Video Driver
    (EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
    (EE) NVIDIA:     system's kernel log for additional error messages.
    (II) UnloadModule: "nvidia"
    (II) Unloading /usr/lib/xorg/modules/drivers//nvidia_drv.so
    (EE) Failed to load module "nvidia" (module-specific error, 0)
    (II) LoadModule: "mouse"
    
    (II) Loading /usr/lib/xorg/modules/input//mouse_drv.so
    (II) Module mouse: vendor="X.Org Foundation"
            compiled for 1.4.99.905, module version = 1.3.0
            Module class: X.Org XInput Driver
            ABI class: X.Org XInput driver, version 2.1
    (II) LoadModule: "kbd"
    
    (II) Loading /usr/lib/xorg/modules/input//kbd_drv.so
    (II) Module kbd: vendor="X.Org Foundation"
            compiled for 1.4.99.905, module version = 1.3.1
            Module class: X.Org XInput Driver
            ABI class: X.Org XInput driver, version 2.1
    (EE) No drivers available.
    
    Fatal server error:
    no screens found
    Enclosed is the generated xorg.conf file.
    Any idea of what went wrong and how to fix it?
    Thank you in advance for any hint!
    File allegati File allegati

Similar Threads

  1. nvidia-driver?
    By kevkid in forum Beginners Forum
    Replies: 1
    Last Post: 05-31-2010, 02:34 AM
  2. Installing Nvidia 8400M GS in Backtrack 4 prefinal failed !!
    By soheilvb in forum OLD BackTrack 4 NON working hardware
    Replies: 1
    Last Post: 10-26-2009, 08:23 PM
  3. Replies: 5
    Last Post: 09-02-2009, 03:09 PM
  4. Need Nvidia driver
    By -=DDOS=- in forum OLD Newbie Area
    Replies: 6
    Last Post: 05-28-2009, 09:55 PM
  5. Nvidia Driver
    By F4LSE in forum OLD Newbie Area
    Replies: 2
    Last Post: 05-04-2008, 01:53 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •