Results 1 to 10 of 11

Thread: db_autopwn error

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Jun 2010
    Posts
    8

    Default db_autopwn error

    I have spent the last few hours trying every guide I could find to fix the following error I encounter when running db_autopwn command. I already ran

    db_driver postgres
    db_create test
    msf > db_nmap 192.168.10.106 -p 445

    Starting Nmap 5.00 ( Nmap - Free Security Scanner For Network Exploration & Security Audits. ) at 2010-06-23 10:35 MST
    Interesting ports on 192.168.10.106:
    PORT STATE SERVICE
    445/tcp open microsoft-ds
    MAC Address: 00:00:00:00:00 (Intel Corporate)

    Nmap done: 1 IP address (1 host up) scanned in 0.36 seconds

    And EVERY time it comes back with the same error when I try to run the following command.

    msf > db_autopwn -t -p -e -s -b
    [-] Error while running command db_autopwn: No classes in Msf::Module::Platform for java!

    Call stack:
    /opt/metasploit3/msf3/lib/msf/core/module/platform.rb:60:in `find_platform'
    /opt/metasploit3/msf3/lib/msf/core/module/platform_list.rb:54:in `initialize'
    /opt/metasploit3/msf3/lib/msf/core/module/platform_list.rb:52:in `each'
    /opt/metasploit3/msf3/lib/msf/core/module/platform_list.rb:52:in `initialize'
    /opt/metasploit3/msf3/lib/msf/core/module/platform_list.rb:39:in `new'
    /opt/metasploit3/msf3/lib/msf/core/module/platform_list.rb:39:in `from_a'
    /opt/metasploit3/msf3/lib/msf/core/module/platform_list.rb:29:in `transform'
    /opt/metasploit3/msf3/lib/msf/core/module.rb:125:in `initialize'
    /opt/metasploit3/msf3/lib/msf/core/exploit.rb:276:in `initialize'
    /opt/metasploit3/msf3/lib/msf/core/exploit.rb:158:in `initialize'
    /opt/metasploit3/msf3/lib/msf/core/exploit/tcp.rb:283:in `initialize'
    /opt/metasploit3/msf3/lib/msf/core/auxiliary/report.rb:13:in `initialize'
    /opt/metasploit3/msf3/lib/msf/core/exploit/http.rb:453:in `initialize'
    /opt/metasploit3/msf3/lib/msf/core/exploit/http.rb:22:in `initialize'
    (eval):80:in `initialize'
    /opt/metasploit3/msf3/lib/msf/ui/console/command_dispatcher/db.rb:578:in `new'
    /opt/metasploit3/msf3/lib/msf/ui/console/command_dispatcher/db.rb:578:in `cmd_db_autopwn'
    /opt/metasploit3/msf3/lib/msf/core/module_manager.rb:230:in `call'
    /opt/metasploit3/msf3/lib/msf/core/module_manager.rb:230:in `each_module_list'
    /opt/metasploit3/msf3/lib/msf/core/module_manager.rb:203:in `each'
    /opt/metasploit3/msf3/lib/msf/core/module_manager.rb:203:in `each_module_list'
    /opt/metasploit3/msf3/lib/msf/core/module_manager.rb:120:in `each_module'
    /opt/metasploit3/msf3/lib/msf/ui/console/command_dispatcher/db.rb:577:in `cmd_db_autopwn'
    /opt/metasploit3/msf3/lib/msf/ui/console/command_dispatcher/db.rb:576:in `each'
    /opt/metasploit3/msf3/lib/msf/ui/console/command_dispatcher/db.rb:576:in `cmd_db_autopwn'
    /opt/metasploit3/msf3/lib/rex/ui/text/dispatcher_shell.rb:246:in `send'
    /opt/metasploit3/msf3/lib/rex/ui/text/dispatcher_shell.rb:246:in `run_command'
    /opt/metasploit3/msf3/lib/rex/ui/text/dispatcher_shell.rb:208:in `run_single'
    /opt/metasploit3/msf3/lib/rex/ui/text/dispatcher_shell.rb:202:in `each'
    /opt/metasploit3/msf3/lib/rex/ui/text/dispatcher_shell.rb:202:in `run_single'
    /opt/metasploit3/msf3/lib/rex/ui/text/shell.rb:141:in `run'
    ./msfconsole:112
    Anyone know how to solve this?
    Last edited by Teiknethal; 06-24-2010 at 03:38 AM.

  2. #2
    Member Krytical's Avatar
    Join Date
    Mar 2010
    Posts
    117

    Default Re: db_autopwn error

    I started getting that error as well, but was a new vmware install.. I could have done many things wrong...

  3. #3
    Just burned his ISO
    Join Date
    Jun 2010
    Posts
    8

    Default Re: db_autopwn error

    If it changes anything at all, I am running a fresh install dual boot. Not a VM or live CD.

  4. #4
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Location
    Behind the screen.
    Posts
    2,921

    Default Re: db_autopwn error

    I've made a tutorial about that.
    Back|track giving machine guns to monkeys since 2007 !

    Do not read the Wiki, most your questions will not be answered there !
    Do not take a look at the: Forum Rules !

  5. #5
    Just burned his ISO
    Join Date
    Jun 2010
    Posts
    3

    Default Re: db_autopwn error

    Sorry for being so impatient, I've started a similar thread, which hasn't been approved by mod so far.. So.. It goes like this:

    Still have problem with db_autopwn. No matter which database I use, the only thing I get is

    Code:
    Error while running command db_autopwn: No classes in Msf::Module::Platform for java!
    And yes, I've used every piece of advice given by User named *sickness*.
    What am I doing wrong?


    a foreigner here, sorry for my english
    '
    Thanks,
    bi11gates

    Everything was alright until 23.06.10 update,

    cheers,
    bi11gates
    Last edited by bi11gates; 06-24-2010 at 11:29 PM.

  6. #6
    Just burned his ISO
    Join Date
    Jun 2010
    Posts
    8

    Default Re: db_autopwn error

    bi11gates

    I solved the problem by completely reinstalling backtrack to my HDD. Upon re-installation I followed this guide EXACTLY. When that was done I opened up konsole and ran
    Code:
    msfupdate
    Let that finish updating Metasploit Framework and then try
    Code:
    db_nmap 192.168.x.xxx
    db_autopwn -p -t -e
    If it comes up with an error like "[-] Error while running command db_connect: Failed to connect to the database: F ATAL: role "root" does not exist" open up console and type this:
    Code:
     su - prostgres
    createuser -P
    ...Assign name as root, your root password, and type "y" for the supervisor role
    You should now be able to connect to the DB.

    Hope this helped.
    Last edited by Teiknethal; 06-25-2010 at 01:59 AM.

  7. #7
    Just burned his ISO
    Join Date
    Jun 2010
    Posts
    3

    Default Re: db_autopwn error

    Teiknethal,

    Indeed, after completed sickness' guide I had the:

    Code:
    [-] Error while running command db_connect: Failed to connect to the database: FATAL: role "root" does not exist
    problem, I'm having like 2 days old BT4, btw.

    Then, I've added a 'root' user, as You adviced (a big Thank You!). But.. now metasploit (fast-track, to be more precise) says:

    Code:
    msf > db_driver postgresql
    [*] Using database driver postgresql
    msf > db_destroy pentest
    dropdb: database removal failed: ERROR:  database "pentest" does not exist
    msf > db_connect pentest
    [-] Error while running command db_connect: Failed to connect to the database: FATAL:  database "pentest" does not exist
    So what, the hell, now am I doing wrong?

    Thanks,
    bi11gates

  8. #8
    Just burned his ISO
    Join Date
    Feb 2010
    Posts
    17

    Default Re: db_autopwn error

    This is a bug in metasploit. Since you havent told us the version you are running, i guess you updated metasploit.

    Bug can be found at Metasploit Framework - Bug #2147: db_autopwn -p -t -e - Metasploit Redmine Interface and is reported as resolved. So another update of metasploit should do it.

Similar Threads

  1. db_autopwn
    By some0ne in forum OLD Pentesting
    Replies: 1
    Last Post: 11-02-2009, 01:36 AM
  2. db_autopwn
    By some0ne in forum Discussioni Generali
    Replies: 2
    Last Post: 10-16-2009, 08:48 AM
  3. db_autopwn -p -t -e 192.168.2.7
    By virusc in forum OLD Newbie Area
    Replies: 2
    Last Post: 04-01-2009, 03:31 AM
  4. db_autopwn
    By JF1976 in forum OLD BackTrack 3 Final
    Replies: 3
    Last Post: 01-05-2009, 04:33 PM
  5. need help with db_autopwn
    By unlazyfree in forum OLD BackTrack v2.0 Final
    Replies: 12
    Last Post: 08-15-2007, 10:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •