Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Senao 2511CD Plus EXT2

  1. #11
    Just burned his ISO
    Join Date
    Jan 2007
    Posts
    15

    Default

    Here's a permanent fix for a hard drive install. If you are running a livecd, you'll need to do this every time. With a livecd, it's probably easier to do it the way the wiki says.

    rm /lib/modules/2.6.20-BT-PwnSauce-NOSMP/kernel/drivers/net/wireless/orinoco*
    rm /lib/modules/2.6.20-BT-PwnSauce-NOSMP/kernel/drivers/net/wireless/hermes.ko
    nano /etc/modprobe.d/blacklist

    comment out the following lines in /etc/modprobe.d/blacklist

    #blacklist hostap_cs
    #blacklist hostap_pci
    #blacklist hostap_plx
    #blacklist hostap

    insert card

    with some laptops you might need to

    pccardctl insert

    bt ~ # lsmod
    Module Size Used by
    hostap_cs 56500 1
    hostap 107540 1 hostap_cs
    Now im not a linux person so please be patient
    I assume that rm means remove, the problem is that now ive installed bt2 final the two folders suggested dont appear to be there!

    next problem comment out ?? the following lines, now id like to comment them out ) i assume its a way of ignoring them without deleting them but again how do i view the contents of the file they are in, I can find the file but not view it

    so close but yet so far

  2. #12
    Just burned his ISO
    Join Date
    Jan 2007
    Posts
    15

    Default

    well I think i figured out the first two parts
    just type the text into a bash screen
    then you get changed into the new directory and to comment out all I do is insert a # before each line
    but the last bit lsmod i get to the screen but can see no way of enetering the new info and now my card dont work at all
    ill try a few more times then reload bt2 to get back to the start

  3. #13
    Member
    Join Date
    Jan 2007
    Posts
    242

    Default

    The lsmod command "lists modules" that are currently loaded. You should see hostap and hostap_cs. If you see those modules loaded, your card will work. Run "iwconfig", from a prompt and see if you have a wlan0.

  4. #14
    Just burned his ISO
    Join Date
    Jan 2007
    Posts
    15

    Default

    Ok here is where im at, and its not far !
    after an install of bts final and following the excellent post on fixig dual boot with xp
    I have a machine that boots (almost, as it stops in the middle and says I have a write command in lilo and to fix it, pressing enter continues the boot). once bt has started if i use the original method of getting the senao card to work ie

    bt ~ # rmmod orinoco_cs
    bt ~ # rmmod orinoco
    bt ~ # rmmod hermes
    bt ~ # modprobe hostap_cs


    the card reports as being in monitor mode
    and if i type the command lsmod

    Module Size Used by
    hostap_cs 56500 0
    hostap 107540 1 hostap_cs


    note i get a 0 and not a 1 as suggested ??

    now if i try to pentest my ap i will recieve maybe 200 to 300 arp requests and on starting aircrck i find that i have only 200 ivs after an hour ! but the sent packet count is high.

    I have tried the permanent fix, as in

    rm /lib/modules/2.6.20-BT-PwnSauce-NOSMP/kernel/drivers/net/wireless/orinoco*
    rm /lib/modules/2.6.20-BT-PwnSauce-NOSMP/kernel/drivers/net/wireless/hermes.ko
    nano /etc/modprobe.d/blacklist

    comment out the following lines in /etc/modprobe.d/blacklist

    #blacklist hostap_cs
    #blacklist hostap_pci
    #blacklist hostap_plx
    #blacklist hostap

    but when i do the lsmod there are no hostap modules shown ?

    so the card will not start

    in desperation I rebooted with my netgear wg511t card and ran my normal method

    ifconfig wifi0 down
    macchanger --mac=00:11:22:33:44:55 wifi0
    wlanconfig ath0 create wlandev wifi0 wlanmode monitor
    airmon-ng start wifi0

    ifconfig ath1 down
    macchanger --mac=00:11:22:33:44:55 ath1
    ifconfig ath1 up


    Start capture.....
    airodump-ng -c <chan> -w <file> --ivs ath1

    Auth.......
    aireplay-ng -e <name> -a <mac> -h 00:11:22:33:44:55 --fakeauth 10 ath1

    Inject......
    aireplay-ng --arpreplay -b <mac> -h 00:11:22:33:44:55 ath1

    Crack.....
    aircrack-ng -0 -n 64 <capture>.ivs


    now the arps come flying as do the packets but after 2 mins only 5000 ivs and after 1 hour still only 5000 ivs but the dump file size grows all the time ?

    I would realy like to get my senao card working and if any one has a simple idiots guide or can spot a glaring error in my method please let me know

    using bt2 beta and the netgear card i cracked my ap in 20 mins so it can be done, also people here are reporting senao card injection so that can also be done, and I have updated the card to version 1.74

  5. #15
    tristania
    Guest

    Default

    It looks like im really not alone with that Packet-Injection problem on that nl-2511CD card ;(

    I looks like nobody know how to fix it, i searched the hole net etc. i gues. ;((

  6. #16
    tristania
    Guest

    Default

    is there maybe any patching of hostap or whatever needed to get the packet injection working?

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •