Results 1 to 4 of 4

Thread: Too many OS's multi-booting causing XP to BSOD

  1. #1
    Senior Member
    Join Date
    Jan 2006
    Posts
    1,334

    Default Too many OS's multi-booting causing XP to BSOD

    I had a problem with a laptop runnning 2x installs of XP and 1x install of Linux.
    I was also using Grub.

    I think the problem was more due to having 2 installs of XP on the same
    drive along with *nix, as it causes XP to start BSOD'ing (seems XP can't
    get on with itself, let alone other OS's), but it's possible the solution I
    found may be relevant here to, with a little tweaking?

    Basically, instead of using Grub as the boot manager, which in turn
    chainloads NTLDR when XP is to be booted, I reversed the chainload method.
    I.E. I set up NTLDR as the default boot manager which would then chainload
    Grub, when *nix is required.

    It's a very simple process.

    I assume, as usual, you have XP on the first primary (hda1)?

    After installing *nix, make sure that Grub is loaded to the boot sector of
    the partition it's installed on - NOT the MBR.

    If you aready have Grub installed in the MBR, just boot a Win disc and use

    Code:
    drive:> fdisk /mbr
    to wipe the MBR and preplace it with Win only.
    If you have more than 1 installation of XP, use bootcfg at the recovery
    console.

    Now you have XP booting again but, just for the moment, no *nix.

    Then use the BT cd to mount the *nix partition, chroot into it and re-
    install Grub to the Linux partition boot sector from there:

    On the box I was working on, *nix was on hda4 - you must edit this
    accordingly


    Code:
    # grub
     grub> root (hd0,3)
     grub> setup (hd0,3)
     grub> quit
    Now you have Grub in the boot sector of the *nix partition.
    The boot sector is the first 512bytes of a partition.
    Now just copy the first 512bytes to something like a usb stick, etc, using
    dd:

    Code:
    # dd if=/dev/hda2 of=grub.mbr bs=512 count=1
    Now boot back into XP and simply paste the file you made and copied to the
    usb stick (grub.mbr) into the root of the C: drive.

    Edit boot.ini to add the option to boot to *nix:

    The simplest way to get to boot.ini, in an editable state, is to go to
    System Properties ---> Advanced ---> Startup & Recovery ---> Edit.

    Add to the end of boot.ini :

    Code:
    C:\grub.mbr="Backtrack"            <------- or whatever label you want
    Now when you boot, NTLDR will be used, offering to boot XP or *nix.
    When you choose your *nix installaton it will chainload Grub.
    Grub will take over from there.

  2. #2
    Just burned his ISO
    Join Date
    Jan 2007
    Posts
    1

    Default

    thx for ur tutor

  3. #3
    Just burned his ISO
    Join Date
    Jan 2007
    Posts
    4

    Default

    Thanks for the tips. I like Grub also.
    Not so sure about to many istalls of XP though. In the past Ive had 7 installs of Win O/S and a Nix or two on the Hard drives at the same time and have not experianced the problem you talk about here.

    Not trying to be a pain just offering my own experiance with multi-booting lots of installs.

  4. #4
    Senior Member
    Join Date
    Jan 2006
    Posts
    1,334

    Default

    Quote Originally Posted by Berzerk View Post
    Thanks for the tips. I like Grub also.
    Not so sure about to many istalls of XP though. In the past Ive had 7 installs of Win O/S and a Nix or two on the Hard drives at the same time and have not experianced the problem you talk about here.

    Not trying to be a pain just offering my own experiance with multi-booting lots of installs.
    I'm not sure of the exact reason for this, as after rectifying it I didn't want to go back over reproducing it again, as it was a customers laptop.
    Basically, the sympton was both XP's BSOD'ing, always after a *nix boot, and was remedied by chainloading Grub (installed on *nix partition) from NTLDR in MBR.
    It seems it may have been simply a weird Ubuntu handling problem, although I'm not sure why! Most references I found to this exact problem were in the Ubuntu site/wiki!
    Yes, I agree with you, there shouldn't be a problem - I have never experienced this before with multi-boot systems, but it certainly seems to be a problem with Ubuntu being in the mix, if their wiki is anything to go by!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •