Results 1 to 7 of 7

Thread: exploit/windows/smb/ms08_067_netapi not working at latest MSF revision

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Jun 2010
    Posts
    3

    Default exploit/windows/smb/ms08_067_netapi not working at latest MSF revision

    Hi All,

    I was pen testing with autopwn on an XP SP3 VM these passed few days and exploit/windows/smb/ms08_067_netap got me a meterpreter session every single time!

    However when I msfupdate'd, this exploit no longer works? I haven't patched the VM's I was testing so all I can think of it's the latest revision of the framework b0rk this one?

    Let me know!

    Thanks,

    S.

    Yes this is definitely the case! Revision 9472 (The latest as of 10th June 2010) breaks this exploit. I downloaded the vmware image and loaded it up in VMWARE Server 2 and performed autopwn -p -t -e -r on my XP SP3 VM - I got a session straight away with this exploit.

    Then I typed msfupdate and tried to pwn the same XP VM and I got no sessions.....

    What's the story???
    Last edited by Archangel-Amael; 06-11-2010 at 11:29 AM.

  2. #2
    Junior Member g3ksan's Avatar
    Join Date
    Jan 2010
    Location
    Florida
    Posts
    93

    Default Re: exploit/windows/smb/ms08_067_netapi not working at latest MSF revision

    One thing I noticed when using this exploit, is that once you use it on a box, you will have to restart the popped box in order to run the exploit again. It is very weird. We had a bunch of people working on a Windows box in a MSF breakout session, we only had one Windows VM running.

    It works on the current revision, which is 9478.

    [edit] after talking to the guy that was in charge with the VMs that night, he had too restore the snapshot for some reason. I'm not exactly sure why that was.
    Last edited by g3ksan; 06-10-2010 at 10:48 PM.

  3. #3
    Just burned his ISO
    Join Date
    Jun 2010
    Posts
    3

    Thumbs down

    I have updated to revision 9496 and this still isn't working.

    On the otherhand, I have booted up the VM version of BT4 available for download and it's metasploit definitions are about 160 days old.

    It works every time with this version.

    Who to we report this to, to get it fixed?

    Should this be moved to bugs?
    Last edited by lupin; 06-12-2010 at 04:23 PM. Reason: Merging...

  4. #4
    Super Moderator lupin's Avatar
    Join Date
    Jan 2010
    Posts
    2,943

    Default Re: exploit/windows/smb/ms08_067_netapi not working at latest MSF revision

    Quote Originally Posted by stiofang View Post
    Who to we report this to, to get it fixed?
    The Metasploit Developers most likely, as long as you can confirm this is not BackTrack specific.

    Quote Originally Posted by stiofang View Post
    Should this be moved to bugs?
    Not unless it's a BackTrack specific issue.
    Capitalisation is important. It's the difference between "Helping your brother Jack off a horse" and "Helping your brother jack off a horse".

    The Forum Rules, Forum FAQ and the BackTrack Wiki... learn them, love them, live them.

  5. #5
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default Re: exploit/windows/smb/ms08_067_netapi not working at latest MSF revision

    Quote Originally Posted by stiofang View Post
    On the otherhand, I have booted up the VM version of BT4 available for download and it's metasploit definitions are about 160 days old.
    That is pretty relevant of irrelevant depending on how you look at things. Yes the definitions for metasploit as well as some other tools are old or even maybe outdated, however that is why there are update commands that one can use.

  6. #6
    Member Krytical's Avatar
    Join Date
    Mar 2010
    Posts
    117

    Default Re: exploit/windows/smb/ms08_067_netapi not working at latest MSF revision

    I think he means it is strange that it works with the old metasploit definitions and not the new ones, I don't think he was complaining about the old definitions...

  7. #7
    Just burned his ISO
    Join Date
    Jun 2010
    Posts
    3

    Default Re: exploit/windows/smb/ms08_067_netapi not working at latest MSF revision

    Yes I was saying that the old definitions work but the new ones don't for this particular exploit!

Similar Threads

  1. how to exploit windows 7?
    By kataibrengsek in forum Experts Forum
    Replies: 2
    Last Post: 05-28-2010, 12:15 AM
  2. MS08_067_netapi exploit
    By khianhui in forum Beginners Forum
    Replies: 3
    Last Post: 03-03-2010, 03:02 AM
  3. aktueller Windows Exploit
    By m-1-k-3 in forum Tutorials und Howtos
    Replies: 10
    Last Post: 01-29-2010, 08:11 AM
  4. BoF Exploit Windows XP SP0
    By mayfly in forum OLD Pentesting
    Replies: 1
    Last Post: 11-01-2009, 05:35 AM
  5. Replies: 0
    Last Post: 09-13-2009, 09:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •