hola a todos, he probado actualizar firefox con ubuntuzilla ya que lei por ahi que asi se podia actualizar, el problema es que me sale un error y nose que significa. si alguien me pudiera ayudar, soy nuevo en esto, hoy instale backtrack

el codigo completo:

1-
wget Download Ubuntuzilla: Mozilla Software Installer from SourceForge.net

2-
dpkg -i ubuntuzilla-4.6.1-0ubuntu1-i386.deb

3-
apt-get install -f

4-
root@bt:/# ubuntuzilla.py -a install -p firefox

Welcome to the Ubuntuzilla Firefox script version 4.6.1

Ubuntuzilla is built only for Ubuntu Linux and other distributions derived from Ubuntu (such as Linux Mint, e.g.)

This script will now install the latest release of the official Mozilla build of Firefox on your Linux system. If you run into any problems using this script, or have feature requests, suggestions, or general comments, please visit our website at SourceForge.net: ubuntuzilla

Retrieving the version of the latest release of Firefox from the Mozilla website...
The most recent release of Firefox is detected to be 3.6.3. Please make sure this is correct before proceeding. (You can confirm by going to Mozilla.org - Home of the Mozilla Project)
If no version number shows, if the version shown is not the latest, or if you would like to install an older release, press 'n', and you'll be given the option to enter the version manually. Otherwise, press 'y', and proceed with installation. [y/n]?
Please enter 'y' or 'n': y
Retrieving list of available localizations for Firefox ...
Please choose the localization (language) for Firefox. Enter the number of your choice from the list below. [If you do not see a list of localizations, please check the help section of our website at SourceForge.net: ubuntuzilla for steps you can take to resolve this problem.]
0. af 1. ar 2. as 3. be
4. bg 5. bn-BD 6. bn-IN 7. ca
8. cs 9. cy 10. da 11. de
12. el 13. en-GB 14. en-US 15. eo
16. es-AR 17. es-CL 18. es-ES 19. es-MX
20. et 21. eu 22. fa 23. fi
24. fr 25. fy-NL 26. ga-IE 27. gl
28. gu-IN 29. he 30. hi-IN 31. hr
32. hu 33. id 34. is 35. it
36. ja 37. ka 38. kk 39. kn
40. ko 41. ku 42. lt 43. lv
44. mk 45. ml 46. mr 47. nb-NO
48. nl 49. nn-NO 50. oc 51. or
52. pa-IN 53. pl 54. pt-BR 55. pt-PT
56. rm 57. ro 58. ru 59. si
60. sk 61. sl 62. sq 63. sr
64. sv-SE 65. ta-LK 66. ta 67. te
68. th 69. tr 70. uk 71. vi
72. zh-CN 73. zh-TW
Enter your choice of localization (integer, from 0 to 73): 16
You have chosen localization es-AR. Is that correct [y/n]?
Please enter 'y' or 'n': y

Updating repositories information with apt-get update. You may be prompted for your password.

Hit Index of / jaunty Release.gpg
Hit Index of / jaunty Release
Hit SUN Backtrack Linux Repository pwnsauce Release.gpg
Hit Index of / jaunty/main Packages
Hit SUN Backtrack Linux Repository pwnsauce Release
Hit SUN Backtrack Linux Repository pwnsauce/main Packages
Hit SUN Backtrack Linux Repository pwnsauce/microverse Packages
Hit SUN Backtrack Linux Repository pwnsauce/macroverse Packages
Hit SUN Backtrack Linux Repository pwnsauce/restricted Packages
Hit SUN Backtrack Linux Repository pwnsauce/universe Packages
Hit SUN Backtrack Linux Repository pwnsauce/multiverse Packages
Reading package lists... Done

Making sure that the repositories version of Firefox is installed...

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
firefox: Depends: libasound2 (> 1.0.18) but 1.0.17a-0ubuntu4 is to be installed
Depends: libdbus-glib-1-2 (>= 0.78) but 0.76-1 is to be installed
Depends: libgtk2.0-0 (>= 2.16.0) but 2.14.4-0ubuntu1 is to be installed
Depends: libnspr4-0d (>= 4.7.3-0ubuntu1~) but 4.7.1+1.9-0ubuntu4 is to be installed
E: Broken packages
sudo apt-get install firefox
Package installation failed. Cannot proceed.
Process returned code 100
Traceback (most recent call last):
File "/usr/local/bin/ubuntuzilla.py", line 1146, in <module>
bs.start()
File "/usr/local/bin/ubuntuzilla.py", line 209, in start
fi.start()
File "/usr/local/bin/ubuntuzilla.py", line 236, in start
self.install()
File "/usr/local/bin/ubuntuzilla.py", line 600, in install
self.aptgetMeasures()
File "/usr/local/bin/ubuntuzilla.py", line 381, in aptgetMeasures
self.util.execSystemCommand(executionstring="sudo apt-get install " + self.aptPackage, errormessage="Package installation failed. Cannot proceed.")
File "/usr/local/bin/ubuntuzilla.py", line 140, in execSystemCommand
raise SystemCommandExecutionError, "Command has not completed successfully. If this problem persists, please seek help at our website, " + self.version.url
__main__.SystemCommandExecutionError: Command has not completed successfully. If this problem persists, please seek help at our website, SourceForge.net: ubuntuzilla


creo que esta todo bien hasta que me sale lo que esta en negrita
y no entiendo nada que significa, tambien probe instalar la actualizacion desde Synaptic Package Manager y tampoco tube exito...