Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Fast-track can not connect to database after updating

  1. #1
    Just burned his ISO
    Join Date
    Jun 2010
    Posts
    1

    Default Fast-track can not connect to database after updating

    i have the feeling i am the only one with that problem. fast-track works great after a fresh install of backtrack but when i update my system it suddenly stops working and gives me the following error - Database not connected. Here is the output -

    =[ metasploit v3.4.1-dev [core:3.4 api:1.0]
    + -- --=[ 556 exploits - 267 auxiliary
    + -- --=[ 209 payloads - 23 encoders - 8 nops
    =[ svn r9452 updated today (2010.06.08)

    msf > db_destroy pentest
    dropdb: could not connect to database postgres: could not connect to server: No such file or directory
    Is the server running locally and accepting
    connections on Unix domain socket "/var/run/postgresql/.s.PGSQL.5432"?
    msf > db_create pentest
    [-]
    [-] Warning: The db_create command is deprecated, use db_connect instead.
    [-] The database and schema will be created automatically by
    [-] db_connect. If db_connect fails to create the database, create
    [-] it manually with your DBMS's administration tools.
    [-]
    createdb: could not connect to database postgres: could not connect to server: No such file or directory
    Is the server running locally and accepting
    connections on Unix domain socket "/var/run/postgresql/.s.PGSQL.5432"?
    [-] Error while running command db_create: Failed to connect to the database: could not connect to server: Connection refused
    Is the server running on host "127.0.0.1" and accepting
    TCP/IP connections on port 5432?


    Call stack:
    /pentest/exploits/framework3/lib/msf/ui/console/command_dispatcher/db.rb:1670:in `db_create_postgresql'
    /pentest/exploits/framework3/lib/msf/ui/console/command_dispatcher/db.rb:1222:in `send'
    /pentest/exploits/framework3/lib/msf/ui/console/command_dispatcher/db.rb:1222:in `cmd_db_create'
    /pentest/exploits/framework3/lib/rex/ui/text/dispatcher_shell.rb:246:in `send'
    /pentest/exploits/framework3/lib/rex/ui/text/dispatcher_shell.rb:246:in `run_command'
    /pentest/exploits/framework3/lib/rex/ui/text/dispatcher_shell.rb:208:in `run_single'
    /pentest/exploits/framework3/lib/rex/ui/text/dispatcher_shell.rb:202:in `each'
    /pentest/exploits/framework3/lib/rex/ui/text/dispatcher_shell.rb:202:in `run_single'
    /pentest/exploits/framework3/lib/rex/ui/text/shell.rb:141:in `run'
    /pentest/exploits/framework3/msfconsole:112
    msf > db_nmap 192.168.0.101
    [-] Database not connected
    msf > db_autopwn -p -t -e -r
    [-] Database not connected
    msf > sleep 5
    msf > jobs -K
    Stopping all jobs...
    msf >
    msf >
    msf >
    msf >
    msf > sessions -l

    Active sessions
    ===============

    No active sessions.


    I searched the forums for a solution but could not find one.

  2. #2
    Junior Member pigtail23's Avatar
    Join Date
    Jun 2010
    Location
    black hole
    Posts
    41

    Default Re: Fast-track can not connect to database after updating

    use sqlite3 as db_driver or search for the howto pgsql thread from sickness.

  3. #3
    Just burned his ISO
    Join Date
    Jun 2010
    Posts
    1

    Default

    I'm having the same issue. I've tried updating several different packages many different times with the same result. Can anybody advise?

    There seems to be a problem where a server.crt file is preventing postgresql from launching properly.

    Try editing the conf file and disabling SSL

    Code:
    nano /etc/postgresql/8.3/main/postgresql.conf
    and comment out the following line:
    Code:
    #ssl = true
    Then restart postgresql and poof - a temporary workaround.

    Code:
    /etc/init.d/postresql restart
    Last edited by lupin; 06-09-2010 at 03:33 AM. Reason: Merging...

  4. #4
    Just burned his ISO
    Join Date
    Aug 2008
    Posts
    8

    Default Re: Fast-track can not connect to database after updating

    I too, have this same issue. I have looked and looked all over google and elsewhere....no luck
    I hope that this was not already addressed, and we missed out on the fix?
    If so could someone please post a link.

    I know that the newer version will break the process, but how to get the old one back?

    Oh Wise Gods of BT, please shine your light of wisdom on this matter.
    Last edited by lupin; 06-09-2010 at 03:31 AM. Reason: Removed annoying formatting

  5. #5
    Just burned his ISO
    Join Date
    Jun 2010
    Posts
    1

    Default

    Same problem here..... running BT4 persistent from usb drive
    after a major update via fast-track, postgresql fails to start

    i tried ding444's method of disabling SSL but that didnt work either
    this is my console output after the restart of postgre

    Restarting PostgreSQL 8.3 database server: main*
    The PostgreSQL server failed to start. Please check the log output:
    2010-06-19 21:30:54 EDT FATAL: could no t create lock file "/var/run/postgresql/ .s.PGSQL.5432.lock": No such file or directory

    help plz, i really dont wanna re-do another persistent usb install

    lol what a dumbass I am, pigtail23 had the right idea by changing the db_driver.. works great now, and to those that dont know how to change the driver its easy...
    console output:

    msf > db_driver sqlite3[*] Using database driver sqlite3
    msf > db_destroy pentest[*] Deleting pentest...
    [-] The specified database does not exist
    msf > db_create pentest
    [-]
    [-] Warning: The db_create command is deprecated, use db_connect instead.
    [-] The database and schema will be created automatically by
    [-] db_connect. If db_connect fails to create the database, create
    [-] it manually with your DBMS's administration tools.
    [-][*] Creating a new database instance...[*] Successfully connected to the database[*] File: pentest
    Last edited by balding_parrot; 06-21-2010 at 02:11 AM.

  6. #6
    Just burned his ISO
    Join Date
    Jun 2010
    Posts
    3

    Default Re: Fast-track can not connect to database after updating

    I have the same problem as the first note. It worked fine after fresh install, then when I updated and ran an nmap, it went downhill from there.

    msf > db_create test1
    [-]
    [-] Warning: The db_create command is deprecated, use db_connect instead.
    [-] The database and schema will be created automatically by
    [-] db_connect. If db_connect fails to create the database, create
    [-] it manually with your DBMS's administration tools.
    [-]
    createdb: could not connect to database postgres: could not connect to server: No such file or directory
    Is the server running locally and accepting
    connections on Unix domain socket "/var/run/postgresql/.s.PGSQL.5432"?
    [-] Error while running command db_create: Failed to connect to the database: could not connect to server: Connection refused
    Is the server running on host "127.0.0.1" and accepting
    TCP/IP connections on port 5432?


    Call stack:
    /opt/metasploit3/msf3/lib/msf/ui/console/command_dispatcher/db.rb:1684:in `db_create_postgresql'
    /opt/metasploit3/msf3/lib/msf/ui/console/command_dispatcher/db.rb:1236:in `send'
    /opt/metasploit3/msf3/lib/msf/ui/console/command_dispatcher/db.rb:1236:in `cmd_db_create'
    /opt/metasploit3/msf3/lib/rex/ui/text/dispatcher_shell.rb:246:in `send'
    /opt/metasploit3/msf3/lib/rex/ui/text/dispatcher_shell.rb:246:in `run_command'
    /opt/metasploit3/msf3/lib/rex/ui/text/dispatcher_shell.rb:208:in `run_single'
    /opt/metasploit3/msf3/lib/rex/ui/text/dispatcher_shell.rb:202:in `each'
    /opt/metasploit3/msf3/lib/rex/ui/text/dispatcher_shell.rb:202:in `run_single'
    /opt/metasploit3/msf3/lib/rex/ui/text/shell.rb:141:in `run'
    ./msfconsole:112

  7. #7
    Just burned his ISO
    Join Date
    Jun 2010
    Posts
    3

    Default Re: Fast-track can not connect to database after updating

    If you haven't found the fix, here it is. mezo36 noted it on another thread:

    msf> db_driver sqlite3

  8. #8
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Location
    Behind the screen.
    Posts
    2,921

    Default Re: Fast-track can not connect to database after updating

    Omg read your errors next time it clearly sais postgreSQL, and I've made a tutorial on how to make postgreSQL work.
    Code:
    createdb: could not connect to database postgres: could not connect to server: No such file or directory
    Is the server running locally and accepting
    connections on Unix domain socket "/var/run/postgresql/.s.PGSQL.5432"?
    [-] Error while running command db_create: Failed to connect to the database: could not connect to server: Connection refused
    Is the server running on host "127.0.0.1" and accepting
    TCP/IP connections on port 5432?
    Back|track giving machine guns to monkeys since 2007 !

    Do not read the Wiki, most your questions will not be answered there !
    Do not take a look at the: Forum Rules !

  9. #9
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default Re: Fast-track can not connect to database after updating

    Not a BT bug.
    Moved.
    I don't believe rel1k even maintains or updates fasttrack any more.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  10. #10
    Just burned his ISO
    Join Date
    Mar 2011
    Posts
    2

    Default Re: Fast-track can not connect to database after updating

    Quote Originally Posted by sickness View Post
    Omg read your errors next time it clearly sais postgreSQL, and I've made a tutorial on how to make postgreSQL work.
    Code:
    createdb: could not connect to database postgres: could not connect to server: No such file or directory
    Is the server running locally and accepting
    connections on Unix domain socket "/var/run/postgresql/.s.PGSQL.5432"?
    [-] Error while running command db_create: Failed to connect to the database: could not connect to server: Connection refused
    Is the server running on host "127.0.0.1" and accepting
    TCP/IP connections on port 5432?
    can u plz paste ur totorial url here abt how to make postgresql!! im new to the form n need time to understand its where abouts !!

Page 1 of 2 12 LastLast

Similar Threads

  1. Updating aircrack with fast-track?
    By elmarko in forum OLD BackTrack 3 Final
    Replies: 0
    Last Post: 07-01-2009, 06:53 PM
  2. I was updating fast.track.py and I got this...
    By drakoth777 in forum OLD BT3final Support
    Replies: 2
    Last Post: 03-23-2009, 06:25 PM
  3. Problem updating Milw0rm via Fast-Track
    By imported_mobychien in forum OLD BT3final Support
    Replies: 4
    Last Post: 02-23-2009, 06:03 PM
  4. Fast-Track not updating?
    By Cr0wZz in forum OLD BT3final Support
    Replies: 11
    Last Post: 01-03-2009, 09:05 AM
  5. fast-track issues on updating
    By imported_spudgunman in forum OLD BT3final Bugs and Fixes
    Replies: 7
    Last Post: 07-01-2008, 01:50 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •