Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: ipw3945 monitor & promiscuous how-to

  1. #1
    Just burned his ISO
    Join Date
    Sep 2006
    Posts
    20

    Default ipw3945 monitor & promiscuous how-to

    Get the drivers from ipw3945 on sourceforge, you want the 1.1.0-pre2 versions

    Unzip ipw3945-linux-1.1.0-pre2.tgz
    Code:
    	% tar xzvf ipw3945-1.1.0-pre2.tgz
    	% cd ipw3945-1.1.0-pre2
    Here we will take a second to enable monitor mode.
    Code:
    % nano Makefile
    On line 29 change: # CONFIG_IPW3945_MONITOR=y
    To: CONFIG_IPW3945_MONITOR=y
    (just take out the # )

    A few lines after that is the same line but monitor says promiscuous, make the same change
    Ctrl X
    Yes to save
    Enter to overwrite
    Now in order to make the file we need to get an uncompiled kernel
    Download http://www.remote-exploit.org/kernel.mo

    Code:
    % uselivemod kernal.mo
    Now back at the shell prompt
    Code:
    % make
    If it complains about the ieeee80211 file, you can either ignore it and do what it says to add that line in, or
    Code:
    	% tar xzvf ipw3945-1.0.0.tgz
    	% cd ipw3945-1.0.0
    	% make
    Now we need to do the firmware
    Code:
    	% wget http://bughost.org/ipw3945/ucode/ipw3945-ucode-1.13.tgz .
    	% tar xzvf ipw3945-ucode-1.13.tgz 
    	# cp ipw3945-ucode-1.13/ipw3945.ucode /lib/firmware
    Now we have to get the daemon to work with our card
    Code:
    	% wget http://bughost.org/ipw3945/daemon/ipw3945d-1.7.18.tgz .
    	% tar xzvf ipw3945d-1.7.18.tgz
    	# cp ipw3945d-1.7.18/x86/ipw3945d /sbin
    Now we can load them
    Code:
    	# ./load debug=0
    Now check out iwconfig… now u can do a iwconfig eth1 mode monitor. and i tested ethereal and it DID go to promiscuous (when just doing monitor mode in 1.0.0 drivers it said it could not get that mode)

  2. #2
    bugmenot11235
    Guest

    Default

    I'm kinda new to this sorry but when you say now we can load them am I meant to navigate to a different directory and type

    ./load debug=0

    because at the moment I get 'no such file or directory'

    EDIT:

    Not sure if it was the ipw3945-1.1.0-pre2 directory so I tried but a succesful load but then iwconfig shows

    lo no wireless extensions.

    sit0 no wireless extensions.

    ppp0 no wireless extensions.

  3. #3
    Just burned his ISO
    Join Date
    Sep 2006
    Posts
    7

    Default

    You must go to ipw3945-1.1.0-pre2 directory and then type ./load debug=0

  4. #4
    Just burned his ISO
    Join Date
    Sep 2006
    Posts
    20

    Default

    yea you must be in the ipw3945 folder when you run the ./load. i know i just made a script (for each wireless signal i get on) on my desktop to:
    Code:
    cd..
    cd ipw3945-1.1.0-pre2
    ./load debug=0
    iwconfig eth1 essid ______
    ifconfig eth1 up
    dhcpcd eth1
    this way it just reloads the drivers each time incase its in monitor mode or what not.





    when you run ./load debug=0 it should say in that text that it finds the card... if not then its not loading correctly... look at teh text

  5. #5
    Just burned his ISO
    Join Date
    Sep 2006
    Posts
    5

    Default

    hi, i'm new at this so any help would be apprecieated.

    When I download the kernel.mo file, does this file have to be moved to a specific directory before the 'uselivemod kernel.mo' command can be used?

    After following all the steps and typing in ./load debug=0, I keep getting the following error. Can anyone tell me what i'm doing wrong?

    Unloaded: ipw3945 ieee80211 ieee80211_crypt
    WARNING: Could not open '/lib/modules/2.6.15.6/kernel/net/ieee80211/ieee80211_crypt.ko': No such file or directory
    FATAL: Could not open '/lib/modules/2.6.15.6/net/ieee80211/ieee80211.ko': No such file or directory
    insmod: can't read './ipw3945.ko': No such file or directory
    Load failed.
    ipw3945d - regulatory daemon
    Copyright (C) 2005-2006 Intel Corporation. All rights reserved.
    version: 1.7.18
    2006-09-24 15:27:30: ERROR: opening /sys/bus/pci/drivers/ipw3945:
    No such file or directory (2)
    2006-09-24 15:27:30: ERROR: Could not find Intel PRO/Wireless 3945ABG Network Connection

  6. #6
    Just burned his ISO
    Join Date
    Sep 2006
    Posts
    7

    Default

    Did you "install" kernel.mo? I can see that your linux can't find your kernel directory or you dont have ieee80211 installed on system

    Did you install ieee80211?

  7. #7
    Just burned his ISO
    Join Date
    Sep 2006
    Posts
    5

    Default

    ah, I didn't do that. All I did was download kernel.mo, and used the 'uselivemod kernel.mo' I think i missed the next step for the iee80211 file.

  8. #8
    bugmenot11235
    Guest

    Default

    I do every listed but when I type 'iwconfig' eth1 is not listed. Any ideas?

  9. #9
    Just burned his ISO
    Join Date
    Sep 2006
    Posts
    20

    Default

    make sure you do the ./load debug=0

    read what it says and that it does find the card... if it does theres no reason why iwconfig shouldn't show it. make sure eth1 is the card maybe its eth2 or something, so doing just iwconfig should show everything and what works.

  10. #10
    Just burned his ISO
    Join Date
    Sep 2006
    Posts
    5

    Default

    ok, i have a little probelm again. i'm able to switch between monitor mode now, but when i scan for networks, it says it didn't find anything. do i have to enable the network card somehow?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •