Results 1 to 5 of 5

Thread: Need to update drivers?

  1. #1
    Just burned his ISO
    Join Date
    Jun 2010
    Location
    Australia
    Posts
    6

    Post Need to update drivers?

    Okay so i am now running BT4 LiveCD, and this time it has recognized my WLAN card but will not show up in airmon-ng. So i typed a few commands with dmesg and came up with this:

    root@bt:~# dmesg | grep wlan
    root@bt:~# dmesg | grep eth
    Driver 'st' needs updating - please use bus_type methods
    Driver 'sd' needs updating - please use bus_type methods
    Driver 'sr' needs updating - please use bus_type methods
    jme: JMicron JMC2XX ethernet driver version 1.0.4
    eth0: Tigon3 [partno(BCM95784M) rev 5784100] (PCI Express) MAC address 00:22:19:fa:93:d4
    eth0: attached PHY is 5784 (10/100/1000Base-T Ethernet) (WireSpeed[1])
    eth0: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] TSOcap[1]
    eth0: dma_rwctrl[76180000] dma_mask[64-bit]
    root@bt:~# dmesg | grep roadcom
    b43-phy0: Broadcom 4312 WLAN found (core revision 15)
    Broadcom 43xx driver loaded [ Features: PLR, Firmware-ID: FW13 ]
    I figure that my wireless card is the one that came up under "dmesg | grep roadcom" and it does not mention a problem there but when i typed in " dmesg lspci" it came up with this:

    b43-phy0: Broadcom 4312 WLAN found (core revision 15)
    b43-phy0 ERROR: FOUND UNSUPPORTED PHY (Analog 6, Type 5, Revision 1)
    b43: probe of ssb0:0 failed with error -95
    Broadcom 43xx driver loaded [ Features: PLR, Firmware-ID: FW13 ]
    So is it i need a new driver or sothimeng else? And if so where can i find the driver?

    Cheers,

  2. #2
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default Re: Need to update drivers?

    You can try the nes backtrack r1 release which has better broadcom support. There is a thread in the Hardware section on it.

  3. #3
    Just burned his ISO
    Join Date
    Jun 2010
    Location
    Australia
    Posts
    6

    Red face Re: Need to update drivers?

    But if it can see the device would it just need an upgrade? I've found the driver for it, and ran through installing it but since its a liveCD it doesnt stick?
    Would I be correct? I'm going to try install it on my external hard drive thats lying round see what happens there.

    Cheers

  4. #4
    Just burned his ISO
    Join Date
    May 2010
    Posts
    10

    Default Re: Need to update drivers?

    Quote Originally Posted by Dreweh View Post
    But if it can see the device would it just need an upgrade? I've found the driver for it, and ran through installing it but since its a liveCD it doesnt stick?
    Would I be correct? I'm going to try install it on my external hard drive thats lying round see what happens there.

    Cheers
    There is a script in the HOWTO section that loads your BT4 .iso and allows you to make changes to it via the terminal (such as apt-get update/upgrade, install drivers or programs, edit .conf files, etc), then you type exit when you are done and it recompresses it as a modified .iso. You just burn the new .iso to a dvd and you have an up-to-date BT4 livecd.

  5. #5
    Just burned his ISO
    Join Date
    Jun 2010
    Location
    Australia
    Posts
    6

    Smile Re: Need to update drivers?

    Quote Originally Posted by Dynatoz View Post
    There is a script in the HOWTO section that loads your BT4 .iso and allows you to make changes to it via the terminal (such as apt-get update/upgrade, install drivers or programs, edit .conf files, etc), then you type exit when you are done and it recompresses it as a modified .iso. You just burn the new .iso to a dvd and you have an up-to-date BT4 livecd.
    Oh okay, thanks mate, will have a look through it, and just post a thread if im having any problems, thanks again

Similar Threads

  1. Cannot update Ralink chipset drivers
    By exus69 in forum Beginners Forum
    Replies: 0
    Last Post: 05-05-2010, 01:45 PM
  2. how to update drivers in a live usb bt4 final!!!
    By scrapkilla321 in forum Beginners Forum
    Replies: 0
    Last Post: 05-05-2010, 04:10 AM
  3. Replies: 2
    Last Post: 04-24-2010, 02:45 AM
  4. HOW TO update to sqlite-3.5.x (update : 3.5.3)
    By balding_parrot in forum OLD Tutorials and Guides
    Replies: 33
    Last Post: 03-18-2009, 06:14 PM
  5. how to apt get update ? and ati drivers ?
    By Kloro in forum OLD Newbie Area
    Replies: 2
    Last Post: 05-02-2007, 10:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •