Page 2 of 8 FirstFirst 1234 ... LastLast
Results 11 to 20 of 73

Thread: Howto: Configure Network Cards

  1. #11
    Just burned his ISO
    Join Date
    Feb 2007
    Posts
    3

    Default /etc/network/interfaces

    That is because of your /etc/network/interfaces file. If you want them permanently configured with a static ip address you must modify this file in order to achive it. For example, if you have eth0 and in the file you find something like this 'iface eth0 inet dhcp' that means that dhcp will run everytime you start networking. Instead you should prefer something like that 'iface eth0 inet static' <- this way you teach eth0 to be static, and in the line below 'address xxx.xxx.xxx.xxx', 'netmask xxx.xxx.xxx.xxx' and 'gateway xxx.xxx.xxx.xxx' all of them in separated lines.

    Hope this helps!

    Quote Originally Posted by michelinok
    Just a thing that i didn't understand: i've manually configured my cards, but everytime i reboot, the dhcpd commands are executed (a dhcpd for each card). How can i disable this and make the configurations permanent?

    Again...sorry for my english!

  2. #12
    Just burned his ISO
    Join Date
    Feb 2007
    Posts
    1

    Default Great thread mate

    I'm new to Linux and backtrack in particular and I just wanted to say that this is one very useful thread indeed. Sorted my LAN difficulties in seconds.

    Cheers xatar

  3. #13
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    20

    Default

    many thanks its help us good

  4. #14
    Just burned his ISO
    Join Date
    Mar 2007
    Posts
    1

    Default Need Help on acer acpi how to....

    I m using acer aspire 3682NWXCI...

    my problem:

    how to setup acer acpi on back track.?

    i had try a few time it wont work..it give...error no such device..

    pls help me.....

  5. #15
    Junior Member
    Join Date
    Oct 2006
    Posts
    37

    Default

    Hello All,

    I have a question here. When BT 2 is booting it comes to a point that it tries to get an IP by doing a dhcpcd on all available network interfaces. I connect wireless to my AP which is obviously secured with a wep key . So the dhcpcd fails and adds quite some seconds to the boot time. When BT 2 is up and running i can configure my wlan card, so set my wep key and connect to my AP succesfully.

    What i actually want is to predefine my wep key and SSID , so that BT 2 can automatically connect to my AP at boot time and only does a dhcpcd on this particular NIC. Is there a way to achieve this?

    Thanks in advance!

  6. #16
    Member
    Join Date
    Jan 2006
    Posts
    66

    Default

    I would recomend using the nodhcp boot code then creating a script with your desired commands (don't forget make it executable) and adding it to /etc/rc.d/rc.local (the last script to be run on startup) with something like this:

    Code:
    # Start wireless config script
    if [ -x /path/to/script.sh ]; then
       . /path/to/script.sh
    fi
    Alternately you can use the /etc/rc.d/rc.wireless script. You can find some info on editing the conf file here (section 23.4).
    ---
    Useful HowTo Threads <-- Why do people think I'm joking when I link this?

  7. #17
    Junior Member
    Join Date
    Oct 2006
    Posts
    37

    Default

    Thanks for your help. Is there also a way to make the nodhcp default?

  8. #18
    Member
    Join Date
    Jan 2006
    Posts
    66

    Default

    Honestly I just commented out that section of code in /etc/rc.d/rc.inet1 like this:

    Code:
    #! /bin/sh
    # /etc/rc.d/rc.inet1
    # This script is used to bring up the various network interfaces.
    #
    # Modified for SLAX by Tomas M. <http://slax.linux-live.org>
    #
    # /proc/cmdline 'nodhcp' option added by Martin J. Muench <mjm@remote-exploit.org>
    
    if [ "$1" = "start" -o "$1" = "" ]; then
    
       ifconfig lo down 2>/dev/null
       /sbin/ifconfig lo 127.0.0.1 2>/dev/null
       /sbin/route add -net 127.0.0.0 netmask 255.0.0.0 lo 2>/dev/null
    
       # check if 'nodhcp' was set
    #   if ! grep -w -q "nodhcp" /proc/cmdline ; then
    #
    #       for eth in `ls /sys/class/net | grep -v sit`; do
               # check if dhcpcd is not already running for $eth interface,
               # in that case it was started by hotplug so don't start it again
    #          if [ "$eth" != "lo" -a ! -e /etc/dhcpc/dhcpcd-$eth.pid ]; then
    #              echo "/sbin/dhcpcd -d -t 10 $eth"
    #              /sbin/dhcpcd -d -t 10 $eth
    #          fi
    #       done
    #   fi
    
    fi
    ---
    Useful HowTo Threads <-- Why do people think I'm joking when I link this?

  9. #19
    Junior Member
    Join Date
    Oct 2006
    Posts
    37

    Default

    Well...i added my card in the /etc/rc.d/rc.wireless.conf with all applicapble parameters. I also modified /etc/rc.d/rc.inet1 just like you did, to disable the dhcpcd on boot. However, after a reboot, the laptop came to the point that the mousepointer appeared and then it automatically shutdown....

    Even the failsafe & a attempt to boot from livecd failed with the same result . So i ended up reinstalling BT 2 all over again.

    So people, Don't try this at home

  10. #20
    Just burned his ISO
    Join Date
    May 2007
    Posts
    4

    Default

    Hallo
    I seached a long time here in the forum. Maybe I´m blind. I just want to get my wireless to work. Because I find a bit hard with all the commands in the shell (Windows Noob I know) I tryed with the
    Code:
    wlassistant
    .
    It says:
    Code:
    Radio of your wireless card is off. Would you like to turn it on?
    . I click
    Code:
    Yes
    Nothing happens.

    Before that, I tryed to config by the console. Thats what I did:
    Code:
    ifconfig eth0 up
    ifconfig eth0 192.168.1.54 netmask 255.255.255.0
    route add default gw 192.168.1.1 eth0
    echo nameserver 192.168.1.1 > /etc/resolv.conf
    After that a symbole in the 'tray' appears for a network connection.

    But I can´t go on any websites with f.fox.

    Strange thing is, that the LED from my WLAN is NOT on. (Normally orange light)

    I have a ACER Notebook: Travel MAte 291 LMi
    Wlan Card: ipw2100 (Intel Pro Wireless 2100)

    And if I type
    Code:
    iwconfig -a
    there comes
    Code:
    No such device
    .
    If I type only
    Code:
    iwconfig
    I have
    Code:
    eth0      unassorciated ESSID:off/any Nickname:"ipw2100
                 Mode:Managed   Channel=0  Acsess Point 00:00:00:00:00:00
                 Bit Rate=0 kb/s      Tx-Power:off  
                 .....
    I had this Problem with windows, too long time ago. I needed a driver for this switch on the notebook.

    Maybe you have another Tutorial link for me. This Tutorial is very usefull although my inet doesn't work

Page 2 of 8 FirstFirst 1234 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •