Results 1 to 2 of 2

Thread: db_driver mysql problem

  1. #1
    Just burned his ISO
    Join Date
    May 2010
    Posts
    1

    Default db_driver mysql problem

    I'm running BT4, and updated it today. Trying to run mysql as a database for all my tests. I issue the db_driver command it tells me that postgresql and sqlite3 are available. All I have to do is issue the "gem install mysql" and "apt-get install libmysqlclient-dev" commands. When I issue the "gem install mysql" command I get a string of these messages:
    "no definitoin for time-set year
    no definition fo error_errno
    .....
    Successfully installed mysql-2.8.1"

    When I issue the "apt-get install libmysqlclient-dev" command, it tells me it's already loaded.

    I can start mysql and create a metasploit database from the command line in Linux. I just can't seem to access it thru msfconsole. Any ideas?

  2. #2
    Just burned his ISO
    Join Date
    May 2010
    Posts
    9

    Default Re: db_driver mysql problem

    i had the same prob today, i couldnt get postgres working either for some reason, even though it is installed.

    in the end i used

    db_driver sqlite3

    works like a charm

Similar Threads

  1. MYSQL database Problem
    By CeEe4 in forum Beginners Forum
    Replies: 6
    Last Post: 04-03-2011, 04:39 PM
  2. metasploit , db_driver: command not found
    By Justs in forum Beginners Forum
    Replies: 2
    Last Post: 03-30-2010, 03:44 AM
  3. MYSQL T_T Big problem with ussers
    By Debci in forum OLD Newbie Area
    Replies: 2
    Last Post: 09-08-2009, 10:21 PM
  4. Problem loading db_sqlite3, calling db_driver
    By kazalku in forum OLD Latest Public Release - BackTrack4 Beta
    Replies: 11
    Last Post: 06-21-2009, 06:23 PM
  5. Mysql problem
    By bluster in forum OLD Newbie Area
    Replies: 6
    Last Post: 09-19-2008, 08:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •