Sorry if this has been posted before but I could not find it searching the forums. When I enter apt-get update I always get:

Err SUN Backtrack Linux Repository pwnsauce/multiverse Translation-en_US
Could not resolve 'archive.offensive-security.com'
Reading package lists... Done
W: Failed to fetch http://archive.offensive-security.co...ce/Release.gpg Could not resolve 'archive.offensive-security.com'

I know its not my internet connection because I downloaded backtrack 4 final on the same connection. I believe its just a settings issue. I am running backtrack in virtualbox on windows 7. Thanks in advance for any help.