Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 48

Thread: Howto get Madwifi-ng drivers to work properly!

  1. #11
    Just burned his ISO
    Join Date
    Feb 2006
    Posts
    8

    Default

    Packet injection works with this patch (just slow, as mentioned). Nice.

  2. #12
    Just burned his ISO
    Join Date
    Feb 2006
    Posts
    1

    Default

    Hi,

    I try to update my madwifi driver to madwifi-ng-r1452-20060217 (http://snapshots.madwifi.org/madwifi...0060217.tar.gz)

    airmon.sh show ath0\t\unknown\t\tunknown (Monitor Mode Not Supported)

    So, Madwifi is correctly install I think,
    but, I don't understand what to patch ...

    when I type :
    Code:
    patch -Np1 -i aircrack-2.41-madwifing.patch
    Code:
    missing header for unified diff at line 3 of patch
    can't find file to patch at input line 3
    Perhaps you used the wrong -p or --strip option?
    The text leading up to this was:
    --------------------------
    |--- aireplay.c 2005-11-12 06:00:00.000000000 -0500
    |+++ aircrack-2.4/linux/aireplay.c      2006-02-15 11:38:46.000000000 -0500
    --------------------------
    File to patch:
    Can you explain how to patch and what to patch ? the Madwifi Driver or Aireplay ?

  3. #13
    Just burned his ISO
    Join Date
    Feb 2006
    Posts
    8

    Default

    You're supposed to patch the aireplay.c file, located in the aircrack 2.41 sources.

  4. #14
    Junior Member
    Join Date
    Feb 2006
    Posts
    72

    Default

    Related to the previous page:

    modprobe ath_pci

    after compiling the drivers and installing give me this error:

    FATAL: Error inserting ath_pci (/lib/modules/2.6.12.2/net/ath_pci.ko) Unknowsn symbol in module, or unknown parameter (see dmesg)



    Any idea whats going on here?

  5. #15
    Just burned his ISO
    Join Date
    Feb 2006
    Posts
    17

    Default

    Grrr. I can't get it to work. I have a Netgear WG511T like you do kirmet. Any suggestions? I tried insmod and modprobe -- no luck. Both ath0 and wifi0 are there -- I just get the dreaded (MONITOR MODE NOT SUPPORTED), but when I bring it up in monitor mode from wlanconfig both lights are blinking together. What gives???

    Maybe I need to check the firmware rev.

    OK, what's really weird is if I do a iwconfig ath0 shows up as "Mode:Monitor". ?!?!?!?

  6. #16
    Junior Member
    Join Date
    Feb 2006
    Posts
    72

    Default

    I am also using a NG511T

    Thats exactly what I have happening right now. I do hope someone can give me an idea here. I have both an ath0 and wifi0.

  7. #17
    Just burned his ISO
    Join Date
    Feb 2006
    Posts
    17

    Default

    Nice -- we both suck!

    Fack -- I'll just install Win2K on another partition and make sure the firmware is up to date.

  8. #18
    Just burned his ISO
    Join Date
    Feb 2006
    Posts
    8

    Default

    Quote Originally Posted by TheGreatVirus
    Related to the previous page:

    modprobe ath_pci

    after compiling the drivers and installing give me this error:

    FATAL: Error inserting ath_pci (/lib/modules/2.6.12.2/net/ath_pci.ko) Unknowsn symbol in module, or unknown parameter (see dmesg)



    Any idea whats going on here?

    Try first unplug your device, then:

    rmmod -w ath_pci

    then, when standing in the dir where ath_pci.ko is, do:

    insmod ath_pci.ko

    then plug in your device...

  9. #19
    Just burned his ISO
    Join Date
    Feb 2006
    Posts
    17

    Default

    Yeah, doesn't seem to work for me. But -- I'll try it again.

    Why would using insmod vs modprobe make that big of a difference? I'm curious.

  10. #20
    Junior Member
    Join Date
    Feb 2006
    Posts
    72

    Default

    I got that working now I found that I just neede to reboot after compiling and installing the driver.


    Im now at the exact same issue as windexh8er now.

Page 2 of 5 FirstFirst 1234 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •