Hi to everybody,
i'm neophyte about bt4 and i'm having some problems with my new wireless adapter. it's a logilink wireless N with chipset ralink rt2870.
I cannot connect to the network, i cannot use it in monitor mode, exacly i cannot use airodump to view the available networks. Moreover i have read that it cannot support injection by default but it's possible to obtain it using one patch. Can anyone help me? Thank's a lot!!
ps.. i have found the following post to install new drivers but i obtain some errors during the complilation process.
this is the link:

RT2870 BT4 Guide (working!!!) - Remote Exploit Forums

and this is the output of the make command:

root@bt:~/rt2870-2.6.27-apocolipse# make
make -C tools
make[1]: Entering directory `/root/rt2870-2.6.27-apocolipse/tools'
gcc -g bin2h.c -o bin2h
make[1]: Leaving directory `/root/rt2870-2.6.27-apocolipse/tools'
/root/rt2870-2.6.27-apocolipse/tools/bin2h
cp -f os/linux/Makefile.6 /root/rt2870-2.6.27-apocolipse/os/linux/Makefile
make -C /lib/modules/2.6.30.9/build SUBDIRS=/root/rt2870-2.6.27-apocolipse/os/linux modules
make[1]: Entering directory `/usr/src/linux-source-2.6.30.9'

WARNING: Symbol version dump /usr/src/linux-source-2.6.30.9/Module.symvers
is missing; modules will have no dependencies and modversions.

CC [M] /root/rt2870-2.6.27-apocolipse/os/linux/../../common/md5.o
CC [M] /root/rt2870-2.6.27-apocolipse/os/linux/../../common/mlme.o
CC [M] /root/rt2870-2.6.27-apocolipse/os/linux/../../common/rtmp_wep.o
CC [M] /root/rt2870-2.6.27-apocolipse/os/linux/../../common/action.o
CC [M] /root/rt2870-2.6.27-apocolipse/os/linux/../../common/ba_action.o
CC [M] /root/rt2870-2.6.27-apocolipse/os/linux/../../common/cmm_data.o
CC [M] /root/rt2870-2.6.27-apocolipse/os/linux/../../common/rtmp_init.o
CC [M] /root/rt2870-2.6.27-apocolipse/os/linux/../../common/rtmp_tkip.o
CC [M] /root/rt2870-2.6.27-apocolipse/os/linux/../../common/cmm_sync.o
CC [M] /root/rt2870-2.6.27-apocolipse/os/linux/../../common/eeprom.o
CC [M] /root/rt2870-2.6.27-apocolipse/os/linux/../../common/cmm_sanity.o
CC [M] /root/rt2870-2.6.27-apocolipse/os/linux/../../common/cmm_info.o
CC [M] /root/rt2870-2.6.27-apocolipse/os/linux/../../common/cmm_wpa.o
CC [M] /root/rt2870-2.6.27-apocolipse/os/linux/../../common/dfs.o
CC [M] /root/rt2870-2.6.27-apocolipse/os/linux/../../sta/assoc.o
CC [M] /root/rt2870-2.6.27-apocolipse/os/linux/../../sta/aironet.o
CC [M] /root/rt2870-2.6.27-apocolipse/os/linux/../../sta/auth.o
CC [M] /root/rt2870-2.6.27-apocolipse/os/linux/../../sta/auth_rsp.o
CC [M] /root/rt2870-2.6.27-apocolipse/os/linux/../../sta/sync.o
CC [M] /root/rt2870-2.6.27-apocolipse/os/linux/../../sta/sanity.o
CC [M] /root/rt2870-2.6.27-apocolipse/os/linux/../../sta/rtmp_data.o
CC [M] /root/rt2870-2.6.27-apocolipse/os/linux/../../sta/connect.o
CC [M] /root/rt2870-2.6.27-apocolipse/os/linux/../../sta/wpa.o
CC [M] /root/rt2870-2.6.27-apocolipse/os/linux/../../os/linux/rt_linux.o
CC [M] /root/rt2870-2.6.27-apocolipse/os/linux/../../os/linux/rt_profile.o
/root/rt2870-2.6.27-apocolipse/os/linux/../../os/linux/rt_profile.c: In function ‘RTMPReadParametersHook’:
/root/rt2870-2.6.27-apocolipse/os/linux/../../os/linux/rt_profile.c:778: error: ‘struct task_struct’ has no member named ‘fsuid’
/root/rt2870-2.6.27-apocolipse/os/linux/../../os/linux/rt_profile.c:779: error: ‘struct task_struct’ has no member named ‘fsgid’
/root/rt2870-2.6.27-apocolipse/os/linux/../../os/linux/rt_profile.c:780: error: ‘struct task_struct’ has no member named ‘fsuid’
/root/rt2870-2.6.27-apocolipse/os/linux/../../os/linux/rt_profile.c:780: error: ‘struct task_struct’ has no member named ‘fsgid’
/root/rt2870-2.6.27-apocolipse/os/linux/../../os/linux/rt_profile.c:1369: error: ‘struct task_struct’ has no member named ‘fsuid’
/root/rt2870-2.6.27-apocolipse/os/linux/../../os/linux/rt_profile.c:1370: error: ‘struct task_struct’ has no member named ‘fsgid’
make[2]: *** [/root/rt2870-2.6.27-apocolipse/os/linux/../../os/linux/rt_profile.o] Error 1
make[1]: *** [_module_/root/rt2870-2.6.27-apocolipse/os/linux] Error 2
make[1]: Leaving directory `/usr/src/linux-source-2.6.30.9'
make: *** [LINUX] Error 2