Results 1 to 9 of 9

Thread: Metasploit Updaten

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Apr 2010
    Posts
    6

    Default Metasploit Updaten

    Hallo

    Ich habe jetzt Metasploit auf Ubuntu 10.04 habe alles installiert und ins Verzeichnis /opt/metsploit kopiert laut dieser Anleitung Metasploit
    Aber wenn ich dan die msfconsole öffne und svn update ausführe steht nur da:
    Code:
    Code:
         =[ metasploit v3.3.3-release [core:3.3 api:1.0]
    + -- --=[ 481 exploits - 220 auxiliary
    + -- --=[ 192 payloads - 22 encoders - 8 nops
    
    msf > svn update[*] exec: svn update
    
    Überspringe ».«
    msf >
    Mfg Pc0017

  2. #2
    Moderator fancy's Avatar
    Join Date
    Jan 2010
    Posts
    204

    Default Re: Metasploit Updaten

    svn update gibst du auch nicht, in der msf Console ein, sondern in der shell.
    Also:

    cd /pentest/exploits/framework3
    svn update

  3. #3
    Just burned his ISO
    Join Date
    Apr 2010
    Posts
    6

    Default Re: Metasploit Updaten

    ich habe nach der Ubuntu Anleitung gemacht. Dieses Verzeichnis gibt es bei mir gar nicht

  4. #4

    Default Re: Metasploit Updaten

    dann versuchs doch damit in verzeichniss von Metasploit ?

  5. #5

    Default Re: Metasploit Updaten

    hier ein ganz hilfreiches msf3 update-script (dirty, aber tut seinen Job ;-)

    Code:
    #!/bin/bash
    
    cd /opt/metasploit3/msf3
    
    if [ "$(svn info |grep 'Date:' |cut -d" " -f4)" == "$(date +%F)" ]; then
     printf "\n..Seems you have already updated the msf3 source today!\n\n"
     read -p "Do it again (y/n)?" -e check
     if [ $check == "n" ]; then
     echo ""
     exit 0
     fi
    fi
    
    svn update
    
    # compile & update lorcon2
    printf "\n..check for lorcon2..."
    if [ ! -d "/opt/metasploit3/msf3/external/ruby-lorcon2/lorcon" ]; then
      svn co https://802.11ninja.net/svn/lorcon/trunk/ lorcon
      cd /opt/metasploit3/msf3/external/ruby-lorcon2/lorcon
      ./configure && make && make install
      cd ../ && ruby extconf.rb
      make && make install
    elif [ -n "$(find /opt/metasploit3/msf3/external/ruby-lorcon2/lorcon/Makefile -mtime +61)" ]; then
     printf "\n...lorcon2 source older than 8 weeks, will update..."
     cd /opt/metasploit3/msf3/external/ruby-lorcon2/lorcon
     svn update
     make clean && ./configure
     make && make install
     cd ..
     make clean && ruby extconf.rb
     make && make install
    else
     printf "\n..looks okay...\n"
    fi
    
    printf "\n..check for ratproxy..."
    cd /opt/metasploit3/msf3/external/ratproxy
    if [ ! -d "ratproxy" ]; then
      printf "\nupppss, no ratproxy, will download, patch & install.."
      wget http://ratproxy.googlecode.com/files/ratproxy-1.58.tar.gz
      tar xvf ratproxy-1.58.tar.gz
      cd /opt/metasploit3/msf3/external/ratproxy
      patch -b -d ratproxy < ratproxy_wmap.diff
      cd /opt/metasploit3/msf3/external/ratproxy/ratproxy
      make clean && make
    elif [ ! -f "/opt/metasploit3/msf3/external/ratproxy/ratproxy/ratproxy.c.orig" ]; then
      cd /opt/metasploit3/msf3/external/ratproxy
      patch -b -d ratproxy < ratproxy_wmap.diff
      cd /opt/metasploit3/msf3/external/ratproxy/ratproxy
      make clean && make
    else
     printf "\n..looks okay...\n"
    fi
    
    printf "\n..compile & install pcaprub..."
    if [ ! -f "/opt/metasploit3/msf3/external/pcaprub/pcaprub.so" ]; then
     cd /opt/metasploit3/msf3/external/pcaprub
     ruby extconf.rb && make && make install
    else
     printf "\n..looks okay...\n"
    fi
    
    printf "\n..compile & install serialport..."
    if [ ! -f "/opt/metasploit3/msf3/external/serialport/serialport.so" ]; then
      cd /opt/metasploit3/msf3/external/serialport
      ruby extconf.rb && make && make install
    else
     printf "\n..looks okay...\n"
    fi
    
    printf "\n..see if we do have some basic msf3 scripts in /opt/metasploit3/msf3/_STUFF...\n"
     printf "\n..looks okay...\n"
    fi
    
    printf "\n..see if we do have some basic msf3 scripts in /opt/metasploit3/msf3/_STUFF...\n"
    if [ ! -d "/opt/metasploit3/msf3/_STUFF/" ]; then
      mkdir /opt/metasploit3/msf3/_STUFF
    elif [ ! -f "/opt/metasploit3/msf3/_STUFF/karma.rc" ]; then
      cd /opt/metasploit3/msf3/_STUFF
      wget http://metasploit.com/users/hdm/tools/karma.rc
    elif [ ! -f "/opt/metasploit3/msf3/_STUFF/makeapplet.sh" ]; then
      cd /opt/metasploit3/msf3/_STUFF
      wget http://spl0it.org/files/makeapplet.sh
    else
     printf "\n..looks okay...\n"
    fi
    
    printf "\n..check if we do have interesting darkoperator meterpreter scripts..\n"
    if [ ! -f "/opt/metasploit3/msf3/scripts/meterpreter/browserenum-dev.rb" ]; then
      cd /opt/metasploit3/msf3/scripts/meterpreter
      wget http://www.darkoperator.com/meterpreter/browserenum-dev.rb
    elif [ ! -f "/opt/metasploit3/msf3/scripts/meterpreter/disable_audit.rb" ]; then
      cd /opt/metasploit3/msf3/scripts/meterpreter
      wget http://www.darkoperator.com/meterpreter/disable_audit.rb
    elif [ ! -f "/opt/metasploit3/msf3/scripts/meterpreter/getcountermeasure.rb" ]; then
      cd /opt/metasploit3/msf3/scripts/meterpreter
      wget http://www.darkoperator.com/meterpreter/getcountermeasure.rb
    else
     printf "\n..looks okay...\n"
    fi
    
    cd /opt/metasploit3/msf3
    echo ""
    echo "######## ! DONE ! ########"
    echo ""
    
    exit 0

  6. #6
    Just burned his ISO BeNeDeLuX's Avatar
    Join Date
    Jan 2010
    Posts
    17

    Default Re: Metasploit Updaten

    Ich benutze Fasttrack dafür welches auch ein paar andere Programme noch auf den aktuellen stand bringt.
    ASUS UL30A / BT5 x64 with KDE on HDD of course!

  7. #7
    Just burned his ISO
    Join Date
    Sep 2010
    Posts
    1

    Default AW: Metasploit Updaten

    Hmm kann es sein das bei dem neusten fasttrack 4.0.1 , keine option mehr dabei ist andere sachen wie kismet etc.. gleich mit auf updates zu prüfen?

    und bei
    Code:
    root@bt:~# cd /pentest/exploits/framework3
    root@bt:/pentest/exploits/framework3# svn update
    svn: Failed to add file 'external/source/meterpreter/source/extensions/stdapi/server/fs/search.c': an unversioned file of the same name already exists
    root@bt:/pentest/exploits/framework3#
    kommt seit neusten immer dieser Fehler.. was könnt ich da falsch gemacht haben..
    hab soweit alles aktuallisiert und nutze bt4.1

  8. #8
    Just burned his ISO metacom's Avatar
    Join Date
    Jun 2008
    Posts
    14

    Default Re: Metasploit Updaten

    ich habe dasselbe problem ich habe die laptop 2 mal gelöst und neue installiert, update von metasploit immer dasselbe problem

  9. #9
    Just burned his ISO
    Join Date
    Apr 2010
    Posts
    11

    Default AW: Metasploit Updaten

    Moin,

    Quote Originally Posted by penor View Post
    und bei
    Code:
    root@bt:~# cd /pentest/exploits/framework3
    root@bt:/pentest/exploits/framework3# svn update
    svn: Failed to add file 'external/source/meterpreter/source/extensions/stdapi/server/fs/search.c': an unversioned file of the same name already exists
    root@bt:/pentest/exploits/framework3#
    kommt seit neusten immer dieser Fehler.. was könnt ich da falsch gemacht haben..
    hab soweit alles aktuallisiert und nutze bt4.1
    haste mal probiert, die Datei zu löschen und anschließend ein "svn update" auszuführen?
    SVN sollte an der Stelle merken, dass die Datei fehlt und sie aus dem Repo neu laden.

    -
    Andurin

Similar Threads

  1. metasploit
    By mmachine47 in forum OLD Newbie Area
    Replies: 9
    Last Post: 01-18-2010, 07:06 PM
  2. metasploit o non metasploit, questo è il problema!
    By eqweo in forum Discussioni Generali
    Replies: 2
    Last Post: 01-14-2010, 12:16 AM
  3. metasploit help
    By jake2891 in forum OLD Newbie Area
    Replies: 1
    Last Post: 12-10-2009, 08:47 PM
  4. Need help with Metasploit
    By dimaglez in forum OLD Newbie Area
    Replies: 6
    Last Post: 12-08-2008, 03:53 PM
  5. The New metasploit
    By streaker69 in forum OLD Newbie Area
    Replies: 4
    Last Post: 04-01-2008, 06:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •