Results 1 to 3 of 3

Thread: airbase-ng on intel 3945 - unable to ping

Threaded View

  1. #1
    Just burned his ISO mistm's Avatar
    Join Date
    May 2010
    Location
    Czech Republic
    Posts
    11

    Question airbase-ng on intel 3945 - unable to ping

    Hello everybody,

    I've spent last 4 hours by searching this forum and googling without any success.

    I have Thinkpad X61 with intel 3945 and updated backtrack 4 final. My goal is to make softap using airbase-ng. I went through lot of tutorials how to make fake ap so here are my steps:

    1) setup mon0
    Code:
    # airmon-ng start wlan0
    2) setup softap
    Code:
    # airbase-ng -e My_ssid mon0
    3) now I see broadcasting SSID of my AP and the interface at0 is created ..... so i bring it up
    Code:
    # ifconfig at0 up
    4) set ip:
    Code:
    # ifconfig at0 inet 10.0.0.1 netmask 255.255.255.0
    I connect with my phone to that AP and I set up its ip to 10.0.0.2.

    So now I should be able to ping 10.0.0.1 from my phone but I dont. Of course there are no firewalls and iptables are flushed.

    It looks like TCP/IP protocol doesnt work but for example BOOTP (which DHCP uses to communicate before it gives ip) is working because I can see that DHCP traffic:

    Code:
    root@bt:~# dhcpd3 -d -cf dhcpd.conf at0
    Internet Systems Consortium DHCP Server V3.1.1
    Copyright 2004-2008 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/sw/dhcp/
    Wrote 0 leases to leases file.
    Listening on LPF/at0/00:1c:bf:04:a8:8f/10.0.0/24
    Sending on   LPF/at0/00:1c:bf:04:a8:8f/10.0.0/24
    Sending on   Socket/fallback/fallback-net
    DHCPDISCOVER from 00:23:76:1d:f9:44 via at0
    DHCPOFFER on 10.0.0.100 to 00:23:76:1d:f9:44 (HTC49) via at0
    DHCPDISCOVER from 00:23:76:1d:f9:44 (HTC49) via at0
    DHCPOFFER on 10.0.0.100 to 00:23:76:1d:f9:44 (HTC49) via at0
    DHCPDISCOVER from 00:23:76:1d:f9:44 (HTC49) via at0
    DHCPOFFER on 10.0.0.100 to 00:23:76:1d:f9:44 (HTC49) via at0
    DHCPDISCOVER from 00:23:76:1d:f9:44 (HTC49) via at0
    DHCPOFFER on 10.0.0.100 to 00:23:76:1d:f9:44 (HTC49) via at0
    I am greatly thankful for any suggestion!

    Is it possible that the problem is that I am trying to connect with Windows mobile? Maybe normal laptop would work? What do you think?

    none knows? :-/

    I tried to connect with another laptop (Windows 7) and the situation is same. I attach tcpdump output when I am trying to connect. Obviously there IS some traffic - mostly UDP.

    Any suggestion is welcome.... if you know how send some trafic which would test out how it behaves tell me please. I went out of ideas. Thanks.
    File allegati File allegati
    Last edited by Archangel-Amael; 05-15-2010 at 07:29 AM.

Similar Threads

  1. airbase-ng duplicate response to ping
    By un2try in forum OLD Newbie Area
    Replies: 0
    Last Post: 06-25-2009, 03:22 PM
  2. Unable to connet Windows to airbase-ng
    By techjohnny in forum OLD Newbie Area
    Replies: 3
    Last Post: 02-27-2009, 01:10 AM
  3. BT3 and Intel 3945
    By TheKing in forum OLD Newbie Area
    Replies: 0
    Last Post: 07-09-2008, 10:47 PM
  4. Unable to ping other wireless device!!!
    By Armagedeon in forum OLD BT3beta Bugs and Fixes
    Replies: 4
    Last Post: 06-05-2008, 05:46 AM
  5. please help with intel 3945
    By Bassil in forum OLD Newbie Area
    Replies: 3
    Last Post: 07-12-2007, 02:21 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •