Results 1 to 2 of 2

Thread: Removed NTFS > Moved /sda4 to the left > BROKE GRUB SETTINGS! HELP!

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    4

    Default Removed NTFS > Moved /sda4 to the left > BROKE GRUB SETTINGS! HELP!

    Long story short my NTFS Drive was infected with a nasty rootkit and I decided to do away with it. Later down the line I wanted to reallocate the freespace to the BT partition, since the NTFS partition was on the 1st cylinder and separated from the reiserfs partition by an ext2 boot and swap I could not do that without deleting both the ext2 and swap and starting them at the first cylinder. 9 Hours later I have a partition that looks like so...

    Device Boot Start End Blocks Id System
    /dev/sda1 1 32 257008+ 83 Linux
    /dev/sda2 33 542 4096575 82 Linux swap / Solaris
    /dev/sda4 543 30401 239842417+ 83 Linux

    I booted from my USB and ran:

    root@bt:~# mkdir /mnt/bt4
    root@bt:~# mount /dev/sda4 /mnt/bt4
    root@bt:~# mkdir /mnt/bt4/boot
    mkdir: cannot create directory `/mnt/bt4/boot': File exists
    root@bt:~# mount /dev/sda1 /mnt/bt4/boot
    root@bt:~# mkdir /mnt/bt4/{dev,mnt,tmp,proc,sys}
    root@bt:~# mount -t proc proc /mnt/bt4/proc/
    root@bt:~# mount -o bind /dev /mnt/bt4/dev/
    root@bt:~# chroot /mnt/bt4/ /bin/bash
    root@bt:/# nano /boot/grub/menu.lst

    Here is a copy of the menu.lst


    Timeout 30 #The number of seconds GRUB should wait before booting an OS
    default 0 #The entry which should be booted by default
    fallback 1 #The entry which should be booted in the event of the first one fail$

    splashimage=(hd0,0)/grub/bt4.xpm.gz

    title BT4 Final
    root (hd0,0) # Boot Partition
    kernel /vmlinuz-2.6.30.9 root=/dev/sda4 rw vga=0x317
    initrd /initrd.img-2.6.30.9


    makeactive
    chainloader +1

    Somewhere in the process of all this it screwed up the GRUB bootloader. How do I go from here and make it so it will boot /dev/sda4 clean from /dev/sda1?
    Last edited by Port3024; 05-11-2010 at 06:21 PM.

  2. #2
    My life is this forum Barry's Avatar
    Join Date
    Jan 2010
    Posts
    3,817

    Default Re: Removed NTFS > Moved /sda4 to the left > BROKE GRUB SETTINGS! HELP!

    Reformat and start over. Easiest way.

Similar Threads

  1. ettercap help [moved]
    By roonie in forum OLD Newbie Area
    Replies: 4
    Last Post: 10-17-2009, 09:44 PM
  2. Added GNOME, removed KDE, but a few problems...
    By ansabhailte in forum OLD Latest Public Release - BackTrack4 Beta
    Replies: 12
    Last Post: 04-21-2009, 08:39 PM
  3. Accidentally removed part of the /usr directory!
    By -=lux=- in forum OLD Newbie Area
    Replies: 5
    Last Post: 06-06-2008, 10:13 AM
  4. Forums Moved, general announcements
    By muts in forum OLD Announcements
    Replies: 6
    Last Post: 07-08-2007, 09:02 AM
  5. ntfs-3g to mount NTFS partitions safely
    By toony in forum OLD Feature requests
    Replies: 3
    Last Post: 05-07-2007, 05:56 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •