Hi everyone,
I was trying to compile Kontroller Lab and got the following error when running the ./configure script

Code:
checking for KDE... configure: error:
in the prefix, you've chosen, are no KDE headers installed. This will fail.
So, check this please and use another prefix!
I figured it was because i didn't have the dev tools so i tried to install kdelibs-dev from the repositories and got the following broken package error.

Code:
apt-get install kdelibs-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting kdelibs4-dev instead of kdelibs-dev
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  kdelibs4-dev: Depends: kdelibs4c2a (= 4:3.5.10-0ubuntu6.2) but 4:3.5.100~0ubuntu1 is to be installed
                Depends: libarts1-dev (>= 1.5.0) but it is not going to be installed
E: Broken packages
I also tried installing kdelibs4-dev and got a similar error. I'm not sure if installing kdelibs5-dev is a good idea because afaik it's for KDE4. If I try to do that, it tries to install lots of dependencies and I have a feeling I'll break things.

Note: I've found a .deb for Kontroller Lab but still think it would be very helpful to be able to compile KDE apps.