Results 1 to 4 of 4

Thread: bt4-final Installation Fails at Grub Install (94%)

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    May 2010
    Posts
    3

    Unhappy bt4-final Installation Fails at Grub Install (94%)

    After downloading bt4-final.iso, md5 checksumming it, booting the KDE desktop and using the install.sh provided on the desktop, I'm attempting to install Backtrack 4 Final to my Macbook 2,1 hard drive on sda5. I want to install the grub bootloader to sda5 as well, since want to retain my current rEFIt bootloader. So far, doing this on sda3 with Ubuntu 10.04 works great, but Backtrack fails every time at the grub install step.

    My partition scheme:
    sda1: 209 mb boot partition (for the mac EFI boot)
    sda2: 59284mb hfs+ (Mac OS 10.6)
    free space 134mb
    sda3: 19999mb ext3 (Ubuntu 10.04)
    sda4: 29999mb ntfs (Windows XP Pro)
    sda5: 7999mb ext3 (for Backtrack 4 final)
    sda6: 2406mb swap

    I configured the partitioner to load sda3 as '/Ubuntu', sda4 as '/WinXPPro' and sda5 as '/'.
    Then I configured the boot loader to be installed on '/dev/sda5', because I want to retain my current bootloader setup.
    It failes at 94% at "/dev/sda5 grub-install".
    The effor message is as follows:

    Installer crashed
    We're sorry; the installer crashed. Please file a new bug report at https://launchpad.net/ubuntu/+source/ubiquity/+filebug (do not attach your details to any existing bug) and a developer will attend to the problem as soon as possible. To help the developers understand what went wrong, include the following detail in your bug report, and attach the files /var/log/syslog and /var/log/partman:

    Traceback (most recent call last):
    File "/usr/lib/ubiquity/bin/ubiquity", line 229, in <module>
    main()
    File "/usr/lib/ubiquity/bin/ubiquity", line 224, in main
    install(args[0])
    File "/usr/lib/ubiquity/bin/ubiquity", line 68, in install
    ret = wizard.run()
    File "/usr/lib/ubiquity/ubiquity/frontend/gtk_ui.py", line 437, in run
    self.progress_loop()
    File "/usr/lib/ubiquity/ubiquity/frontend/gtk_ui.py" line 831, in progress_loop
    (ret,realtb))
    RuntimeError: Install failed with exit code 1
    Traceback (most recent call last):
    File "/usr/share/ubiquity/install.py", line 2112, in <module>
    install.run()
    File "/usr/share/ubiquity/install.py, line 428, in run
    self.configure_bootloader()
    File "/usr/share/ubiquity/install.py", line 1599, in configure_bootloader
    "GrubInstaller failed with code %d" % ret)
    InstallStepError: GrubInstaller failed with code 1

    Please help!

  2. #2
    Just burned his ISO
    Join Date
    Apr 2010
    Posts
    7

    Default Re: bt4-final Installation Fails at Grub Install (94%)

    this is a ubiquity bug that needs to be patched/updated by the developers of backtrack4 as ubiquity itself has already been updated ...

  3. #3
    Just burned his ISO
    Join Date
    May 2010
    Posts
    3

    Default Re: bt4-final Installation Fails at Grub Install (94%)

    Could I simply download and run the grub install boot disk and install grub on /dev/sda5? Would that work since ubiquity has already installed everything else? I've never run just a grub install/repair - so I'd need a little help with that.

    What are my options from here? I still would like to run BT4 from my local HDD.

    Thanks!

  4. #4
    Just burned his ISO
    Join Date
    May 2010
    Posts
    3

    Default Re: bt4-final Installation Fails at Grub Install (94%)

    What are my options at this point? Could I create a grub install boot disk and run the command: "/dev/sda5 grub-install" ? I already have an installation of grub2 on sda3 with lucid lynx (ubuntu 10.04).

    It seems like it failed on the very last step - I'm just not well versed enough with ubiquity/debian/backtrack to know what the best course of action is here.

    Any suggestions welcome!!

    Thanks!

Similar Threads

  1. Replies: 5
    Last Post: 02-16-2010, 01:03 AM
  2. BT4 Pre-Final to eee 701 4G SSD Install Fails
    By frankenberry in forum OLD BackTrack 4 NON working hardware
    Replies: 8
    Last Post: 08-18-2009, 06:16 PM
  3. installation on GPT disk (GUID) fails (BT4 pre final)
    By blackdir in forum OLD BackTrack 4 Bugs and Fixes
    Replies: 1
    Last Post: 07-28-2009, 08:21 AM
  4. Replies: 11
    Last Post: 09-12-2007, 07:16 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •