Results 1 to 4 of 4

Thread: AR5009 assistance or advice using BackTrack 4

Hybrid View

  1. #1
    Junior Member
    Join Date
    Apr 2010
    Posts
    26

    Default AR5009 assistance or advice using BackTrack 4

    I have to stop and ask this question after reading around the net. There seems to be a bunch of conflicting responses as to whether or not the Atheros AR5009 drivers are in the BT4 final. I see no evidence - either way - in the hardware list forum.

    I have been struggling with BT4 final on a USB and using the Atheros AR5009 chip.

    Can someone definitively inform me IF the AR5009 needed drivers are resident in the BT4 final? My experience shows they are not fully developed, but I could really use some experienced members here to chime in.

    There are tons of threads around the net with people at a loss for the AR5009 atheros chip, and its used on a bunch of laptops.



    My frustration stems from being soooooo close but the machine will not inject and I am almost certain that the AR5009 is the culprit.

    Hopefully a Mod will OK my post/thread so a bunch of us using AR5009's can get our answer.

    I will do anything reasonable to get this working. If I have to do a complete install I will, but even there I don't see any significant support for the AR5009's.

    Assistance please????

  2. #2
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default Re: AR5009 assistance or advice using BackTrack 4

    Well let's see a printout of an lspci or lsusb, not to mention ifconfig.
    Then we can help you better.

  3. #3
    Junior Member
    Join Date
    Apr 2010
    Posts
    26

    Default Re: AR5009 assistance or advice using BackTrack 4

    I am attaching the lspci -v and iwconfig reports as requested. The lspci is kind of long so I only pasted in the section pertaining to the network controller.

    Please note that the AR928X adapter is seen. I don't know how to interpret this report but from a newbie viewpoint I see section [100] shows an advanced error report, along with section [160] showing no device serial number.

    The kernel driver and kernel modules show to be using ath9k which is what it is supposed to indicate.


    I hope this report shows something to you members with linux sage, because its over my head. I am reading and studying every day and continuing my struggle.



    Can anyone here make some sense out of these reports and give me steer ---- PLEASE???
    File allegati File allegati

  4. #4
    Junior Member
    Join Date
    Apr 2010
    Posts
    26

    Default Re: AR5009 assistance or advice using BackTrack 4

    Well I have beat myself up long enough on this.

    Newbie here. After reading around for like 30 hours I have come to understand that IF I want wireless capabilities I need to get a USB wireless card anyway. I will be running in VM and the atheros on the motherboard will not work for full wireless in that mode. There is no sense in manipulating the drivers if I even can, only to end up with injecting successfully but nowhere to go afterward.

    I should have read the sticky sooner talking about the NEED for a USB wireless card if the user (ME) is going to be using Backtrack from VM or virtual.

    I ordered a new genuine awus036h 1000mw card. Should be here middle of next week and then I'll go from there.

    Sounds like its almost plug and play out of the box for the basics. Although I am planning on running VM as my mode, but I do have one question just for a super basic starting point to make sure the wireless card works properly when I get it:

    If I insert my USB bootable BT 4 flash, which I already have working, will it see the awus036h automatically during boot if they are both plugged in as the machine boots?

    I don't want to run in this mode for long, but it would be a way to make sure the card is working and not broken. Meantime I will be working on doing my homework for setting up the VM ware.

    I would appreciate an answer to my question regarding the "automatic" detection of my card during boot.

    Thanks.

Similar Threads

  1. Atheros AR5009 802.11a/g/n WiFi Adapter help
    By dtddemon in forum OLD BackTrack 4 General Support
    Replies: 2
    Last Post: 07-22-2009, 11:59 AM
  2. Atheros AR5009 not working
    By Erjon in forum OLD Bt4beta Non-Working Hardware
    Replies: 3
    Last Post: 04-28-2009, 10:53 AM
  3. AR5009 will it ever see support in BT
    By bigbadlou in forum OLD BT3final Support
    Replies: 1
    Last Post: 04-05-2009, 03:18 PM
  4. Social Engineering with backtrack - assistance needed
    By williamc in forum OLD BT3final Support
    Replies: 2
    Last Post: 10-01-2008, 11:19 AM
  5. Need Advice! - Backtrack & ubuntu
    By KeaperGrave in forum OLD Newbie Area
    Replies: 9
    Last Post: 09-23-2008, 10:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •