Results 1 to 2 of 2

Thread: Nexpose Postgresql error

Hybrid View

  1. #1
    Junior Member WolverineOD's Avatar
    Join Date
    Apr 2010
    Location
    Infront of Screen
    Posts
    28

    Default Nexpose Postgresql error

    Hello.

    When starting Nexpose (cd to dir, ./nsc.sh) I get this postgresql error:

    Code:
    DaemonMgr   5/2/10 10:11 AM: Starting WebServer
    NSC         5/2/10 10:11 AM: Web server subsystem initialized
    httpd       5/2/10 10:11 AM: bringing up SSL and initializing components...
    Scheduler   5/2/10 10:11 AM: initializing...
    DaemonMgr   5/2/10 10:11 AM: Starting NexposeScheduler
    NSC         5/2/10 10:11 AM: Scheduler subsystem initialized
    NSC         5/2/10 10:11 AM: Initializing administrative alerters
    NSC         5/2/10 10:11 AM: initializing log rotation
    NSC         5/2/10 10:11 AM: Initializing update engine
    NSC         5/2/10 10:11 AM: Cleaning up temporary NeXpose files
    AU-AAD241F855/2/10 10:11 AM: initializing update engine for AAD241F857610BDEDDC35                                                                            03B2D0A56CEE6867499...
    AU-AAD241F855/2/10 10:11 AM: Checking for approved updates...
    AU-AAD241F855/2/10 10:11 AM: No approved updates found for processing
    AU-AAD241F855/2/10 10:11 AM: Started auto-update...
    AU-AAD241F855/2/10 10:11 AM: Establishing HTTP connection with updates.rapid7.com via proxy (updates.rapid7.com:80)...
    httpd       5/2/10 10:14 AM: NSC/0.6.4 (JVM) bound to port 3780 and running...
    AU-AAD241F855/2/10 10:14 AM: Checking for approved updates...
    AU-AAD241F855/2/10 10:14 AM: No approved updates found for processing
    NSC         5/2/10 10:14 AM: Initializing postgresql database manager for //127.0.0.1:5433/nexpose...
    postgresql  5/2/10 10:14 AM: Starting up postgresql DB system
    postgresql  5/2/10 10:14 AM: Nexpose PostgreSQL service status: 0
    postgresql  5/2/10 10:14 AM:    Nexpose PostgreSQL service status: 0
    postgresql  5/2/10 10:14 AM:    Nexpose PostgreSQL service status: 0
    postgresql  5/2/10 10:14 AM:    Nexpose PostgreSQL service status: 0
    "Nexpose PostgreSQL service status: 0" loops until I get this error:

    Code:
    NSC         5/2/10 10:15 AM: Database initialization failed : java.sql.SQLException: Error starting PostgreSQL: com.rapid7.os.OSException: Could not start the nxpgsql daemon
            at com.rapid7.nexpose.datastore.A.K.E(Unknown Source)
            at com.rapid7.nexpose.datastore.n.H(Unknown Source)
            at com.rapid7.nexpose.datastore.n.E(Unknown Source)
            at com.rapid7.nexpose.datastore.n.E(Unknown Source)
            at com.rapid7.nexpose.nsc.NSC.U(Unknown Source)
            at com.rapid7.nexpose.nsc.NSC.?(Unknown Source)
            at com.rapid7.nexpose.nsc.NSC.?(Unknown Source)
            at com.rapid7.nexpose.nsc.NSC.run(Unknown Source)
            at com.rapid7.nexpose.nsc.NSC.main(Unknown Source)
    Caused by: com.rapid7.os.OSException: Could not start the nxpgsql daemon
            at com.rapid7.nexpose.datastore.A.K.A(Unknown Source)
            ... 9 more
      SQLState=null, errorCode=0
    
    
    > httpd       5/2/10 10:15 AM: Shutting down socket...
    httpd       5/2/10 10:15 AM: I/O problem fetching client socket: Socket closed
    httpd       5/2/10 10:15 AM: Shutting down thread pool...
    After which the apache server is restarted, is opened on port 3780 and finishes the script.

    I have followed the steps here:
    Code:
    http://www.noahjaehnert.com/2009/12/help-nexpose-and-backtrack-4-could-not-start-the-nxpgsql-daemon
    But to no avail. And i have also tried reinstalling following the guide at Archangel-Amaels Blog:
    Code:
    http://archangelamael.blogspot.com/2009/12/installing-nexpose-in-back-track-4.html
    but again to no avail. I did have Nexpose working for 2 days originally before this error started occuring, and after exhausting my google-fu I am reverting back here in hope that someone has a solution to my problem. Any Help would be appreciated. Cheers

  2. #2
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default Re: Nexpose Postgresql error

    Go to the nexpose community wiki and join their mailing list. There you will find experts who can help you with this.
    The turn around rate is about 24 hours or less. Just submit an email to the list with the above info.
    Also if you have updated to different versions of software packages then what is default in BT and or used different versions of Nexpose then it may not work.

    http://community.rapid7.com/redmine/...s/nexpose/wiki

Similar Threads

  1. apt-get upgrade: Fehler bzgl postgresql-8.3
    By cleguevara in forum Software support
    Replies: 4
    Last Post: 01-13-2010, 08:55 AM
  2. Nexpose Error Messed with Kmenu Backtrack
    By Wolfheart in forum OLD BackTrack 4 Software Related Issues
    Replies: 0
    Last Post: 12-12-2009, 04:41 AM
  3. errore: postgresql-8.3
    By xanders in forum Supporto Software
    Replies: 10
    Last Post: 11-21-2009, 09:34 AM
  4. Error with Postgresql after recent dist-upgrade
    By imported_davehardy20 in forum OLD BackTrack 4 Bugs and Fixes
    Replies: 15
    Last Post: 11-20-2009, 10:23 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •