Hello,
although that this is my first post I have a big Problem.
A while ago i bought the. You can find informations about it here.
Al over the net it is written that it has a RT3070 chip inside. When I put it into my PC, it is a sun virtual box machine with back track 4 final, It is recognized and loaded properly with the backtrack built in rt3070sta.ko driver from "/lib/modules/2.6.30.9/kernel/drivers/net/wireless". when I fire the device (ra0) up every thing is working fine. The stick recognizes about 8 Accespoints.


The first thing, which is mysterious to me is that it has a noise level of -159Db. On the Net I found two people which said two different things about these number. the one said it is a good to have this value so "high" and the other person said this is the last values you can connect the hotspot, if it is "higher" the connection will get lost. This is what I don´t understand. Who's right?


When i type iwconfig output is:
<... Cut some out ...>

Code:
ra0 RT2870 Wireless ESSID:"" Nickname:""
Mode:Auto Frequency=2.412 GHz
Link Quality=10/100 Signal level:0 dBm Noise level:-143 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
Why does it say RT2870? I thought this is a complete other driver! and when I do lsmod it says:
Module Size Used by
rt3070sta 509260 0
<...>
And there is nowere a rt2870.

When I type Airmon-ng start ra0 it says:

Code:
Interface Chipset Driver

ra0 Ralink 2560 PCI rt2500 (monitor mode enabled)
What this programm sasy is the third meaning about the Wlan chip. Now it is a Ralink 2560 and has a rt2500 driver?!

When I type iwconfig it says:

Code:
ra0 RT2870 Wireless ESSID:"" Nickname:"RT2870STA"
Mode:Monitor Frequency=2.432 GHz Bit Rate=1 Mb/s 
RTS thrff Fragment thrff
Encryption keyff
Link Quality=10/100 Signal level:0 dBm Noise level:-115 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
<...>
What In my eays says that monitor mode is activated!

But airodump-ng finds no Acces Point at this Point! Before the monitor mode it found 8!

I don´t know what to do now I googled the last days for an solutions, but found nothing what helped me.

Thank you for your help!!!

P.s.: Sorry for my English but its not my native Language.