Results 1 to 3 of 3

Thread: BCM43xx can not be work under BT4 final after update drivers

  1. #1
    Just burned his ISO
    Join Date
    Mar 2010
    Posts
    24

    Default BCM43xx can not be work under BT4 final after update drivers

    before
    Code:
    b43 ssb0:0: firmware: requesting b43/ucode13.fw
    b43 ssb0:0: firmware: requesting b43/b0g0initvals13.fw
    b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
    Registered led device: b43-phy0::tx
    Registered led device: b43-phy0::rx
    Registered led device: b43-phy0::radio
    b43-phy0: Radio turned on by software
    after updated compat-wireless-2010-04-XX
    could not be work. both ar9170usb & ath9k
    like wn821n & wn722n
    Code:
    ./scripts/gen-compat-autoconf.sh config.mk > include/linux/compat_autoconf.h
    make -C /lib/modules/2.6.30.9/build M=/root/compat-wireless-2.6.34-rc4 modules
    make[1]: Entering directory `/usr/src/linux-source-2.6.30.9'
    
      WARNING: Symbol version dump /usr/src/linux-source-2.6.30.9/Module.symvers
               is missing; modules will have no dependencies and modversions.
    /lib/modules/2.6.30.9/kernel/net/wireless/wl.ko
    FATAL: Error inserting b43 (/lib/modules/2.6.30.9/updates/drivers/net/wireless/b43/b43.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    ....
    make -C /lib/modules/2.6.30.9/build M=/root/compat-wireless-2.6.34-rc4 modules
    make[1]: Entering directory `/usr/src/linux-source-2.6.30.9'
    
      WARNING: Symbol version dump /usr/src/linux-source-2.6.30.9/Module.symvers
               is missing; modules will have no dependencies and modversions.
    
    .......
     INSTALL /root/compat-wireless-2.6.34-rc4/net/wireless/lib80211_crypt_wep.ko
      DEPMOD  2.6.30.9
    make[1]: Leaving directory `/usr/src/linux-source-2.6.30.9'
    Updating Ubuntu's initramfs for 2.6.31-wl under /boot/ ...
    Cannot find /lib/modules/2.6.31-wl
    Will now run update-grub to ensure grub will find the new initramfs ...
    Searching for GRUB installation directory ... found: /boot/grub
    Searching for default file ... found: /boot/grub/default
    Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
    Searching for splash image ... found: /boot/grub/splash.xpm.gz
    Found kernel: /boot/vmlinuz-2.6.30.9
    Found kernel: /boot/memtest86+.bin
    Updating /boot/grub/menu.lst ... done
    
    depmod will prefer updates/ over kernel/ -- OK!
    
    FATAL: Module at76_usb not found.
    Loading mwl8k...
    Loading mac80211_hwsim...
    Loading at76c50x_usb...
    Loading bluetooth...
    Loading btusb...
    Loading l2cap...
    Loading sco...
    Loading hidp...
    Loading rfcomm...
    Loading bnep...
    Module ath_pci not detected -- this is fine
    ath5k loaded successfully
    ath9k loaded successfully
    Module bcm43xx not detected -- this is fine
    Module wl not detected -- this is fine
    FATAL: Error inserting b43 (/lib/modules/2.6.30.9/updates/drivers/net/wireless/b43/b43.ko): Unknown symbol in module, or unknown parameter (see dmesg)

  2. #2
    Just burned his ISO
    Join Date
    Apr 2010
    Posts
    1

    Default Re: BCM43xx can not be work under BT4 final after update drivers

    bcm43xx boards dont support packet injection
    but you can install it following this AUR (en) - broadcom-wl

  3. #3
    Just burned his ISO
    Join Date
    Mar 2010
    Posts
    24

    Default

    and check this (/lib/modules/2.6.30.9/updates/drivers/net/wireless/b43/b43.ko) doesn't exist

    the dmesg
    Code:
    root@bt:/# modprobe ar9170usb
    root@bt:/# dmesg |grep ar9170usb
    usbcore: registered new interface driver ar9170usb
    root@bt:/# modprobe b43
    FATAL: Error inserting b43 (/lib/modules/2.6.30.9/updates/drivers/net/wireless/b43/b43.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    root@bt:/# dmesg |grep b43
    b43: Unknown symbol ssb_pmu_set_ldo_paref
    b43: Unknown symbol ssb_pmu_set_ldo_voltage
    b43: Unknown symbol ssb_chipco_gpio_control
    b43: Unknown symbol ssb_bus_sdiobus_register
    b43: Unknown symbol ssb_bus_pcmciabus_register
    b43: Unknown symbol ssb_pmu_set_ldo_paref
    b43: Unknown symbol ssb_pmu_set_ldo_voltage
    b43: Unknown symbol ssb_chipco_gpio_control
    b43: Unknown symbol ssb_bus_sdiobus_register
    b43: Unknown symbol ssb_bus_pcmciabus_register
    root@bt:/# modprobe ath9k_htc
    root@bt:/# dmesg |grep ath9k_htc
    root@bt:/# modprobe ath9k
    root@bt:/# dmesg | grep ath9k
    usbcore: registered new interface driver ath9k_hif_usb
    root@bt:/#
    Last edited by Archangel-Amael; 04-26-2010 at 08:48 AM.

Similar Threads

  1. Did my Update/Upgrade Work?
    By rayj00 in forum OLD BackTrack 4 Software Related Issues
    Replies: 1
    Last Post: 11-22-2009, 03:47 PM
  2. X11 doesnt work after update
    By imported_masteroc in forum OLD BT3beta Software related issues
    Replies: 20
    Last Post: 04-11-2008, 06:07 PM
  3. what the heck! cant get hostap drivers to work
    By renizer in forum OLD BackTrack v2.0 Final
    Replies: 2
    Last Post: 06-06-2007, 09:17 AM
  4. NVIDIA 3d drivers work easy with BT2 final
    By imported_aliosity in forum OLD BackTrack v2.0 Final
    Replies: 2
    Last Post: 05-04-2007, 03:47 AM
  5. how to apt get update ? and ati drivers ?
    By Kloro in forum OLD Newbie Area
    Replies: 2
    Last Post: 05-02-2007, 10:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •