Results 1 to 3 of 3

Thread: Nessus 4.2.2 and Metasploit v3.3.4

  1. #1
    Just burned his ISO hanc2006's Avatar
    Join Date
    Feb 2009
    Location
    Swiss
    Posts
    2

    Default Nessus 4.2.2 and Metasploit v3.3.4

    Hy guys,
    I have problems to import nessus xml report scan in metasploit framework.
    I have installed the new nessus 4.2.2 version and when I try to import the report file with db_import_nessus_xml I receive this error:

    msf > db_import_nessus_xml /root/xxx.nessus
    [-] Error while running command db_import_nessus_xml: undefined local variable or method `file_contents' for #<Msf.DBManager:0xb7330bdc>

    Call stack:
    /opt/metasploit3/msf3/lib/msf/core/db.rb:1185:in `import_nessus_xml'
    /opt/metasploit3/msf3/lib/msf/core/db.rb:1203:in `import_nessus_xml_file'
    /opt/metasploit3/msf3/lib/msf/ui/console/command_dispatcher/db.rb:886:in `cmd_db_import_nessus_xml'
    /opt/metasploit3/msf3/lib/rex/ui/text/dispatcher_shell.rb:239:in `send'
    /opt/metasploit3/msf3/lib/rex/ui/text/dispatcher_shell.rb:239:in `run_command'
    /opt/metasploit3/msf3/lib/rex/ui/text/dispatcher_shell.rb:201:in `run_single'
    /opt/metasploit3/msf3/lib/rex/ui/text/dispatcher_shell.rb:195:in `each'
    /opt/metasploit3/msf3/lib/rex/ui/text/dispatcher_shell.rb:195:in `run_single'
    /opt/metasploit3/msf3/lib/rex/ui/text/shell.rb:144:in `run'
    ./msfconsole:92


    I save the xml report in nessus version 1 because the version 2 is not already supported by metasploit framework.

    Any idea?
    Thx!

  2. #2
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default Re: Nessus 4.2.2 and Metasploit v3.3.4

    Since nessus is not included in BT you will likely have or get better support from either metasploit or nessus.

  3. #3
    Just burned his ISO hanc2006's Avatar
    Join Date
    Feb 2009
    Location
    Swiss
    Posts
    2

    Default Re: Nessus 4.2.2 and Metasploit v3.3.4

    I have solved!
    This bug affects only pre-installed version of metasploit in backtrack 4. With fastrack update the problem will be resolved!

    Thx :)

Similar Threads

  1. Using Nessus and/or Nexpose together with metasploit
    By imported_Warlord711 in forum OLD Pentesting
    Replies: 1
    Last Post: 02-03-2010, 04:46 AM
  2. Nessus
    By .rtkd in forum Tool Requests
    Replies: 10
    Last Post: 01-19-2010, 05:35 AM
  3. Nessus 3.0
    By macamba in forum OLD Tutorials and Guides
    Replies: 43
    Last Post: 03-16-2009, 07:21 PM
  4. Importing Nessus NBE scans into Metasploit
    By snorty mcsnort in forum OLD Newbie Area
    Replies: 0
    Last Post: 01-27-2009, 09:38 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •