Results 1 to 2 of 2

Thread: Teste de vulnerabilidades com OpenVAS 3.0 - parte 1

Threaded View

  1. #1
    Moderator firebits's Avatar
    Join Date
    Mar 2010
    Location
    Brazil
    Posts
    353

    Lightbulb Teste de vulnerabilidades com OpenVAS 3.0 - parte 1

    A nova versão do ótimo scanner de vulnerabilidades, OpenVAS 3.0, já está disponível. Ainda não há ports para árvores de várias distros como Debian, Ubuntu e outras, mas há o código-fonte, do qual qualquer distro pode aceitar a compilação. No processo de Pentesting, uma das etapas é "teste de vulnerabilidades", para na sequência "teste de ataques", por exemplo com o Metaspolit Framework.

    Esta é mais um artigo sobre OpenVAS. Como todo mundo sabe, há o projeto Backtrack Brasil, onde você também pode achar este artigo com mais detalhes ainda. Vou me concentrar no Ubuntu 9.10, pois está aqui no nosso Pentesting LAB em uma máquina virtual, para testarmos, mas a técnica é similar nas outras distros. Não testamos em outras distros ainda e até convido os membros do Viva o Linux e Backtrack Brasil a fazerem isso. Aqueles que gostariam de aproveitar OpenVAS 3 podem esperar as seguintes novas funcionalidades:
    • A nova arquitetura interna dos módulos
    • NVT Meta informação que está livre de limites de tamanho arbitrário
    • Suporte a IPv6
    • suporte a clientes WMI
    • Suporta próximas extensões opcionais:
      * OpenVAS Manager para armazenar e organizar exames em um servidor central em um Banco de dados SQL
      * OpenVAS Administrador de Usuário, Feed-e Configurações de Gestão
      * Greenbone Segurança Assistent para uma versão web-based Vulnerability Management


    Você pode ler mais sobre ele no site oficial OpenVAS, que é www.openvas.org. Agora, vamos para as coisas boas.

    As instruções a seguir são para fazer o OpenVAS 3 funcionar no Ubuntu 9.10.

    Pré-requisitos

    Primeiro precisamos instalar todos os pacotes dependentes:

    $ sudo apt-get install build-essencial libgnutls libpcap0.8-dev-dev bison libglib2.0-dev libgpgme11 libssl-dev-dev cmake

    Depois de ter instalado os pacotes, precisamos fazer o download dos arquivos necessários para OpenVAS. Os links abaixo podem ser ultrapassados devido a constante atualização, logo certifique-se de obter a versão mais recente.

    $ cd /tmp
    $ wget
    http://wald.intevation.org/frs/downl...s-3.0.3.tar.gz
    $ wget http://wald.intevation.org/frs/downl...r-3.0.1.tar.gz

    Agora que baixamos os arquivos necessários, devemos compilar e instalar os pacotes na seguinte ordem:

    1. openvas-libraries
    2. openvas-scanner

    Instalar OpenVAS Libraries (bibliotecas do OpenVAS)

    Comece por descompactar openvas-libraries e depois compile/instale:

    $ tar -xvf openvas-libraries-3.0.3.tar.gz
    $ cd openvas-libraries-3.0.3/
    $ sudo ./configure
    $ sudo make
    $ sudo make install


    Se tudo correr bem aqui, então você deve receber uma mensagem dizendo que o openvas-libraries foi instalado. Se por algum motivo você receber uma mensagem dizendo que gpgme não foi instalado, tente o seguinte:

    $ sudo apt-get install libgpgme11-dev

    Instalar OpenVAS Scanner

    Em seguida descompacte o openvas-scanner e depois compile/instale:

    $ cd ..
    $ tar -xvf openvas-scanner-3.0.1.tar.gz
    $ cd openvas-scanner-3.0.1/
    $ sudo ./configure
    $ sudo make
    $ sudo make install


    As bibliotecas do OpenVAS e o scanner devem agora ser instaladas.

    Temos que nos certificar de que o /usr/local/bin e /usr/local/sbin estão em nosso PATH. Podemos fazer isso digitando:

    $ echo ${PATH}

    Na saída do comando acima você deve ver /usr/local/bin e /usr/local/sbin em algum lugar. Senão você terá que adicionar as entradas para a variável PATH do ambiente manualmente, veja neste link:


    Se a sua variável PATH do ambiente está correta e funcionando, então você pode construir os links para as novas bibliotecas:

    $ sudo ldconfig

    Gerar um Certificado

    Agora estamos prontos para gerar um certificado para o nosso OpenVAS Server e certifique-se de adicionar valores relevantes para a sua localização.

    $ sudo openvas-mkcert

    Siga as instruções na tela e insira as informações apropriadas quando solicitado.

    Artigo Próprio do firebits
    http://www.backtrack-linux.org/forum.../firebits.html
    Last edited by firebits; 04-17-2010 at 04:22 PM.

Similar Threads

  1. NeXpose --- Escaner de Vulnerabilidades
    By šØrτĦacK in forum BT Videos - ES
    Replies: 4
    Last Post: 04-05-2010, 07:09 PM
  2. Vulnerabilidades del cifrado WEP
    By ANTRAX-LABS in forum Soporte en Wireless
    Replies: 0
    Last Post: 12-11-2009, 04:30 PM
  3. Nessus or OpenVas
    By hawaii67 in forum OLD Pentesting
    Replies: 4
    Last Post: 02-19-2009, 05:28 AM
  4. No OpenVAS ?
    By robert_larsen in forum OLD BT4beta Software Related Issues
    Replies: 3
    Last Post: 02-13-2009, 09:45 AM
  5. OpenVAS in BackTrack3
    By _kost in forum OLD Newbie Area
    Replies: 5
    Last Post: 01-27-2009, 03:30 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •