Results 1 to 4 of 4

Thread: kernel 2.6.30-7 y driver de video nvidia

  1. #1
    Junior Member
    Join Date
    Dec 2009
    Posts
    29

    Unhappy kernel 2.6.30-7 y driver de video nvidia

    buenas! desde que instale este kernel no me funciona el video con el driver nvidia y antes de esta actualización funcionaba....
    con solo instalar el paquete nvidia-driver, BT me instalaba solo el driver de video, ahora lo instala pero cuando hago startx me dice que no encuentra ese modulo, probé con el el kernel 2.6.30-5 y tampoco.
    pero con el kernel 2.6.29 o 28.... no me acuerdo funciona bien el video aunque tiene algunos problemas con el acpi, que se solucionan con pci=noacpi pero es incomodo

    bueno, si alguien tuvo el mismo problema y lo soluciono espero que me extienda una mano...


    este es un lspci del hardware que tengo

    [hackmaf@athlon64x2 ~]$ lspci
    00:00.0 RAM memory: nVidia Corporation MCP67 Memory Controller (rev a2)
    00:01.0 ISA bridge: nVidia Corporation MCP67 ISA Bridge (rev a2)
    00:01.1 SMBus: nVidia Corporation MCP67 SMBus (rev a2)
    00:01.2 RAM memory: nVidia Corporation MCP67 Memory Controller (rev a2)
    00:01.3 Co-processor: nVidia Corporation MCP67 Co-processor (rev a2)
    00:02.0 USB Controller: nVidia Corporation MCP67 OHCI USB 1.1 Controller (rev a2)
    00:02.1 USB Controller: nVidia Corporation MCP67 EHCI USB 2.0 Controller (rev a2)
    00:04.0 USB Controller: nVidia Corporation MCP67 OHCI USB 1.1 Controller (rev a2)
    00:04.1 USB Controller: nVidia Corporation MCP67 EHCI USB 2.0 Controller (rev a2)
    00:06.0 IDE interface: nVidia Corporation MCP67 IDE Controller (rev a1)
    00:07.0 Audio device: nVidia Corporation MCP67 High Definition Audio (rev a1)
    00:08.0 PCI bridge: nVidia Corporation MCP67 PCI Bridge (rev a2)
    00:09.0 IDE interface: nVidia Corporation MCP67 AHCI Controller (rev a2)
    00:0a.0 Ethernet controller: nVidia Corporation MCP67 Ethernet (rev a2)
    00:0c.0 PCI bridge: nVidia Corporation MCP67 PCI Express Bridge (rev a2)
    00:0d.0 PCI bridge: nVidia Corporation MCP67 PCI Express Bridge (rev a2)
    00:12.0 VGA compatible controller: nVidia Corporation C67 [GeForce 7000M / nForce 610M] (rev a2)
    00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
    00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
    00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
    00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
    03:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)


    .
    .
    .
    hackmaf

  2. #2
    Just burned his ISO
    Join Date
    Nov 2009
    Posts
    3

    Default

    Prueba con

    Siendo usuario root, lo primero es poner al día el repositorio de paquetes para tener la ultima version de estos:

    apt-get update

    Ahora instalamos los paquetes necesarios:

    apt-get install nvidia-kernel-common
    apt-get install nvidia-glx
    apt-get install nvidia-settings

    nvidia-setting no es realmente necesario, pero no es grande y nos permite activar cosas como el antialiasing fácilmente.
    Instalados los paquetes vamos a decirle al sistema que utilice nvidia:

    modprobe nvidia
    update-modules

    Y que carge el módulo de nvidia al arrancar. Para ello hay que editar el archivo /etc/modules y añadir al final una linea que diga: nvidia
    Utilizando nano:

    nano /etc/modules

    Mi archivo queda:

    # /etc/modules: kernel modules to load at boot time.
    #
    # This file should contain the names of kernel modules that are
    # to be loaded at boot time, one per line. Comments begin with
    # a "#", and everything on the line after them are ignored.



    sd_mod
    psmouse
    mousedev
    ide-cd
    ide-disk
    ide-generic
    lp
    nvidia

    Ahora solo falta decirle al sistema grafico que carge el modulo de nvidia. Para ello debemos editar el archivo /etc/X11/XF86Config-4 y buscar la linea donde dice:

    driver "nv"

    y sustituirla por:

    driver "nvidia"

    En mi caso queda:

    Section "Device"
    Identifier "NVIDIA Corporation NV28 [GeForce4 Ti 4200 AGP 8x]"
    Driver "nvidia"
    BusID "PCI:1:0:0"
    EndSection

    Al reiniciar el sistema ya deberiamos tener funcionando todo y nos saldra la patalla de nvidia al arrancar el entorno grafico.





    Por último, y aunque no tiene que ver con la instalación de los drivers, decir que la instalación automática no asigna bien los valores de refresco del monitor en las X. Se pueden cambiar fácilmente los parámetros en /etc/X11/XF86Config-4 en la sección Section "Monitor".



    En mi caso:

    Section "Monitor"
    Identifier "Monitor genérico"
    HorizSync 31-71
    VertRefresh 50-140
    Option "DPMS"
    EndSection

  3. #3
    Junior Member
    Join Date
    Dec 2009
    Posts
    29

    Thumbs up ya esta!

    ya esta! se soluciono con guardar el archivo xorg.conf antes de actualizar el kernel, el problema esta en la autoconfiguracion del archivo xorg.conf , este es el que deje ahora y funciona a la perfección.

    Code:
    root@athlon64x2bt:~# cat /etc/X11/xorg.conf
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # Note that some configuration settings that could be done previously
    # in this file, now are automatically configured by the server and settings
    # here are ignored.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Device"
            Identifier      "Configured Video Device"
            driver          "nvidia"
    EndSection
    
    Section "Monitor"
            Identifier      "Configured Monitor"
    EndSection
    
    Section "Screen"
            Identifier      "Default Screen"
            Monitor         "Configured Monitor"
            Device          "Configured Video Device"
    EndSection

  4. #4
    Just burned his ISO
    Join Date
    Feb 2010
    Posts
    5

    Default Re: ya esta!

    saludos

    hermanos me esta pasando algo con las interfaces no me reconoce ninguna esto fue despues de darle el upgrade y no tengo ni idea de configurar el xorg.conf para nvidia me podrian ayudar con esto aki les dejo mi xorg.conf

    estas son mis interfaces.

    01:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)
    02:00.0 Ethernet controller: Attansic Technology Corp. Atheros AR8132 / L1c Gigabit Ethernet Adapter (rev c0)
    ´´´´´´´´´´´´´´´´´´´´´´´´´´´´´´´´´´´´´´´´´´´´´´´´´´ ´´´´´´´´´´´´´´´´´´´´´´

    XORG.CONF --- # File generated by xf86config - Xorg.conf nvidia - f76CV0Df - Pastebin.com


    gracias de ante mano

    paz.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •